- Update to 1.0.r4.3

- Add knob WITH_XINE (vs mplayer)

PR:		ports/102277
Submitted by:	Nicola Vitale (maintainer)
This commit is contained in:
Ion-Mihai Tetcu 2006-09-04 09:16:42 +00:00
parent 2d6c8a770b
commit ca4fa15387
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=172161
6 changed files with 39 additions and 17 deletions

View File

@ -6,11 +6,11 @@
#
PORTNAME= tunapie
PORTVERSION= 1.0.r3
PORTVERSION= 1.0.r4.3
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION:S|.r3|_rc3|}
DISTNAME= ${PORTNAME}_${PORTVERSION:S|.r4.3|-rc4-3|}
MAINTAINER= nivit@email.it
COMMENT= Tuner for streaming internet radio and TV
@ -18,24 +18,35 @@ COMMENT= Tuner for streaming internet radio and TV
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
${PYTHON_SITELIBDIR}/${WX_PYTHON_DIR}/wxPython/_wx.py:${PORTSDIR}/x11-toolkits/py-wxPython26 \
streamripper:${PORTSDIR}/audio/streamripper \
xine:${PORTSDIR}/multimedia/xine \
xmms:${PORTSDIR}/multimedia/xmms
NO_BUILD= yes
USE_PYTHON= yes
OPTIONS= ADULT "non-censored TV listings" off
OPTIONS= ADULT "non-censored TV listings" off \
XINE "use xine instead of mplayer" off
MAN1= tunapie.1
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,^${PREFIX}/,,}"
WRKSRC= ${WRKDIR}/${DISTNAME:C/-rc4-3$/_rc4/}
FIND_FILES= -type f -and \( -name "install.sh" -or -name "*.py" \)
post-patch:
cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
cd ${WRKSRC} && ${FIND} . ${FIND_FILES} -exec ${REINPLACE_CMD} \
-e 's|%%DATADIR%%|${DATADIR}|g'\
-e 's|%%X11BASE%%|${X11BASE}|g'\
-e 's|%%DESKTOPDIR%%|${DESKTOPDIR}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
-e 's|%%MANPREFIX%%|${MANPREFIX}|g' \
-e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%VIDEOPLAYER%%|${VIDEOPLAYER}|g' \
-e 's|%%X11BASE%%|${X11BASE}|g' \
-e 's|wxversion.select("2.6")|wxversion.select("${WX_PYTHON_DIR:S/^wx-//g}")|g' {} \;
do-install:
${MKDIR} ${DATADIR}
${MKDIR} ${DESKTOPDIR}
cd ${WRKSRC} && ./install.sh ${ADULT_TVLIST}
.include <bsd.port.pre.mk>
@ -44,6 +55,14 @@ do-install:
ADULT_TVLIST= --adult
.endif
.if defined(WITH_XINE)
RUN_DEPENDS+= xine:${PORTSDIR}/multimedia/xine
VIDEOPLAYER= ${X11BASE}/bin/xine
.else
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
VIDEOPLAYER= ${LOCALBASE}/bin/mplayer
.endif
.if defined(WITH_UNICODE) && (${OSVERSION} > 500000)
WX_PYTHON_DIR= wx-2.6-gtk2-unicode
.else

View File

@ -1,3 +1,3 @@
MD5 (tunapie_1.0_rc3.tar.gz) = b92d0929cbddd0a7252ba49d8e5646ba
SHA256 (tunapie_1.0_rc3.tar.gz) = bc22079b6e486853588c81029e08d827c649a1b9914b721c73010e394e069e95
SIZE (tunapie_1.0_rc3.tar.gz) = 39147
MD5 (tunapie_1.0-rc4-3.tar.gz) = 849390775274b5cc6b31e8cc7dfd11cb
SHA256 (tunapie_1.0-rc4-3.tar.gz) = 9792a1a960f3ddf2094b45c5aedc7b6cc239570bb4902ebcb1316afff36b2476
SIZE (tunapie_1.0-rc4-3.tar.gz) = 41982

View File

@ -1,7 +1,6 @@
$FreeBSD$
--- install.sh Sun Jul 2 10:49:31 2006
+++ install.sh.port Tue Jul 4 14:10:42 2006
@@ -3,7 +3,7 @@
--- install.sh Thu Aug 17 09:17:10 2006
+++ install.sh.port Sun Sep 3 17:24:54 2006
@@ -3,9 +3,7 @@
else cp src/tunersafe.py src/tuner.py
fi
python src/compile
@ -9,7 +8,9 @@ $FreeBSD$
-rm -rf /usr/local/share/tunapie
-mkdir /usr/local/share/tunapie
-cp src/*.py src/*.pyc src/*.jpg /usr/local/share/tunapie
-cp tunapie.1 /usr/local/man/man1
-cp tunapie.desktop /usr/local/share/applications
+cp tunapie %%PREFIX%%/bin
+#rm -rf /usr/local/share/tunapie
+mkdir %%DATADIR%%
+cp src/*.py src/*.pyc src/*.jpg %%DATADIR%%
+cp tunapie.1 %%MANPREFIX%%/man/man1
+cp tunapie.desktop %%DESKTOPDIR%%

View File

@ -10,7 +10,7 @@ $FreeBSD$
- self.term='/usr/bin/x-terminal-emulator'
- self.ripper='/usr/bin/streamripper -t -u winamp2 -o never'
+ self.mediaplayer='%%X11BASE%%/bin/xmms'
+ self.videoplayer='%%X11BASE%%/bin/xine'
+ self.videoplayer='%%VIDEOPLAYER%%'
+ self.term='%%X11BASE%%/bin/xterm'
+ self.ripper='%%LOCALBASE%%/bin/streamripper -t -u winamp2 -o never'
self.rdir=self.home+'/.tunapie/streamripper'

View File

@ -14,7 +14,7 @@
self.videopath = wx.TextCtrl(id=wxID_PREFERENCESVIDEOPATH,
name='videopath', parent=self, pos=wx.Point(168, 48),
- size=wx.Size(200, 22), style=0, value='/usr/bin/mplayer')
+ size=wx.Size(200, 22), style=0, value='%%X11BASE%%/bin/xine')
+ size=wx.Size(200, 22), style=0, value='%%VIDEOPLAYER%%')
self.videopath.SetFont(wx.Font(7, 77, wx.NORMAL, wx.NORMAL, False,
u'Sans'))
self.videopath.SetBackgroundColour(wx.Colour(255, 253, 239))

View File

@ -23,4 +23,6 @@ bin/tunapie
%%DATADIR%%/tuneradult.pyc
%%DATADIR%%/tunersafe.py
%%DATADIR%%/tunersafe.pyc
%%DESKTOPDIR%%/tunapie.desktop
@dirrm %%DATADIR%%
@dirrmtry share/applications