- Update to 5.1.4
- Add LICENSE - Add regression tests
This commit is contained in:
parent
a7ef7f9657
commit
c9c5c37375
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424274
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= giflib
|
||||
PORTVERSION= 5.1.3
|
||||
PORTVERSION= 5.1.4
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= SF/${PORTNAME}
|
||||
@ -10,7 +10,10 @@ MASTER_SITES= SF/${PORTNAME}
|
||||
MAINTAINER= portmgr@FreeBSD.org
|
||||
COMMENT= Tools and library routines for working with GIF images
|
||||
|
||||
CONFLICTS= libungif-[0-9]*
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
TEST_DEPENDS= ghead:sysutils/coreutils
|
||||
|
||||
USES= tar:bzip2 libtool
|
||||
GNU_CONFIGURE= yes
|
||||
@ -20,6 +23,7 @@ OPTIONS_DEFINE= DOCBOOK DOCS
|
||||
OPTIONS_SUB= yes
|
||||
DOCBOOK_DESC= Generate API documentation (requires DOCS)
|
||||
INSTALL_TARGET= install-strip
|
||||
TEST_TARGET= check-TESTS
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (giflib-5.1.3.tar.bz2) = 5096d27805283599b01074d487ad3f8e02bd26b84d759b9017be876ca3d5b81d
|
||||
SIZE (giflib-5.1.3.tar.bz2) = 639420
|
||||
TIMESTAMP = 1476601913
|
||||
SHA256 (giflib-5.1.4.tar.bz2) = df27ec3ff24671f80b29e6ab1c4971059c14ac3db95406884fc26574631ba8d5
|
||||
SIZE (giflib-5.1.4.tar.bz2) = 639703
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/dgif_lib.c.orig 2016-01-07 10:44:44 UTC
|
||||
--- lib/dgif_lib.c.orig 2016-04-02 15:34:00 UTC
|
||||
+++ lib/dgif_lib.c
|
||||
@@ -41,6 +41,9 @@ static int DGifDecompressInput(GifFileTy
|
||||
static int DGifBufferedInput(GifFileType *GifFile, GifByteType *Buf,
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/Makefile.in.orig 2016-01-07 12:54:02 UTC
|
||||
--- lib/Makefile.in.orig 2016-04-02 15:36:45 UTC
|
||||
+++ lib/Makefile.in
|
||||
@@ -134,7 +134,7 @@ am__installdirs = "$(DESTDIR)$(libdir)"
|
||||
LTLIBRARIES = $(lib_LTLIBRARIES)
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- lib/gif_lib.h.orig 2016-01-07 12:51:53 UTC
|
||||
--- lib/gif_lib.h.orig 2016-04-02 15:35:30 UTC
|
||||
+++ lib/gif_lib.h
|
||||
@@ -244,9 +244,6 @@ extern ColorMapObject *GifUnionColorMap(
|
||||
GifPixelType ColorTransIn2[]);
|
||||
|
24
graphics/giflib/files/patch-tests_makefile
Normal file
24
graphics/giflib/files/patch-tests_makefile
Normal file
@ -0,0 +1,24 @@
|
||||
--- tests/makefile.orig 2014-05-16 10:46:53 UTC
|
||||
+++ tests/makefile
|
||||
@@ -27,7 +27,7 @@ rebuild: render-rebuild \
|
||||
UTILS = ../util
|
||||
PICS = ../pic
|
||||
|
||||
-GIFS := $(shell ls ../pic/*.gif)
|
||||
+GIFS := `ls ../pic/*.gif`
|
||||
|
||||
# Test decompression and rendering by unpacking images,
|
||||
# converting them to RGB, and comparing that result to a check file.
|
||||
@@ -103,10 +103,10 @@ giffilter-regress:
|
||||
|
||||
giffix-rebuild:
|
||||
@echo "Rebuilding giffix test."
|
||||
- @head --bytes=-20 <$(PICS)/treescap.gif | $(UTILS)/giffix 2>/dev/null | $(UTILS)/gifbuild -d >giffixed.ico
|
||||
+ @ghead --bytes=-20 <$(PICS)/treescap.gif | $(UTILS)/giffix 2>/dev/null | $(UTILS)/gifbuild -d >giffixed.ico
|
||||
giffix-regress:
|
||||
@echo "giffix: Testing giffix behavior"
|
||||
- @head --bytes=-20 <$(PICS)/treescap.gif | $(UTILS)/giffix 2>/dev/null | $(UTILS)/gifbuild -d | diff -u giffixed.ico -
|
||||
+ @ghead --bytes=-20 <$(PICS)/treescap.gif | $(UTILS)/giffix 2>/dev/null | $(UTILS)/gifbuild -d | diff -u giffixed.ico -
|
||||
|
||||
gifinto-regress:
|
||||
@echo "gifinto: Checking behavior on short files."
|
Loading…
Reference in New Issue
Block a user