- Update to 0.9.2

- Stage support
- Add LICENSE
- Convert to PYDISTUTILS_AUTOPLIST

PR:		189369
Submitted by:	Muhammad Moinur Rahman <5u623l20@gmail.com>
This commit is contained in:
Wen Heping 2014-05-11 13:19:46 +00:00
parent f2cacbe752
commit c999f7756d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=353682
4 changed files with 7 additions and 1539 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= obspy
PORTVERSION= 0.8.4
PORTREVISION= 3
PORTVERSION= 0.9.2
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -11,6 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wen@FreeBSD.org
COMMENT= Python framework for seismological observatories
LICENSE= LGPL3
BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.6.0:${PORTSDIR}/science/py-scipy \
${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib \
@ -20,11 +21,12 @@ BUILD_DEPENDS= ${PYNUMPY} \
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= fortran zip
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_AUTOPLIST= yes
PYEASYINSTALL_ARCHDEP= yes
NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s#FC#${FC}#g" ${WRKSRC}/setup.py

View File

@ -1,2 +1,2 @@
SHA256 (obspy-0.8.4.zip) = 6e9e0a5c0e673ae41d64ca265d4abdadf2b83a60ff27c516a8dbb0e2b38965cf
SIZE (obspy-0.8.4.zip) = 9783983
SHA256 (obspy-0.9.2.zip) = 9c5be30398fbe620ce467d676b04996468fa7d85160e3d65e8eb39d724435f92
SIZE (obspy-0.9.2.zip) = 11650367

View File

@ -1,30 +0,0 @@
--- ./setup.py.orig 2013-06-28 18:07:26.000000000 -0300
+++ ./setup.py 2013-11-27 17:04:07.589319517 -0200
@@ -27,7 +27,6 @@
from distutils.unixccompiler import UnixCCompiler
from setuptools import find_packages, setup
from setuptools.extension import Extension
-import distribute_setup
import glob
import os
import platform
@@ -370,8 +369,8 @@
# otherwise we just use the original compile method
UnixCCompiler.linker_so = None
return self._original_compile(obj, src, *args, **kwargs)
- UnixCCompiler.linker_so = ["gfortran"]
- self.compiler_so = ["gfortran"]
+ UnixCCompiler.linker_so = ["gfortran46"]
+ self.compiler_so = ["gfortran46"]
cc_args = ['-c', '-fno-underscoring']
cc_args.append('-fPIC')
try:
@@ -629,8 +628,6 @@
def setupPackage(gfortran=True, ccompiler=True):
- # automatically install distribute if the user does not have it installed
- distribute_setup.use_setuptools()
# use lib2to3 for Python 3.x
if sys.version_info[0] == 3:
convert2to3()

File diff suppressed because it is too large Load Diff