MFH: r555541

astro/siril: Fix run-time error: Undefined symbol "cblas_dcopy"

This was because math/gsl installs 2 libraries, libgsl.so and
libgslcblas.so, the former of which should depend on the latter one.
Instead, the gsl package through its pkg-config script asks users to
link to both libraries. This fails when the link line also has
-Wl,--as-needed which causes the linker to drop the second library.
In such case the above error is triggered at runtime.

Also update WWW.

PR:		251206
Submitted by:	Ned Leitch <ned.leitch+freebsd@gmail.com>

Approved by:	ports-secteam (fluffy)
This commit is contained in:
Yuri Victorovich 2020-11-19 07:39:41 +00:00
parent d9057e3b3d
commit c983066ac4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q4/; revision=555693
4 changed files with 12 additions and 12 deletions

View File

@ -2,6 +2,7 @@
PORTNAME= siril
DISTVERSION= 0.99.6
PORTREVISION= 1
CATEGORIES= astro graphics
MASTER_SITES= https://free-astro.org/download/

View File

@ -1,11 +0,0 @@
--- Makefile.am.orig 2019-05-27 09:16:07 UTC
+++ Makefile.am
@@ -21,7 +21,7 @@ scripts_DATA = scripts/DSLR_preprocessing.ssf \
3rdparty/scripts/en/DSLR_Preprocessing_NoFlat_NoDark.ssf \
3rdparty/scripts/en/DSLR_Preprocessing_NoFlat.ssf
-doc_DATA = AUTHORS \
+#doc_DATA = AUTHORS \
LICENSE.md
man_MANS = siril.1.gz

View File

@ -0,0 +1,10 @@
--- meson.build.orig 2020-09-22 20:01:48 UTC
+++ meson.build
@@ -123,6 +123,7 @@ if platform_linux
elif platform_bsd
siril_link_arg += '-rdynamic'
siril_link_arg += '-lexecinfo'
+ siril_link_arg += '-Wl,--no-as-needed' # workaround for https://gitlab.com/free-astro/siril/-/issues/614 (Bug#251206)
elif platform_windows
#TODO: Do Meson provide more elegant way?
siril_link_arg += '-Wl,--export-all-symbols'

View File

@ -8,4 +8,4 @@ interface than Iris' command line as well as more modern and powerful processing
algorithms, but it is not yet as automated as DeepSkyStacker or Registax. It
also provides a basic command line to access various processing functions.
WWW: https://free-astro.org/index.php/Siril
WWW: https://www.siril.org/