rename most cases of jakarta- to apache-

The Apache Softare Foundation used to maintain an umbrella project named
Jakarta but it was retired on 2011. This name now conflicts with the new
name for Java EE under the Eclipse Foundation.

Rename most of the packages to be more consistent. Some other packages remain
but they will require intervention by their corresponding maintainers.

Approved by:	thierry (mentor), makc
Differential Revision:	https://reviews.freebsd.org/D21902
This commit is contained in:
Pedro F. Giffuni 2019-10-06 19:08:14 +00:00
parent bbc7901e66
commit c937a4ccc9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=513899
64 changed files with 197 additions and 97 deletions

13
MOVED
View File

@ -13054,3 +13054,16 @@ x11/xtrap||2019-10-01|Deprecated upstream
security/softhsm|security/softhsm2|2019-10-04|Has expired: End-of-life announced, update to softhsm2 ASAP.
net/asterisk15|net/asterisk16|2019-10-04|Has expired: Asterisk 15.x will reach EOL on 2019-10-03. Please migrate to net/asterisk16
x11-wm/fvwm|x11-wm/fvwm2|2019-10-06|Has expired: Unfetchable, unmaintained, unsupported upstream
databases/jakarta-commons-dbutils|databases/apache-commons-dbutils|2019-10-06|Renamed upstream
devel/jakarta-commons-configuration|devel/apache-commons-configuration|2019-10-06|Renamed upstream
devel/jakarta-commons-io|devel/apache-commons-io|2019-10-06|Renamed upstream
devel/jakarta-commons-jxpath|devel/apache-commons-jxpath|2019-10-06|Renamed upstream
devel/jakarta-commons-modeler|devel/apache-commons-modeler|2019-10-06|Renamed upstream
java/jakarta-commons-cli|apache-commons-cli|2019-10-06|Renamed upstream
java/jakarta-commons-collections|java/apache-commons-collections|2019-10-06|Renamed upstream
java/jakarta-commons-lang|apache-commons-lang|2019-10-06|Renamed upstream
java/jakarta-commons-logging|java/apache-commons-logging|2019-10-06|Renamed upstream
java/jakarta-commons-primitives|java/apache-commons-primitives|2019-10-06|Renamed upstream
lang/jakarta-commons-jelly|lang/apache-commons-jelly|2019-10-06|Renamed upstream
net/jakarta-commons-net|net/apache-commons-net|2019-10-06|Renamed upstream
textproc/jakarta-commons-digester|textproc/apache-commons-digester|2019-10-06|Renamed upstream

View File

@ -15,6 +15,7 @@
SUBDIR += adodb
SUBDIR += adodb5
SUBDIR += akonadi
SUBDIR += apache-commons-dbutils
SUBDIR += apq
SUBDIR += apq-mysql
SUBDIR += apq-odbc
@ -113,7 +114,6 @@
SUBDIR += ipa_sdb
SUBDIR += iplike
SUBDIR += isql-viewer
SUBDIR += jakarta-commons-dbutils
SUBDIR += jasperreports
SUBDIR += jdb
SUBDIR += jdbc-oracle11g

View File

@ -5,7 +5,7 @@ PORTNAME= commons-dbutils
PORTVERSION= 1.7
CATEGORIES= databases java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org

View File

@ -124,6 +124,10 @@
SUBDIR += antlr3
SUBDIR += antlr4
SUBDIR += apache-ant
SUBDIR += apache-commons-configuration
SUBDIR += apache-commons-io
SUBDIR += apache-commons-jxpath
SUBDIR += apache-commons-modeler
SUBDIR += apache-rat
SUBDIR += aphpbreakdown
SUBDIR += aphpunit
@ -1026,11 +1030,7 @@
SUBDIR += itext
SUBDIR += ivykis
SUBDIR += iz
SUBDIR += jakarta-commons-configuration
SUBDIR += jakarta-commons-daemon
SUBDIR += jakarta-commons-io
SUBDIR += jakarta-commons-jxpath
SUBDIR += jakarta-commons-modeler
SUBDIR += jam
SUBDIR += jansson
SUBDIR += java-findbugs

View File

@ -5,7 +5,7 @@ PORTNAME= commons-configuration
PORTVERSION= 1.10
CATEGORIES= devel java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org
@ -15,7 +15,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \
${JAVALIBDIR}/commons-lang.jar:java/jakarta-commons-lang \
${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}

View File

@ -7,12 +7,17 @@ Configuration parameters may be loaded from the following sources:
* Properties files
* XML documents
* Windows INI files
* Property list files (plist)
* JNDI
* JDBC Datasource
* System properties
* Applet parameters
* Servlet parameters
Different configuration sources can be mixed using a ConfigurationFactory and
CompositeConfiguration. Additional sources of configuration parameters can be
created by using custom configuration objects. This customization can be
achieved by extending AbstractConfiguration.
WWW: http://jakarta.apache.org/commons/configuration/
WWW: http://commons.apache.org/proper/commons-configuration/

View File

@ -5,7 +5,7 @@ PORTNAME= commons-io
PORTVERSION= 2.6
CATEGORIES= devel java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= makc@FreeBSD.org

View File

@ -5,9 +5,11 @@ PORTNAME= commons-jxpath
PORTVERSION= 1.3
CATEGORIES= devel www java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
LICENSE= APACHE20
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities for manipulating Java Beans using the XPath syntax

View File

@ -3,4 +3,4 @@ expression language called XPath. JXPath applies XPath expressions to
graphs of objects of all kinds: JavaBeans, Maps, Servlet contexts, DOM
etc, including mixtures thereof.
WWW: http://jakarta.apache.org/commons/jxpath/
WWW: http://commons.apache.org/proper/commons-jxpath/

View File

@ -3,14 +3,15 @@
PORTNAME= commons-modeler
PORTVERSION= 2.0.1
PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
MAINTAINER= ports@FreeBSD.org
COMMENT= Mechanisms to create Model MBeans compatible with JMX specification
LICENSE= APACHE20
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes

View File

@ -15,4 +15,4 @@ information. The Modeler component is designed to make this process fairly pain
Model MBean to be supported. In addition, Modeler provides a factory mechanism
to create the actual Model MBean instances themselves.
WWW: http://jakarta.apache.org/commons/modeler/
WWW: https://commons.apache.org/dormant/commons-modeler/

View File

@ -3,7 +3,7 @@
PORTNAME= charva
PORTVERSION= 1.1.4
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= devel java
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}
@ -12,7 +12,7 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= Java Windowing Toolkit for Text Terminals
BUILD_DEPENDS= gmake:devel/gmake
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
BROKEN_armv6= fails to compile: build.xml: compilation failed
BROKEN_armv7= fails to compile: build.xml: compilation failed

View File

@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
PORTREVISION= 0
PORTREVISION= 1
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
@ -232,8 +232,8 @@ CONFIGURE_ARGS+= --enable-symbols
.endif
.if ${PORT_OPTIONS:MREPORT_BUILDER} || ${PORT_OPTIONS:MWIKI_PUBLISHER}
BUILD_DEPENDS+= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
RUN_DEPENDS+= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
BUILD_DEPENDS+= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
RUN_DEPENDS+= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
CONFIGURE_ARGS+= --with-commons-logging-jar=${JAVALIBDIR}/commons-logging.jar
.else
CONFIGURE_ARGS+= --without-commons-logging

View File

@ -3,6 +3,11 @@
COMMENT = Java language support
SUBDIR += apache-commons-cli
SUBDIR += apache-commons-collections
SUBDIR += apache-commons-lang
SUBDIR += apache-commons-logging
SUBDIR += apache-commons-primitives
SUBDIR += aparapi
SUBDIR += avis
SUBDIR += berkeley-db
@ -39,17 +44,12 @@
SUBDIR += jai
SUBDIR += jakarta-bcel
SUBDIR += jakarta-commons-beanutils
SUBDIR += jakarta-commons-cli
SUBDIR += jakarta-commons-codec
SUBDIR += jakarta-commons-collections
SUBDIR += jakarta-commons-dbcp
SUBDIR += jakarta-commons-discovery
SUBDIR += jakarta-commons-httpclient
SUBDIR += jakarta-commons-lang
SUBDIR += jakarta-commons-lang3
SUBDIR += jakarta-commons-logging
SUBDIR += jakarta-commons-pool
SUBDIR += jakarta-commons-primitives
SUBDIR += jakarta-oro
SUBDIR += jakarta-regexp
SUBDIR += jasmin

View File

@ -3,10 +3,9 @@
PORTNAME= commons-cli
PORTVERSION= 1.4
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org

View File

@ -0,0 +1,4 @@
The Apache Commons CLI library provides a simple and easy to use
API for working with the command line arguments and options.
WWW: http://commons.apache.org/proper/commons-cli/

View File

@ -5,16 +5,19 @@ PORTNAME= commons-collections
PORTVERSION= 3.2.1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= makc@FreeBSD.org
COMMENT= Classes that extend/augment the Java Collections Framework
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
LICENSE= APACHE20
USES= dos2unix
USE_JAVA= yes
JAVA_VERSION= 8+
USE_ANT= yes
DOS2UNIX_GLOB= Multi*.java Test*.java
ALL_TARGET= jar

View File

@ -1,2 +1,3 @@
TIMESTAMP = 1570206793
SHA256 (commons-collections-3.2.1-src.tar.gz) = 9a4a800cb7ecdaf3b6f608cd608682b88b506f1b1c4b727d15471ae3329fc63d
SIZE (commons-collections-3.2.1-src.tar.gz) = 609930

View File

@ -1,6 +1,6 @@
--- src/java/org/apache/commons/collections/MultiHashMap.java
--- src/java/org/apache/commons/collections/MultiHashMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/MultiHashMap.java
@@ -331,21 +331,21 @@ public class MultiHashMap extends HashMap implements MultiMap {
@@ -331,21 +331,21 @@ public class MultiHashMap extends HashMap implements M
* @param item the value to remove
* @return the value removed (which was passed in), null if nothing removed
*/
@ -26,8 +26,7 @@
}
/**
--- src/java/org/apache/commons/collections/MultiMap.java
--- src/java/org/apache/commons/collections/MultiMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/MultiMap.java
@@ -66,7 +66,7 @@ public interface MultiMap extends Map {
* @throws ClassCastException if the key or value is of an invalid type
@ -47,8 +46,7 @@
/**
* Gets a collection containing all the values in the map.
--- src/java/org/apache/commons/collections/map/MultiKeyMap.java
--- src/java/org/apache/commons/collections/map/MultiKeyMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/map/MultiKeyMap.java
@@ -197,7 +197,7 @@ public class MultiKeyMap
* @param key2 the second key
@ -76,10 +74,9 @@
}
/**
--- src/java/org/apache/commons/collections/map/MultiValueMap.java
--- src/java/org/apache/commons/collections/map/MultiValueMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/map/MultiValueMap.java
@@ -153,19 +153,19 @@ public class MultiValueMap extends AbstractMapDecorator implements MultiMap {
@@ -153,19 +153,19 @@ public class MultiValueMap extends AbstractMapDecorato
* @param value the value to remove
* @return the value removed (which was passed in), null if nothing removed
*/
@ -103,10 +100,9 @@
}
/**
--- src/test/org/apache/commons/collections/TestMultiHashMap.java
--- src/test/org/apache/commons/collections/TestMultiHashMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/test/org/apache/commons/collections/TestMultiHashMap.java
@@ -464,11 +464,11 @@ public class TestMultiHashMap extends AbstractTestMap {
@@ -464,11 +464,11 @@ public class TestMultiHashMap extends AbstractTestMap
map.put("A", "AA");
map.put("A", "AB");
map.put("A", "AC");
@ -123,10 +119,9 @@
assertEquals(new MultiHashMap(), map);
}
--- src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
--- src/test/org/apache/commons/collections/map/TestMultiKeyMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
@@ -315,10 +315,10 @@ public class TestMultiKeyMap extends AbstractTestIterableMap {
@@ -315,10 +315,10 @@ public class TestMultiKeyMap extends AbstractTestItera
switch (key.size()) {
case 2:
assertEquals(true, multimap.containsKey(key.getKey(0), key.getKey(1)));
@ -139,6 +134,3 @@
assertEquals(false, multimap.containsKey(key.getKey(0), key.getKey(1)));
break;
case 3:
--
2.5.0

View File

@ -1,12 +1,11 @@
A suite of classes that extend or augment the Java Collections Framework.
There are certain holes left unfilled by Sun's implementations, and the
Jakarta-Commons Collections Component strives to fulfill them. Among the
features of this package are:
Commons-Collections seek to build upon the JDK classes by providing new interfaces, implementations and utilities. There are many features,
including:
Special-purpose implementations of Lists and Maps for fast access Adapter
classes from Java1-style containers (arrays, enumerations) to Java 2-style
collections. Methods to test or create typical set-theory properties of
collections such as union, intersection, and closure.
WWW: http://jakarta.apache.org/commons/collections/
WWW: http://commons.apache.org/proper/commons-collections/

View File

@ -5,11 +5,11 @@ PORTNAME= commons-lang
PORTVERSION= 2.6
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Jakarta library with helper utilities for the java.lang API
COMMENT= Apache library with helper utilities for the java.lang API
LICENSE= APACHE20

View File

@ -10,4 +10,4 @@ enum type, an exception structure that supports multiple types of
nested-Exceptions and a series of utlities dedicated to help with
building methods, such as hashCode, toString and equals.
WWW: http://jakarta.apache.org/commons/lang/
WWW: http://commons.apache.org/proper/commons-lang/

View File

@ -5,7 +5,7 @@ PORTNAME= commons-logging
PORTVERSION= 1.2
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= makc@FreeBSD.org

View File

@ -1,2 +1,3 @@
TIMESTAMP = 1570207571
SHA256 (commons-logging-1.2-bin.tar.gz) = 3f758805c7290d9c6d22d1451587c9f7232744aef4c984e88aa683cdea0587bd
SIZE (commons-logging-1.2-bin.tar.gz) = 315429

View File

@ -1,4 +1,4 @@
Jakarta Commons Logging library.
Apache Commons Logging library.
There is a great need for debugging and logging information inside of Commons
components such as HTTPClient and DBCP. However, there are many logging APIs
@ -9,4 +9,4 @@ libraries. Commons components may use the Logging API to remove compile-time
and run-time dependencies on any particular logging package, and contributors
may write Log implementations for the library of their choice.
WWW: http://jakarta.apache.org/commons/logging/
WWW: http://commons.apache.org/proper/commons-logging/

View File

@ -3,15 +3,16 @@
PORTNAME= commons-primitives
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= java
MASTER_SITES= APACHE_COMMONS_SOURCE
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Library supporting Java primitive types
LICENSE= APACHE20
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes

View File

@ -1,4 +1,4 @@
Apache Jakarta Commons Primitives provides a collection of types and utilities
Apache Commons Primitives provides a collection of types and utilities
optimized for working with Java primitives (boolean, byte, char, double, float,
int, long, short). Generally, the Commons-Primitives classes are faster,
smaller and easier to work with than their purely Object based alternatives.
@ -6,4 +6,4 @@ smaller and easier to work with than their purely Object based alternatives.
Currently Commons Primitives is primarily composed of implementations of the
java.util collections adapted for the primitive types.
WWW: http://jakarta.apache.org/commons/primitives
WWW: http://commons.apache.org/dormant/commons-primitives/

View File

@ -3,6 +3,7 @@
PORTNAME= commons-beanutils
PORTVERSION= 1.9.2
PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
PKGNAMEPREFIX= jakarta-
@ -13,10 +14,10 @@ COMMENT= JavaBeans utility library
LICENSE= APACHE20
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-collections.jar:java/jakarta-commons-collections
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-collections.jar:java/jakarta-commons-collections
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
USES= dos2unix
USE_JAVA= yes

View File

@ -1,4 +0,0 @@
The Jakarta Commons CLI library provides a simple and easy to use
API for working with the command line arguments and options.
WWW: http://jakarta.apache.org/commons/cli/

View File

@ -3,7 +3,7 @@
PORTNAME= commons-httpclient
DISTVERSION= 3.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= java www
MASTER_SITES= APACHE/httpcomponents/${PORTNAME}/source
PKGNAMEPREFIX= jakarta-
@ -14,9 +14,9 @@ COMMENT= Package implementing the client side of the HTTP standard
LICENSE= APACHE20
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
BUILD_DEPENDS+= ${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
RUN_DEPENDS+= ${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec
OPTIONS_DEFINE= DOCS

View File

@ -7,4 +7,6 @@ libraries from ORO, Inc. (www.oroinc.com). They have been donated to
the Jakarta Project by Daniel Savarese (www.savarese.org), the
copyright holder of the ORO libraries.
As of 2010-09-01, the ORO project is retired.
WWW: http://jakarta.apache.org/oro/

View File

@ -1,3 +1,5 @@
A 100% Pure Java Regular Expression package by Jonathan Locke.
As of 2011-04-17, the Regexp project is retired.
WWW: http://jakarta.apache.org/regexp/

View File

@ -11,6 +11,7 @@
SUBDIR += alchemist.el
SUBDIR += algol68g
SUBDIR += angelscript
SUBDIR += apache-commons-jelly
SUBDIR += arena
SUBDIR += asis
SUBDIR += asn1c
@ -152,7 +153,6 @@
SUBDIR += io-devel
SUBDIR += itcl
SUBDIR += itcl4
SUBDIR += jakarta-commons-jelly
SUBDIR += janet
SUBDIR += jimtcl
SUBDIR += jruby

View File

@ -3,14 +3,15 @@
PORTNAME= commons-jelly
PORTVERSION= 1.0
PORTREVISION= 3
CATEGORIES= lang devel java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
MAINTAINER= ports@FreeBSD.org
COMMENT= XML based scripting engine
LICENSE= APACHE20
USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes

View File

@ -1,2 +1,3 @@
TIMESTAMP = 1570225476
SHA256 (commons-jelly-1.0.tar.gz) = c945943c1ca8c05170d1a7eb7402363c6817819321e1b2ae749d4ee93f27061b
SIZE (commons-jelly-1.0.tar.gz) = 3384141

View File

@ -12,4 +12,4 @@ dynamic web site generation. A single Jelly tag can produce, consume, filter or
transform XML events. This leads to a powerful XML pipeline engine similar in
some ways to Cocoon.
WWW: http://jakarta.apache.org/commons/jelly/index.html
WWW: http://commons.apache.org/proper/commons-jelly/index.html

View File

@ -3,6 +3,7 @@
PORTNAME= mime4j
PORTVERSION= 0.7.2
PORTREVISION= 1
CATEGORIES= mail java
MASTER_SITES= APACHE/james/${PORTNAME}
DISTNAME= apache-${PORTNAME}-${PORTVERSION}-bin
@ -12,7 +13,7 @@ COMMENT= Java parser for e-mail message streams
LICENSE= APACHE20
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
OPTIONS_DEFINE= DOCS

View File

@ -3,7 +3,7 @@
PORTNAME= scilab
PORTVERSION= 5.5.2
PORTREVISION= 21
PORTREVISION= 22
CATEGORIES= math cad java
MASTER_SITES= https://www.scilab.org/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
@ -68,7 +68,7 @@ _GUI_DEPENDS+= ${JAVALIBDIR}/flexdock.jar:devel/flexdock \
foprep:math/jeuclid \
${JAVALIBDIR}/jhall.jar:java/javahelp \
${JAVALIBDIR}/jrosetta-api.jar:java/jrosetta \
${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/jgraphx.jar:java/jgraphx \
${JAVALIBDIR}/jlatexmath.jar:math/jlatexmath \
${LOCALBASE}/share/java/ecj-4.5.jar:lang/gcc-ecj45
@ -77,7 +77,7 @@ _GUI_DEPENDS+= ${LOCALBASE}/share/java/fop/build/fop.jar:textproc/fop \
${JAVALIBDIR}/jlatexmath-fop.jar:math/jlatexmath \
${LOCALBASE}/share/java/batik/lib/batik-all.jar:graphics/batik \
${JAVALIBDIR}/avalon-framework.jar:devel/avalon-framework \
${JAVALIBDIR}/commons-io.jar:devel/jakarta-commons-io \
${JAVALIBDIR}/commons-io.jar:devel/apache-commons-io \
${JAVALIBDIR}/xmlgraphics-commons.jar:graphics/xmlgraphics-commons
# Code quality:
_GUI_DEPENDS+= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \

View File

@ -20,6 +20,7 @@
SUBDIR += aluminum
SUBDIR += anet
SUBDIR += aoe
SUBDIR += apache-commons-net
SUBDIR += apinger
SUBDIR += appkonference
SUBDIR += aprsc
@ -283,7 +284,6 @@
SUBDIR += isc-dhcp44-relay
SUBDIR += isc-dhcp44-server
SUBDIR += istgt
SUBDIR += jakarta-commons-net
SUBDIR += java-beepcore
SUBDIR += jcifs
SUBDIR += jgroups

View File

@ -5,7 +5,7 @@ PORTNAME= commons-net
PORTVERSION= 3.6
CATEGORIES= net java
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org

View File

@ -1,4 +1,4 @@
Jakarta Commons Net implements the client side of many basic Internet
Apache Commons Net implements the client side of many basic Internet
protocols. The purpose of the library is to provide fundamental protocol
access.
@ -18,4 +18,4 @@ Supported protocols are:
* Discard
* NTP/SNTP
WWW: http://jakarta.apache.org/commons/net/
WWW: http://commons.apache.org/proper/commons-net/

View File

@ -3,6 +3,7 @@
PORTNAME= pdfbox
PORTVERSION= 2.0.14
PORTREVISION= 1
CATEGORIES= print textproc java
MASTER_SITES= APACHE/pdfbox/${PORTVERSION}
DISTFILES= ${JAR_NAMES:S/$/-${PORTVERSION}.jar/}
@ -14,8 +15,8 @@ COMMENT= Java tool for working with PDF documents
LICENSE= APACHE20
RUN_DEPENDS= ${JAVALIBDIR}/bcmail.jar:java/bouncycastle15 \
${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-io.jar:devel/jakarta-commons-io
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-io.jar:devel/apache-commons-io
JAR_NAMES= pdfbox fontbox preflight xmpbox pdfbox-tools pdfbox-debugger

View File

@ -3,6 +3,7 @@
PORTNAME= xml-security
DISTVERSION= 1_5_5
PORTREVISION= 1
CATEGORIES= security java
MASTER_SITES= APACHE/santuario/java-library/${DISTVERSION}
DISTNAME= ${PORTNAME}-src-${DISTVERSION}
@ -10,9 +11,9 @@ DISTNAME= ${PORTNAME}-src-${DISTVERSION}
MAINTAINER= ale@FreeBSD.org
COMMENT= Java library for XML Signature and Encryption
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/xalan.jar:textproc/xalan-j
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
LICENSE= APACHE20

View File

@ -41,6 +41,7 @@
SUBDIR += amberfish
SUBDIR += ansifilter
SUBDIR += antiword
SUBDIR += apache-commons-digester
SUBDIR += apache-poi
SUBDIR += apache-solr
SUBDIR += apertium
@ -304,7 +305,6 @@
SUBDIR += itstool
SUBDIR += itstool22
SUBDIR += jade
SUBDIR += jakarta-commons-digester
SUBDIR += jalingo
SUBDIR += jarnal
SUBDIR += java2html

View File

@ -0,0 +1,55 @@
# Created by: Herve Quiroz <hq@FreeBSD.org>
# $FreeBSD$
PORTNAME= commons-digester
PORTVERSION= 2.1
PORTREVISION= 1
CATEGORIES= textproc java devel
MASTER_SITES= APACHE_COMMONS_BINARIES
PKGNAMEPREFIX= jakarta-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org
COMMENT= XML-to-Java-object mapping utility package
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${JAR_DEPENDS}
RUN_DEPENDS= ${JAR_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
NO_ARCH= yes
USE_JAVA= yes
JAVA_VERSION= 1.6+
JARFILE= ${PORTNAME}.jar
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
OPTIONS_DEFINE= DOCS
OTHERDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
PORTDOCS= *
.include <bsd.port.pre.mk>
JAR_DEPENDS= ${JAVALIBDIR}/commons-beanutils.jar:java/jakarta-commons-beanutils \
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections \
${JAVALIBDIR}/xercesImpl.jar:textproc/xerces-j
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${JARFILE}
@${ECHO_MSG} " [ DONE ]"
do-install-DOCS-on:
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@cd ${WRKSRC}/apidocs \
&& ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; \
&& ${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
SHA256 (commons-digester-2.1-bin.tar.gz) = c739162c5eafbbaecfe3ae9e3733221781def20c6603972a124b7ebb552a1af1
SIZE (commons-digester-2.1-bin.tar.gz) = 2308650

View File

@ -0,0 +1,15 @@
The Digester package lets you configure an XML -> Java object mapping module,
which triggers certain actions called rules whenever a particular pattern of
nested XML elements is recognized. A rich set of predefined rules is available
for your use, or you can also create your own. Advanced features of Digester
include:
- Ability to plug in your own pattern matching engine, if the standard one is
not sufficient for your requirements.
- Optional namespace-aware processing, so that you can define rules that are
relevant only to a particular XML namespace.
- Encapsulation of Rules into RuleSets that can be easily and conveniently
reused in more than one application that requires the same type of
processing
WWW: http://jakarta.apache.org/commons/digester/

View File

@ -3,6 +3,7 @@
PORTNAME= httpclient
DISTVERSION= 4.5.10
PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= APACHE/httpcomponents/${PORTNAME}/binary
DISTNAME= httpcomponents-client-${DISTVERSION}-bin
@ -14,7 +15,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${JAVALIBDIR}/httpcore.jar:www/httpcore \
${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec
OPTIONS_DEFINE= DOCS

View File

@ -3,7 +3,7 @@
PORTNAME= apache-jmeter
PORTVERSION= 2.11
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= www benchmarks java
MASTER_SITES= APACHE/jmeter/binaries
@ -18,12 +18,12 @@ LICENSE= APACHE20
RUN_DEPENDS= \
${JAVALIBDIR}/avalon-framework.jar:devel/avalon-framework \
${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec \
${JAVALIBDIR}/commons-collections.jar:java/jakarta-commons-collections \
${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections \
${JAVALIBDIR}/commons-httpclient.jar:java/jakarta-commons-httpclient \
${JAVALIBDIR}/commons-io.jar:devel/jakarta-commons-io \
${JAVALIBDIR}/commons-io.jar:devel/apache-commons-io \
${JAVALIBDIR}/commons-lang.jar:java/jakarta-commons-lang \
${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
${JAVALIBDIR}/commons-net.jar:net/jakarta-commons-net \
${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
${JAVALIBDIR}/commons-net.jar:net/apache-commons-net \
${JAVALIBDIR}/httpclient.jar:www/httpclient \
${JAVALIBDIR}/httpcore.jar:www/httpcore \
${JAVALIBDIR}/httpmime.jar:www/httpclient \