Add files missed in previous commit

PR:		224217
Submitted by:	nwhitehorn
This commit is contained in:
Steve Wills 2018-02-06 14:38:27 +00:00
parent b52a2cbd82
commit c93544f869
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461059
3 changed files with 94 additions and 0 deletions

View File

@ -0,0 +1,72 @@
--- Makefile.in.orig 2016-04-13 11:02:08.000000000 -0700
+++ Makefile.in 2017-12-08 14:01:46.149339000 -0800
@@ -2784,7 +2784,8 @@
esac; \
module_srcdir=libiberty; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -2841,7 +2842,8 @@
esac; \
module_srcdir=bison; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -2898,7 +2900,8 @@
esac; \
module_srcdir=flex; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -2955,7 +2958,8 @@
esac; \
module_srcdir=m4; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -3012,7 +3016,8 @@
esac; \
module_srcdir=texinfo; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -3069,7 +3074,8 @@
esac; \
module_srcdir=fixincludes; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \
@@ -3126,7 +3132,8 @@
esac; \
module_srcdir=libcpp; \
rm -f no-such-file || : ; \
- CONFIG_SITE=no-such-file $(SHELL) \
+ CONFIG_SITE=no-such-file CFLAGS="${HOST_CFLAGS}" \
+ CPPFLAGS="${HOST_CPPFLAGS}" CXXFLAGS="${HOST_CXXFLAGS}" $(SHELL) \
$$s/$$module_srcdir/configure \
--srcdir=$${topdir}/$$module_srcdir \
$(BUILD_CONFIGARGS) --build=${build_alias} --host=${build_alias} \

View File

@ -0,0 +1,11 @@
--- gcc/Makefile.in.orig 2017-12-09 14:33:56.283411000 -0800
+++ gcc/Makefile.in 2017-12-09 14:34:16.979742000 -0800
@@ -779,7 +779,7 @@
BUILD_NO_PIE_FLAG = @BUILD_NO_PIE_FLAG@
BUILD_LDFLAGS += $(BUILD_NO_PIE_FLAG)
BUILD_CPPFLAGS= -I. -I$(@D) -I$(srcdir) -I$(srcdir)/$(@D) \
- -I$(srcdir)/../include @INCINTL@ $(CPPINC) $(CPPFLAGS)
+ -I$(srcdir)/../include @INCINTL@ $(CPPINC) $(CPPFLAGS_FOR_BUILD)
# Actual name to use when installing a native compiler.
GCC_INSTALL_NAME := $(shell echo gcc|sed '$(program_transform_name)')

View File

@ -0,0 +1,11 @@
--- gcc/configure.orig 2017-12-09 14:33:36.570113000 -0800
+++ gcc/configure 2017-12-09 14:33:50.647310000 -0800
@@ -11803,7 +11803,7 @@
CC="${CC_FOR_BUILD}" CFLAGS="${CFLAGS_FOR_BUILD}" \
CXX="${CXX_FOR_BUILD}" CXXFLAGS="${CXXFLAGS_FOR_BUILD}" \
LD="${LD_FOR_BUILD}" LDFLAGS="${LDFLAGS_FOR_BUILD}" \
- GMPINC="" CPPFLAGS="${CPPFLAGS} -DGENERATOR_FILE" \
+ GMPINC="" CPPFLAGS="${CPPFLAGS_FOR_BUILD} -DGENERATOR_FILE" \
${realsrcdir}/configure \
--enable-languages=${enable_languages-all} \
--target=$target_alias --host=$build_alias --build=$build_alias