Update to 2.34.3.

This commit is contained in:
Koop Mast 2011-08-23 18:31:40 +00:00
parent eafcfff4e7
commit c9250fda95
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=280292
6 changed files with 30 additions and 77 deletions

View File

@ -3,7 +3,7 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/devel/libsoup-gnome/Makefile,v 1.1 2010/06/05 21:11:10 kwm Exp $
# $MCom: ports/devel/libsoup-gnome/Makefile,v 1.3 2011/06/06 17:50:29 kwm Exp $
#
PORTREVISION= 1
@ -14,16 +14,9 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNOME wrapper for libsoup
MASTERDIR= ${.CURDIR}/../libsoup
#BUILD_WRKSRC= ${WRKSRC}/gsf-gnome
#INSTALL_WRKSRC= ${WRKSRC}/gsf-gnome
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
SOUP_SLAVE= yes
#post-install:
# @${MKDIR} ${PREFIX}/libdata/pkgconfig
# @${INSTALL_DATA} ${WRKSRC}/libsoup-gnome-2.4.pc \
# ${PREFIX}/libdata/pkgconfig/
.include "${MASTERDIR}/Makefile"

View File

@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/devel/libsoup/Makefile,v 1.90 2010/11/16 02:38:21 avl Exp $
# $MCom: ports/devel/libsoup/Makefile,v 1.106 2011/07/28 19:00:08 kwm Exp $
#
PORTNAME= libsoup
PORTVERSION= 2.32.2
PORTREVISION?= 3
PORTVERSION= 2.34.3
PORTREVISION?= 0
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@ -16,7 +16,11 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A SOAP (Simple Object Access Protocol) implementation in C
USE_BZIP2= yes
USE_XZ= yes
BUILD_DEPENDS= glib-networking>=2.28.4:${PORTSDIR}/net/glib-networking
LIB_DEPENDS= gcrypt.18:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= glib-networking>=2.28.4:${PORTSDIR}/net/glib-networking
.if !defined(REFERENCE_PORT)
@ -26,42 +30,25 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CPPFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
PLIST_SUB= VERSION="2.4"
.include <bsd.port.pre.mk>
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
.if defined(SOUP_SLAVE)
LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup \
proxy.0:${PORTSDIR}/net/libproxy \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
sqlite3.8:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+=--with-gnome
USE_GNOME+= gconf2
.else
BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
CONFIGURE_ARGS+=--without-gnome
.endif
.if !defined(WITHOUT_SSL)
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+=--disable-ssl
.endif
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "libsoup has the following configurable option(s):"
@${ECHO_MSG} " WITHOUT_SSL Disable GnuTLS SSL support"
@${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g ; \
s|" == "|" = "|g' \
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||g' \
${WRKSRC}/configure
.if defined(SOUP_SLAVE)
@ -84,7 +71,7 @@ post-install:
.else
@${INSTALL_DATA} ${WRKSRC}/libsoup/soup-connection.h \
${PREFIX}/include/libsoup-2.4/libsoup/soup-connection.h
.endif
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (gnome2/libsoup-2.32.2.tar.bz2) = 96e6973c8b7459523c0f44e7aec69528ff2fbd388e8ddc415f91bcc42f50777f
SIZE (gnome2/libsoup-2.32.2.tar.bz2) = 668131
SHA256 (gnome2/libsoup-2.34.3.tar.xz) = c43f8865a9f7016c618b481bea3dd9ea65d9200685d4a94cddc54f8663704a1c
SIZE (gnome2/libsoup-2.34.3.tar.xz) = 595916

View File

@ -1,19 +1,19 @@
--- libsoup/Makefile.in.orig 2010-05-14 16:28:56.000000000 +0200
+++ libsoup/Makefile.in 2010-05-14 16:31:03.000000000 +0200
@@ -112,7 +112,6 @@
--- libsoup/Makefile.in.orig 2011-07-28 20:47:20.000000000 +0200
+++ libsoup/Makefile.in 2011-07-28 20:47:20.000000000 +0200
@@ -119,7 +119,6 @@
$(AM_CFLAGS) $(CFLAGS) $(libsoup_2_4_la_LDFLAGS) $(LDFLAGS) -o \
$@
@BUILD_LIBSOUP_GNOME_TRUE@libsoup_gnome_2_4_la_DEPENDENCIES = \
-@BUILD_LIBSOUP_GNOME_TRUE@ libsoup-2.4.la $(am__DEPENDENCIES_1) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(am__DEPENDENCIES_1) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(am__DEPENDENCIES_1) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(am__DEPENDENCIES_1) \
@@ -473,7 +472,7 @@
@BUILD_LIBSOUP_GNOME_TRUE@ $(am__DEPENDENCIES_1)
am__libsoup_gnome_2_4_la_SOURCES_DIST = soup-cookie-jar-sqlite.c \
@@ -494,7 +493,7 @@
@BUILD_LIBSOUP_GNOME_TRUE@libsoup_gnome_2_4_la_LDFLAGS = $(libsoup_2_4_la_LDFLAGS)
@BUILD_LIBSOUP_GNOME_TRUE@libsoup_gnome_2_4_la_LIBADD = \
-@BUILD_LIBSOUP_GNOME_TRUE@ libsoup-2.4.la \
+@BUILD_LIBSOUP_GNOME_TRUE@ -lsoup-2.4 \
@BUILD_LIBSOUP_GNOME_TRUE@ $(GLIB_LIBS) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(GCONF_LIBS) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(LIBPROXY_LIBS) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(SQLITE_LIBS) \
@BUILD_LIBSOUP_GNOME_TRUE@ $(GNOME_KEYRING_LIBS)

View File

@ -1,34 +0,0 @@
From 51eb8798c3965b49f3010db82009d36429f28514 Mon Sep 17 00:00:00 2001
From: Dan Winship <danw@gnome.org>
Date: Wed, 29 Jun 2011 14:04:06 +0000
Subject: SoupServer: fix to not allow smuggling ".." into path
When SoupServer:raw-paths was set (the default), it was possible to
sneak ".." segments into the path passed to the SoupServerHandler,
which could then end up tricking some handlers into retrieving
arbitrary files from the filesystem. Fix that.
https://bugzilla.gnome.org/show_bug.cgi?id=653258
---
diff --git a/libsoup/soup-server.c b/libsoup/soup-server.c
index d56efd1..7225337 100644
--- libsoup/soup-server.c
+++ libsoup/soup-server.c
@@ -779,6 +779,15 @@ got_headers (SoupMessage *req, SoupClientContext *client)
uri = soup_message_get_uri (req);
decoded_path = soup_uri_decode (uri->path);
+
+ if (strstr (decoded_path, "/../") ||
+ g_str_has_suffix (decoded_path, "/..")) {
+ /* Introducing new ".." segments is not allowed */
+ g_free (decoded_path);
+ soup_message_set_status (req, SOUP_STATUS_BAD_REQUEST);
+ return;
+ }
+
soup_uri_set_path (uri, decoded_path);
g_free (decoded_path);
}
--
cgit v0.9

View File

@ -3,6 +3,7 @@ include/libsoup-%%VERSION%%/libsoup/soup-auth-domain-basic.h
include/libsoup-%%VERSION%%/libsoup/soup-auth-domain-digest.h
include/libsoup-%%VERSION%%/libsoup/soup-auth-domain.h
include/libsoup-%%VERSION%%/libsoup/soup-auth.h
include/libsoup-%%VERSION%%/libsoup/soup-cache.h
include/libsoup-%%VERSION%%/libsoup/soup-connection.h
include/libsoup-%%VERSION%%/libsoup/soup-content-decoder.h
include/libsoup-%%VERSION%%/libsoup/soup-content-sniffer.h
@ -23,7 +24,13 @@ include/libsoup-%%VERSION%%/libsoup/soup-multipart.h
include/libsoup-%%VERSION%%/libsoup/soup-password-manager.h
include/libsoup-%%VERSION%%/libsoup/soup-portability.h
include/libsoup-%%VERSION%%/libsoup/soup-proxy-resolver.h
include/libsoup-%%VERSION%%/libsoup/soup-proxy-resolver-default.h
include/libsoup-%%VERSION%%/libsoup/soup-proxy-uri-resolver.h
include/libsoup-%%VERSION%%/libsoup/soup-request-data.h
include/libsoup-%%VERSION%%/libsoup/soup-request-file.h
include/libsoup-%%VERSION%%/libsoup/soup-request-http.h
include/libsoup-%%VERSION%%/libsoup/soup-request.h
include/libsoup-%%VERSION%%/libsoup/soup-requester.h
include/libsoup-%%VERSION%%/libsoup/soup-server.h
include/libsoup-%%VERSION%%/libsoup/soup-session-async.h
include/libsoup-%%VERSION%%/libsoup/soup-session-feature.h