CMU Gwydion project interpreter and compiler for the Dylan language.

Submitted by:	Peter S. Housel <housel@acm.org>
This commit is contained in:
Jeffrey Hsu 1998-07-12 21:58:13 +00:00
parent 5a0c7abaad
commit c90b59a68e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=11849
7 changed files with 3836 additions and 0 deletions

30
lang/dylan/Makefile Normal file
View File

@ -0,0 +1,30 @@
# New ports collection makefile for: Dylan
# Version required: 2.0
# Date created: 23 Jan 1998
# Whom: housel@acm.org
#
# $Id$
#
DISTNAME= gd20-source
PKGNAME= dylan-2.0
CATEGORIES= lang
MASTER_SITES= http://legend.gwydion.cs.cmu.edu/gwydion/dylan/release/
MAINTAINER= housel@acm.org
WRKSRC= $(WRKDIR)/src
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=$(PREFIX) --srcdir=$(WRKSRC)
CONFIGURE_ENV= D2C="$(WRKDIR)/d2c -p$(WRKSRC)/d2c/compiler/platforms.descr"
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= default
post-extract:
uudecode -p $(FILESDIR)/d2c.gz.uu | $(GUNZIP_CMD) > $(WRKDIR)/d2c
chmod ugo+x $(WRKDIR)/d2c
.include <bsd.port.mk>

1
lang/dylan/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gd20-source.tar.gz) = 86ae9486ef78104f2ad85d4fd9230bd0

3683
lang/dylan/files/patch-aa Normal file

File diff suppressed because it is too large Load Diff

11
lang/dylan/files/patch-ab Normal file
View File

@ -0,0 +1,11 @@
--- mindy/comp/Makefile.in.orig Fri May 9 20:45:36 1997
+++ mindy/comp/Makefile.in Sun Jul 12 00:32:35 1998
@@ -147,7 +147,7 @@
lexer-tab.o: ${SRCDIR}/lexer-tab.c ${SRCDIR}/lexer.h ${SRCDIR}/src.h \
${SRCDIR}/parser-tab.h
- ${CC} -c ${CFLAGS} ${SRCDIR}/lexer-tab.c
+ ${CC} -c -D_ANSI_SOURCE ${CFLAGS} ${SRCDIR}/lexer-tab.c
literal.o: ${SRCDIR}/literal.c ${SRCDIR}/../compat/std-c.h ${SRCDIR}/mindycomp.h \
${SRCDIR}/literal.h ${SRCDIR}/lose.h

1
lang/dylan/pkg-comment Normal file
View File

@ -0,0 +1 @@
CMU Gwydion project interpreter and compiler for the Dylan language.

39
lang/dylan/pkg-descr Normal file
View File

@ -0,0 +1,39 @@
This is a port of the CMU Gwydion project's implementation of the
Dylan programming language. Dylan is an object-oriented language with
many powerful features, including automatic memory management (garbage
collection), generic functions (also known as multiple dispatch or
multi-methods), multiple inheritance, a powerful and safe macro
facility for extending the language's syntax, and a powerful class and
function library. Though it is a DYnamic LANguage, it includes
facilities for making compiled programs more efficient than many other
dynamic languages.
The Dylan language was originally developed by Apple, but the project
was dropped just as the language definition was being finished and
before a production-quality compiler was complete. The CMU Gwydion
project and Harlequin have continued use and development of the
language. For more information about the Dylan language, see the
Dylan World site (http://www-dylan.uchicago.edu/).
Gwydion Dylan actually contains two implementations of the language.
One, called Mindy (Mindy Is Not Dylan Yet), is a bytecode compiler and
interpreter that implements most of the language except for the macro
facility. The other, d2c, is a compiler for the full language that
uses C as its target "assembly language". The d2c compiler was
written in Dylan and bootstrapped using Mindy.
A copy of the d2c compiler binary is included with the port to
bootstrap the entire system. As the Gwydion documentation says,
Recompiling the entire system takes over an hour on 64meg 200mhz
Pentium Pro running Windows/NT. This is almost all for the
compilation of the d2c runtime and compiler; compiling just Mindy
takes only a few minutes. d2c also uses lots of memory, especially
when compiling itself: you want at least 48 meg, and more is
better.
For more information about building Gwydion dylan, see
http://legend.gwydion.cs.cmu.edu/gwydion/dylan/docs/htdocs/unix-build.html.
The Gwydion project home page is at http://legend.gwydion.cs.cmu.edu/gwydion/
-Peter S. Housel- housel@acm.org

71
lang/dylan/pkg-plist Normal file
View File

@ -0,0 +1,71 @@
lib/dylan/collection-extensions-lib.dbc
lib/dylan/collection-extensions.lib.du
lib/dylan/dylan-lib.dbc
lib/dylan/dylan.lib.du
lib/dylan/elisp/dylan-mode.el
lib/dylan/elisp/dylan-params.el
lib/dylan/elisp/fill-comment.el
lib/dylan/elisp/goto-def.el
lib/dylan/elisp/mindy-comp.el
lib/dylan/elisp/page-cmds.el
lib/dylan/format-lib.dbc
lib/dylan/format-out-lib.dbc
lib/dylan/format-out.lib.du
lib/dylan/format.lib.du
lib/dylan/inspector-base-lib.dbc
lib/dylan/libcollext.a
lib/dylan/libdylan.a
lib/dylan/libformat.a
lib/dylan/libformatout.a
lib/dylan/libgc.a
lib/dylan/libmatrix.a
lib/dylan/libmelange.a
lib/dylan/libprint.a
lib/dylan/librandom.a
lib/dylan/libregexp.a
lib/dylan/libruntime.a
lib/dylan/libstdio.a
lib/dylan/libstreamext.a
lib/dylan/libstreams.a
lib/dylan/libstringext.a
lib/dylan/libtableext.a
lib/dylan/libtranscendental.a
lib/dylan/matrix-lib.dbc
lib/dylan/matrix.lib.du
lib/dylan/melange-support.lib.du
lib/dylan/print-lib.dbc
lib/dylan/print.lib.du
lib/dylan/random-lib.dbc
lib/dylan/random.lib.du
lib/dylan/regular-expressions-lib.dbc
lib/dylan/regular-expressions.lib.du
lib/dylan/standard-io-lib.dbc
lib/dylan/standard-io.lib.du
lib/dylan/stream-extensions-lib.dbc
lib/dylan/stream-extensions.lib.du
lib/dylan/streams-lib.dbc
lib/dylan/streams.lib.du
lib/dylan/string-extensions-lib.dbc
lib/dylan/string-extensions.lib.du
lib/dylan/table-extensions-lib.dbc
lib/dylan/table-extensions.lib.du
lib/dylan/text-inspector-lib.dbc
lib/dylan/tk-lib.dbc
lib/dylan/transcendental-lib.dbc
lib/dylan/transcendental.lib.du
lib/dylan/x-inspector-lib.dbc
bin/d2c
bin/gen-makefile
bin/line-count
bin/lisp2dylan
bin/make-exports
bin/melange
bin/mindy
bin/mindycomp
bin/mindyexec
bin/mk-build-tree
bin/mk-rcs-links
bin/parsergen
bin/synopsis
etc/platforms.descr
include/runtime.h