After repocopy from audio/audacity, add audacity-devel, a development
branch of this audio waveform editor program. This is a beta of upcoming major release 1.2.0, and is already worth a try. For details see http://audacity.sourceforge.net/beta.php PR: ports/59915 Submitted by: Craig Boston <craig@yekse.gank.org>
This commit is contained in:
parent
14140d9071
commit
c908872f20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=95922
@ -19,6 +19,7 @@
|
||||
SUBDIR += asmixer
|
||||
SUBDIR += aube
|
||||
SUBDIR += audacity
|
||||
SUBDIR += audacity-devel
|
||||
SUBDIR += aumix
|
||||
SUBDIR += aureal-kmod
|
||||
SUBDIR += autocd
|
||||
|
@ -1,61 +1,64 @@
|
||||
# New ports collection makefile for: audacity
|
||||
# Date created: 21 Jul 2001
|
||||
# Whom: Marc van Woerkom <3d@freebsd.org>
|
||||
# New ports collection makefile for: audacity-devel
|
||||
# Date created: 2 Dec 2003
|
||||
# Whom: Craig Boston <craig@yekse.gank.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= audacity
|
||||
PORTVERSION= 1.0.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.2.0.p3
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-src-${PORTVERSION}-2
|
||||
EXTRACT_SUFX= .tgz
|
||||
DISTNAME= ${PORTNAME}-src-1.2.0-pre3
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= craig@yekse.gank.org
|
||||
COMMENT= Audacity is a GUI editor for digital audio waveforms
|
||||
|
||||
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip
|
||||
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
|
||||
mad.2:${PORTSDIR}/audio/mad
|
||||
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
|
||||
GNU_CONFIGURE= yes
|
||||
CONFLICTS= audacity-1.0*
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-src-1.2.0-pre3
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
AUDACITY_HELP_DIR= ${PREFIX}/share/doc/audacity
|
||||
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
|
||||
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
CFLAGS="-DAUDACITY_HELP_DIR=${AUDACITY_HELP_DIR} ${PTHREAD_CFLAGS}" \
|
||||
USE_LIBTOOL= yes
|
||||
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
|
||||
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
|
||||
WX_CONFIG=${X11BASE}/bin/wxgtk2-2.4-config
|
||||
CONFIGURE_ARGS+= --with-id3=no --with-libmad=yes
|
||||
CONFIGURE_ARGS+= --with-id3=no
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_ARTS)
|
||||
LIB_DEPENDS+= qtmcop.1:${PORTSDIR}/audio/arts
|
||||
CONFIGURE_ARGS+= --with-arts-soundserver=yes
|
||||
.if !defined(NOPORTDOCS)
|
||||
MAKE_ENV= DOC=yes
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_MAD)
|
||||
CONFIGURE_ARGS+= --with-libmad=system
|
||||
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-libmad
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_VORBIS)
|
||||
CONFIGURE_ARGS+= --with-vorbis
|
||||
CONFIGURE_ARGS+= --with-vorbis=system
|
||||
LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-vorbis
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITHOUT_MAD)
|
||||
@${ECHO_MSG} "You can disable support for libmad (MP3) by defining WITHOUT_MAD."
|
||||
.endif
|
||||
.if !defined(WITHOUT_VORBIS)
|
||||
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
|
||||
.endif
|
||||
.if !defined(WITH_ARTS)
|
||||
@${ECHO_MSG} "You can use artsd instead of OSS for output by defining WITH_ARTS."
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/audacity ${PREFIX}/bin/audacity
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/doc/audacity
|
||||
${INSTALL_DATA} ${WRKSRC}/audacity-help.htb ${WRKSRC}/README.txt ${WRKSRC}/LICENSE.txt ${PREFIX}/share/doc/audacity/
|
||||
.endif
|
||||
MAN1= audacity.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (audacity-src-1.0.0-2.tgz) = 221573db91b48d521a55c7432189df80
|
||||
MD5 (audacity-src-1.2.0-pre3.tar.bz2) = a7efddd64e2ce3e380614796d689e11f
|
||||
|
17
audio/audacity-devel/files/patch-Makefile.in
Normal file
17
audio/audacity-devel/files/patch-Makefile.in
Normal file
@ -0,0 +1,17 @@
|
||||
--- Makefile.in.orig Tue Dec 2 22:43:47 2003
|
||||
+++ Makefile.in Tue Dec 2 22:46:38 2003
|
||||
@@ -27,12 +27,14 @@
|
||||
$(INSTALL) -d $(DESTDIR)$(BINDIR)
|
||||
$(INSTALL) -m 755 audacity $(DESTDIR)$(BINDIR)/$(AUDACITY_NAME)
|
||||
|
||||
+ifeq ($(DOC),yes)
|
||||
# install docs
|
||||
$(INSTALL) -d $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)
|
||||
-test -f audacity-1.2-help.htb && $(INSTALL) -m 644 audacity-1.2-help.htb \
|
||||
$(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/audacity-1.2-help.htb
|
||||
$(INSTALL) -m 644 README.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/README.txt
|
||||
$(INSTALL) -m 644 LICENSE.txt $(DESTDIR)$(DATADIR)/doc/$(AUDACITY_NAME)/LICENSE.txt
|
||||
+endif
|
||||
|
||||
# install manpage
|
||||
$(INSTALL) -d $(DESTDIR)$(MANDIR)/man1
|
@ -1,11 +0,0 @@
|
||||
--- snd/audioarts.c.orig Wed May 29 19:10:43 2002
|
||||
+++ snd/audioarts.c Wed May 29 19:10:51 2002
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
#include <sys/time.h>
|
||||
|
||||
-#include <kde/artsc/artsc.h>
|
||||
+#include <artsc/artsc.h>
|
||||
|
||||
/* snd includes */
|
||||
|
36
audio/audacity-devel/files/patch-libnyquist-Makefile.in
Normal file
36
audio/audacity-devel/files/patch-libnyquist-Makefile.in
Normal file
@ -0,0 +1,36 @@
|
||||
--- lib-src/libnyquist/Makefile.in.orig Tue Dec 2 19:32:18 2003
|
||||
+++ lib-src/libnyquist/Makefile.in Tue Dec 2 19:32:42 2003
|
||||
@@ -465,13 +465,13 @@
|
||||
cc -c cmt/userio.c -o cmt/userio.o $(CFLAGS)
|
||||
|
||||
misc/intgen: misc/intgen.c
|
||||
- cd misc; make intgen
|
||||
+ cd misc; $(MAKE) intgen
|
||||
|
||||
misc/unpacker: misc/unpacker.c misc/convert.c
|
||||
- cd misc; make unpacker
|
||||
+ cd misc; $(MAKE) unpacker
|
||||
|
||||
misc/packer: misc/packer.c misc/convert.c
|
||||
- cd misc; make packer
|
||||
+ cd misc; $(MAKE) packer
|
||||
|
||||
nyqsrc/sndfnintptrs.h: $(NYQHDRS) snd/snd.h misc/intgen
|
||||
$(INTGEN) nyqsrc/sndfnint $(NYQHDRS)
|
||||
@@ -481,14 +481,14 @@
|
||||
|
||||
clean:
|
||||
rm -f libnyquist.a
|
||||
- cd misc; make clean
|
||||
+ cd misc; $(MAKE) clean
|
||||
rm -f $(OBJECTS)
|
||||
# Note that these files are machine-generated:
|
||||
rm -f nyqsrc/sndfnintptrs.h nyqsrc/sndfnint.c nyqsrc/sndfnintdefs.h
|
||||
rm -f nyqsrc/seqfnintptrs.h nyqsrc/seqfnint.c nyqsrc/seqfnintdefs.h
|
||||
|
||||
cleaner: clean
|
||||
- cd misc; make cleaner
|
||||
+ cd misc; $(MAKE) cleaner
|
||||
rm -f *.backup */*.backup
|
||||
rm -f *~ */*.*~
|
||||
rm -f *.save */*.save
|
11
audio/audacity-devel/files/patch-libnyquist-switches.h
Normal file
11
audio/audacity-devel/files/patch-libnyquist-switches.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/libnyquist/sys/switches.h.orig Tue Dec 2 19:14:40 2003
|
||||
+++ lib-src/libnyquist/sys/switches.h Tue Dec 2 19:16:20 2003
|
||||
@@ -39,7 +39,7 @@
|
||||
*/
|
||||
#define nyquist_printf printf
|
||||
|
||||
-#if __APPLE__ && __GNUC__ /* Mac OS X */
|
||||
+#if (__FreeBSD__ || __APPLE__) && __GNUC__ /* Mac OS X */
|
||||
#define NEED_ULONG 1
|
||||
#else
|
||||
#include <sys/types.h>
|
11
audio/audacity-devel/files/patch-libnyquist-term.c
Normal file
11
audio/audacity-devel/files/patch-libnyquist-term.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/libnyquist/sys/term.c.orig Tue Dec 2 19:17:30 2003
|
||||
+++ lib-src/libnyquist/sys/term.c Tue Dec 2 19:17:51 2003
|
||||
@@ -40,7 +40,7 @@
|
||||
#else
|
||||
|
||||
#include <termios.h>
|
||||
-#ifndef __APPLE__
|
||||
+#if !defined(__APPLE__) && !defined(__FreeBSD__)
|
||||
#include <asm/ioctls.h>
|
||||
#endif
|
||||
#include <signal.h>
|
11
audio/audacity-devel/files/patch-libresample-Makefile.in
Normal file
11
audio/audacity-devel/files/patch-libresample-Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
|
||||
+++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
|
||||
@@ -6,7 +6,7 @@
|
||||
CC = @CC@
|
||||
CFLAGS = @CFLAGS@ -Wall
|
||||
|
||||
-LIBS = @LIBS@ -lm
|
||||
+LIBS = @LDFLAGS@ @LIBS@ -lm
|
||||
|
||||
AR = @AR@
|
||||
RANLIB = @RANLIB@
|
11
audio/audacity-devel/files/patch-portaudio-pa_unix.h
Normal file
11
audio/audacity-devel/files/patch-portaudio-pa_unix.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
|
||||
+++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
|
||||
@@ -82,7 +82,7 @@
|
||||
#define MAX_TIMEOUT_MSEC (1000)
|
||||
|
||||
/************************************************* Definitions ********/
|
||||
-#ifdef __linux__
|
||||
+#if defined(__linux__) || defined(__FreeBSD__)
|
||||
#define DEVICE_NAME_BASE "/dev/dsp"
|
||||
#else
|
||||
#define DEVICE_NAME_BASE "/dev/audio"
|
11
audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
Normal file
11
audio/audacity-devel/files/patch-portaudio-pa_unix_oss.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/portaudio/pa_unix_oss/pa_unix_oss.c.orig Tue Dec 2 19:57:13 2003
|
||||
+++ lib-src/portaudio/pa_unix_oss/pa_unix_oss.c Tue Dec 2 19:57:47 2003
|
||||
@@ -42,6 +42,8 @@
|
||||
|
||||
#ifdef __linux__
|
||||
#include <linux/soundcard.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <sys/soundcard.h>
|
||||
#else
|
||||
#include <machine/soundcard.h> /* JH20010905 */
|
||||
#endif
|
11
audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
Normal file
11
audio/audacity-devel/files/patch-portmixer-px_unix_oss.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- lib-src/portmixer/px_unix_oss/px_unix_oss.c.orig Tue Dec 2 20:06:55 2003
|
||||
+++ lib-src/portmixer/px_unix_oss/px_unix_oss.c Tue Dec 2 20:07:09 2003
|
||||
@@ -37,6 +37,8 @@
|
||||
|
||||
#ifdef __linux__
|
||||
#include <linux/soundcard.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <sys/soundcard.h>
|
||||
#else
|
||||
#include <machine/soundcard.h> /* JH20010905 */
|
||||
#endif
|
16
audio/audacity-devel/files/patch-soundtouch-Makefile.in
Normal file
16
audio/audacity-devel/files/patch-soundtouch-Makefile.in
Normal file
@ -0,0 +1,16 @@
|
||||
--- lib-src/soundtouch/Makefile.in.orig Tue Dec 2 19:01:28 2003
|
||||
+++ lib-src/soundtouch/Makefile.in Tue Dec 2 19:03:17 2003
|
||||
@@ -1,10 +1,10 @@
|
||||
all:
|
||||
- cd src && make
|
||||
+ cd src && $(MAKE)
|
||||
|
||||
clean:
|
||||
rm -f *~ *.a config.cache config.log config.status core*
|
||||
- cd src && make clean
|
||||
+ cd src && $(MAKE) clean
|
||||
|
||||
distclean: clean
|
||||
rm -f Makefile
|
||||
- cd src && make dist
|
||||
+ cd src && $(MAKE) dist
|
@ -1,11 +0,0 @@
|
||||
--- Help.cpp.orig Mon Sep 17 16:50:58 2001
|
||||
+++ Help.cpp Mon Sep 17 16:53:11 2001
|
||||
@@ -61,7 +61,7 @@
|
||||
void InitHelp(wxWindow * parent)
|
||||
{
|
||||
if (!gHelp) {
|
||||
- wxString defaultLoc = wxGetCwd() + wxFILE_SEP_PATH + "audacity-help.htb";
|
||||
+ wxString defaultLoc = AUDACITY_HELP_DIR + wxFILE_SEP_PATH + "audacity-help.htb";
|
||||
|
||||
wxString helpFilePath =
|
||||
gPrefs->Read("/Help/HelpFilePath", defaultLoc);
|
@ -1,13 +0,0 @@
|
||||
--- Help.h.orig Mon Sep 17 16:52:09 2001
|
||||
+++ Help.h Mon Sep 17 16:52:53 2001
|
||||
@@ -11,6 +11,10 @@
|
||||
#ifndef __AUDACITY_HELP__
|
||||
#define __AUDACITY_HELP__
|
||||
|
||||
+#ifndef AUDACITY_HELP_DIR
|
||||
+#define AUDACITY_HELP_DIR /usr/X11R6/share/audacity
|
||||
+#endif
|
||||
+
|
||||
void InitHelp(wxWindow * parent);
|
||||
void ShowHelp(wxWindow * parent);
|
||||
void ShowHelp(wxWindow * parent, wxString topic);
|
@ -6,7 +6,11 @@ common editing operations such as Cut, Copy, and Paste, plus it will
|
||||
mix tracks and let you apply plug-in effects to any part of a sound. It
|
||||
also has a built-in amplitude envelope editor, a customizable
|
||||
spectrogram mode and a frequency analysis window for audio
|
||||
analysis applications.
|
||||
analysis applications.
|
||||
|
||||
This is the development release of Audacity. It has significant
|
||||
feature improvements over the stable release (audio/audacity), but has
|
||||
not received as much real-world testing.
|
||||
|
||||
Author: Dominic Mazzoni dominic@minorninth.com
|
||||
WWW: http://audacity.sourceforge.net
|
||||
|
@ -1,5 +1,44 @@
|
||||
bin/audacity
|
||||
%%PORTDOCS%%%%DOCSDIR%%/audacity-help.htb
|
||||
share/audacity/nyquist/bug.lsp
|
||||
share/audacity/nyquist/dspprims.lsp
|
||||
share/audacity/nyquist/evalenv.lsp
|
||||
share/audacity/nyquist/follow.lsp
|
||||
share/audacity/nyquist/init.lsp
|
||||
share/audacity/nyquist/misc.lsp
|
||||
share/audacity/nyquist/nyinit.lsp
|
||||
share/audacity/nyquist/nyqmisc.lsp
|
||||
share/audacity/nyquist/nyquist.lsp
|
||||
share/audacity/nyquist/printrec.lsp
|
||||
share/audacity/nyquist/profile.lsp
|
||||
share/audacity/nyquist/seq.lsp
|
||||
share/audacity/nyquist/seqfnint.lsp
|
||||
share/audacity/nyquist/seqmidi.lsp
|
||||
share/audacity/nyquist/sndfnint.lsp
|
||||
share/audacity/nyquist/system.lsp
|
||||
share/audacity/nyquist/test.lsp
|
||||
share/audacity/nyquist/xlinit.lsp
|
||||
share/audacity/plug-ins/clicktrack.ny
|
||||
share/audacity/plug-ins/delay.ny
|
||||
share/audacity/plug-ins/highpass.ny
|
||||
share/audacity/plug-ins/lowpass.ny
|
||||
share/audacity/plug-ins/pluck.ny
|
||||
share/audacity/plug-ins/tremolo.ny
|
||||
share/locale/bg/LC_MESSAGES/audacity.mo
|
||||
share/locale/ca/LC_MESSAGES/audacity.mo
|
||||
share/locale/cs/LC_MESSAGES/audacity.mo
|
||||
share/locale/da/LC_MESSAGES/audacity.mo
|
||||
share/locale/de/LC_MESSAGES/audacity.mo
|
||||
share/locale/es/LC_MESSAGES/audacity.mo
|
||||
share/locale/it/LC_MESSAGES/audacity.mo
|
||||
share/locale/mk/LC_MESSAGES/audacity.mo
|
||||
share/locale/nl/LC_MESSAGES/audacity.mo
|
||||
share/locale/pt/LC_MESSAGES/audacity.mo
|
||||
share/locale/ru/LC_MESSAGES/audacity.mo
|
||||
share/locale/sv/LC_MESSAGES/audacity.mo
|
||||
@dirrm share/audacity/plug-ins
|
||||
@dirrm share/audacity/nyquist
|
||||
@dirrm share/audacity
|
||||
%%PORTDOCS%%%%DOCSDIR%%/audacity-1.2-help.htb
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user