Support CC/CFLAGS/LOCALBASE/X11BASE properly

Contacted maintainer with 'User unknown' error.

PR:		21577
Submitted by:	Ports Fury
This commit is contained in:
Ade Lovett 2000-10-13 20:20:36 +00:00
parent 34e2748f25
commit c90490bfbc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33782

View File

@ -1,15 +1,19 @@
--- ORIG/Makefile Wed Mar 11 23:11:26 1998
+++ Makefile Wed Aug 18 18:57:46 1999
@@ -61,23 +61,28 @@
CC = cc
--- Makefile.orig Thu Mar 12 13:11:26 1998
+++ Makefile Thu Aug 10 21:13:42 2000
@@ -58,26 +58,30 @@
# The C compiler:
-CC = cc
+CC ?= cc
# Compiler options:
-COPTS = -c -O
+COPTS = -c -O -w
+COPTS = -c -w
# Shared library linker command:
-SHLINK = cc -G
+SHLINK = cc -shared
+SHLINK = ${CC} -shared
# Name for the shared lib:
-#SH_LIB = libtogl.so.1.3
@ -20,16 +24,15 @@
-# Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
-INCLUDES = -I/usr/local/include -I/usr/include/tcl
+# Where to find tc.hl, tk.h, OpenGL/Mesa headers, etc:
+INCLUDES = -I/usr/local/include/tcl8.2 \
+ -I/usr/local/include/tk8.2 \
+ -I/usr/local/include/tk8.2/generic \
+ -I/usr/X11R6/include \
+ -I/usr/include/tcl
+INCLUDES = -I${LOCALBASE}/include/tcl8.2 \
+ -I${LOCALBASE}/include/tk8.2 \
+ -I${LOCALBASE}/include/tk8.2/generic \
+ -I${X11BASE}/include
# Where to find libtcl.a, libtk.a, OpenGL/Mesa libraries:
-LIBDIRS = -L/usr/local/lib
+LIBDIRS = -L/usr/local/lib \
+ -L/usr/X11R6/lib
+LIBDIRS = -L${LOCALBASE}/lib \
+ -L${X11BASE}/lib
# Libraries to link with (-ldl for Linux only?):
-LIBS = -ltk -ltcl -lGLU -lGL -L/usr/X11/lib -lX11 -lXmu -lXext -lXt -lm -ldl
@ -37,7 +40,16 @@
TK_FLAGS =
@@ -144,8 +149,8 @@
@@ -85,7 +89,7 @@
#### Shouldn't have to change anything beyond this point ####
-CFLAGS = $(COPTS) $(INCLUDES) $(TK_FLAGS)
+CFLAGS += $(COPTS) $(INCLUDES) $(TK_FLAGS)
LFLAGS = $(LIBDIRS)
@@ -144,8 +148,8 @@
$(CC) $(CFLAGS) togl.c