archivers/libdeflate: update the port to version 1.15

- The build system had been switched to CMake, adjust the Makefile
  accordingly and convert outgrown PLIST_FILES into static pkg-plist
- Backport one upstream commit for the sake of consistency, so unit
  tests reflect on release binaries (it also happens to inadvertently
  inhibit detection of futimes(2), which is deprecated interface as
  it does not provide nanosecond accuracy, so it's probably okay)
- Do not pass "-O2 -DNDEBUG" on release CFLAGS: -O2 is redundant and
  NDEBUG is not actually used anywhere in the library source code

PR:	268519
This commit is contained in:
Daniel Engberg 2023-01-05 08:21:46 +00:00 committed by Alexey Dokuchaev
parent 7a04fc5683
commit c8d13ef7f3
4 changed files with 29 additions and 44 deletions

View File

@ -1,8 +1,11 @@
PORTNAME= libdeflate
PORTVERSION= 1.14
PORTVERSION= 1.15
DISTVERSIONPREFIX= v
CATEGORIES= archivers
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= 98174ac5e6fe2a806923bcb6bfa24cdbf32c79d0.patch:-p1
MAINTAINER= danfe@FreeBSD.org
COMMENT= Fast, whole-buffer DEFLATE-based compression library
WWW= https://github.com/ebiggers/libdeflate
@ -10,24 +13,20 @@ WWW= https://github.com/ebiggers/libdeflate
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake
USES= cmake:testing pathfix
USE_GITHUB= yes
GH_ACCOUNT= ebiggers
USE_LDCONFIG= yes
MAKE_ARGS= V=1
TEST_TARGET= check
PLIST_FILES= bin/libdeflate-gunzip bin/libdeflate-gzip \
include/libdeflate.h \
libdata/pkgconfig/libdeflate.pc \
lib/libdeflate.a lib/libdeflate.so lib/libdeflate.so.0
PORTDOCS= NEWS.md README.md
CMAKE_ON= LIBDEFLATE_USE_SHARED_LIB
CMAKE_TESTING_ON= LIBDEFLATE_BUILD_TESTS
OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e '/-O2 -DNDEBUG/d' ${WRKSRC}/CMakeLists.txt
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.md ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,3 +1,5 @@
TIMESTAMP = 1662862430
SHA256 (ebiggers-libdeflate-v1.14_GH0.tar.gz) = 89e7df898c37c3427b0f39aadcf733731321a278771d20fc553f92da8d4808ac
SIZE (ebiggers-libdeflate-v1.14_GH0.tar.gz) = 180182
TIMESTAMP = 1670215210
SHA256 (ebiggers-libdeflate-v1.15_GH0.tar.gz) = 58b95040df7383dc0413defb700d9893c194732474283cc4c8f144b00a68154b
SIZE (ebiggers-libdeflate-v1.15_GH0.tar.gz) = 180818
SHA256 (98174ac5e6fe2a806923bcb6bfa24cdbf32c79d0.patch) = 3b80183158aee9c01274258548a938bfa2bf4377ccfb0d6f3277424126068a37
SIZE (98174ac5e6fe2a806923bcb6bfa24cdbf32c79d0.patch) = 1502

View File

@ -1,29 +0,0 @@
--- Makefile.orig 2022-09-11 02:13:50 UTC
+++ Makefile
@@ -54,7 +54,7 @@ override CFLAGS := \
1>&2 2>/dev/null; then echo $(1); fi)
override CFLAGS := \
- -O2 -fomit-frame-pointer -std=c99 -I. -Wall -Wundef \
+ -std=c99 -I. -Wall -Wundef \
$(call cc-option,-Wdeclaration-after-statement) \
$(call cc-option,-Wimplicit-fallthrough) \
$(call cc-option,-Wmissing-prototypes) \
@@ -340,7 +340,7 @@ install:all $(PKGCONFBASE)
$(DESTDIR)$(BINDIR)
install -m644 $(STATIC_LIB) $(DESTDIR)$(LIBDIR)
if [ -z "$(DISABLE_SHARED)" ]; then \
- install -m755 $(SHARED_LIB) $(DESTDIR)$(LIBDIR); \
+ install -s -m755 $(SHARED_LIB) $(DESTDIR)$(LIBDIR); \
fi
sed -e "s|@PREFIX@|$(PREFIX)|" \
-e "s|@LIBDIR@|$(LIBDIR)|" \
@@ -349,7 +349,7 @@ install:all $(PKGCONFBASE)
$(PKGCONFBASE) > $(DESTDIR)$(LIBDIR)/pkgconfig/libdeflate.pc
chmod 644 $(DESTDIR)$(LIBDIR)/pkgconfig/libdeflate.pc
install -m644 libdeflate.h $(DESTDIR)$(INCDIR)
- install -m755 gzip$(PROG_SUFFIX) \
+ install -s -m755 gzip$(PROG_SUFFIX) \
$(DESTDIR)$(BINDIR)/libdeflate-gzip$(PROG_SUFFIX)
if [ -n "$(HARD_LINKS)" ]; then \
ln -f $(DESTDIR)$(BINDIR)/libdeflate-gzip$(PROG_SUFFIX) \

View File

@ -0,0 +1,13 @@
bin/libdeflate-gunzip
bin/libdeflate-gzip
include/libdeflate.h
lib/cmake/libdeflate/libdeflate-config-version.cmake
lib/cmake/libdeflate/libdeflate-config.cmake
lib/cmake/libdeflate/libdeflate-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/libdeflate/libdeflate-targets.cmake
lib/libdeflate.a
lib/libdeflate.so
lib/libdeflate.so.0
libdata/pkgconfig/libdeflate.pc
%%PORTDOCS%%%%DOCSDIR%%/NEWS.md
%%PORTDOCS%%%%DOCSDIR%%/README.md