- Update to version 0.6.0.20070905.

This commit is contained in:
Alejandro Pulver 2007-09-09 07:33:04 +00:00
parent 4dac1588e9
commit c887e0a58c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=199172
5 changed files with 73 additions and 40 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= gigi
PORTVERSION= 0.6.0.20070726
PORTVERSION= 0.6.0.20070905
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= alepulver
@ -20,24 +20,34 @@ LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil \
USE_BZIP2= yes
USE_SCONS= yes
SCONS_ARGS= prefix=""
SCONS_ARGS= prefix="" pkgconfigdir=""
USE_SDL= sdl
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}/GG
#OPTIONS= OGRE "Enable Ogre (3D engine) support" off
SHLIB_VER= 0
PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
.include <bsd.port.pre.mk>
#.if defined(WITH_OGRE)
#LIB_DEPENDS+= OgreMain.13:${PORTSDIR}/graphics/ogre3d
#PLIST_SUB+= OGRE=""
#.else
#SCONS_ENV+= build_ogre_driver=0 build_ogre_ois_plugin=0
#PLIST_SUB+= OGRE="@comment "
#.endif
post-build:
.for f in GiGi GiGiSDL
@cd ${WRKSRC} && ${SED} -e \
's|%(prefix)s|${PREFIX}|; s|%(libdir)s|${PREFIX}/lib|; \
s|%(incdir)s|${PREFIX}/include|; \
s|%(version)s|${PORTVERSION}|; \
s|%(boost_include)s||; s|%(gigi_libs)s||; \
s|%(gigi_sdl_libs)s||; s|%(sdl_include)s||' \
${f}.pc.in > ${f}.pc
.endfor
@${REINPLACE_CMD} -Ee 's,^(prefix|(lib|include)dir)=,&${PREFIX},' \
${WRKSRC}/*.pc
do-build:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${SCONS_BUILDENV} ktrace -di ${SCONS_BIN} ${SCONS_ENV} ${SCONS_ARGS} \
${SCONS_TARGET}
do-install:
${MKDIR} ${PREFIX}/include/GG
@ -58,4 +68,4 @@ maint-gen-distfile:
tar cjf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}
${RM} -rf ${PORTNAME}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (gigi-0.6.0.20070726.tar.bz2) = 60878c47daf21394d02729624e74f722
SHA256 (gigi-0.6.0.20070726.tar.bz2) = 4831702da64a10ad9888af563e122a5a90928605ad97c75c7381c2f8738e0193
SIZE (gigi-0.6.0.20070726.tar.bz2) = 563236
MD5 (gigi-0.6.0.20070905.tar.bz2) = a0a766163975200ed09be8b4cbfbd557
SHA256 (gigi-0.6.0.20070905.tar.bz2) = c77f63364ce3496f3ef2f584e1fa88e84681efce74431a58fe70531073f1cb53
SIZE (gigi-0.6.0.20070905.tar.bz2) = 601868

View File

@ -1,11 +0,0 @@
--- GiGiSDL.pc.in.orig Fri Jul 20 19:21:38 2007
+++ GiGiSDL.pc.in Thu Jul 26 14:20:45 2007
@@ -4,7 +4,7 @@
Name: GiGiSDL
Description: An SDL-based input driver and application framework for use with libGiGi.
-Requires: GiGi = ${version}
+Requires: GiGi = ${version}, sdl
Version: ${version}
Libs: -lGiGiSDL %(gigi_sdl_libs)s
Cflags:

View File

@ -1,6 +1,6 @@
--- ./SConstruct.orig Tue Aug 22 23:22:16 2006
+++ ./SConstruct Tue May 1 16:01:52 2007
@@ -53,6 +53,11 @@
--- ./SConstruct.orig Wed Aug 29 19:33:24 2007
+++ ./SConstruct Wed Sep 5 17:54:37 2007
@@ -45,6 +45,11 @@
options.Add('with_devil', 'Root directory of DevIL installation')
options.Add('with_devil_include', 'Specify exact include dir for DevIL headers')
options.Add('with_devil_libdir', 'Specify exact library dir for DevIL library')
@ -10,16 +10,48 @@
+options.Add('CPPPATH', 'Compiler include path', Split(''))
+options.Add('LIBPATH', 'Linker library path', Split(''))
##################################################
@@ -103,6 +108,10 @@
pass
# Drivers #
@@ -124,6 +129,10 @@
options.Update(env)
+
+env['CCFLAGS'] = Split(env['CCFLAGS'])
+env['CPPPATH'] = Split(env['CPPPATH'])
+env['LIBPATH'] = Split(env['LIBPATH'])
+
if env.has_key('use_distcc') and env['use_distcc']:
env['CC'] = 'distcc %s' % env['CC']
env['CXX'] = 'distcc %s' % env['CXX']
@@ -274,6 +283,15 @@
else:
print 'Configuring unknown system (assuming the system is POSIX-like) ...'
+ # pthreads
+ if str(Platform()) == 'posix':
+ if env['multithreaded']:
+ if conf.CheckCHeader('pthread.h') and conf.CheckLib('pthread', 'pthread_create', autoadd = 0):
+ env.Append(CCFLAGS = ['-pthread'])
+ env.Append(LINKFLAGS = ['-pthread'])
+ else:
+ Exit(1)
+
if OptionValue('boost_signals_namespace', env):
signals_namespace = OptionValue('boost_signals_namespace', env)
env.Append(CPPDEFINES = [
@@ -288,15 +306,6 @@
]
if not conf.CheckBoost(boost_version_string, boost_libs, conf, not ms_linker):
Exit(1)
-
- # pthreads
- if str(Platform()) == 'posix':
- if env['multithreaded']:
- if conf.CheckCHeader('pthread.h') and conf.CheckLib('pthread', 'pthread_create', autoadd = 0):
- env.Append(CCFLAGS = ['-pthread'])
- env.Append(LINKFLAGS = ['-pthread'])
- else:
- Exit(1)
# GL and GLU
if str(Platform()) == 'win32':

View File

@ -1,10 +1,10 @@
include/GG/AlignmentFlags.h
include/GG/Base.h
include/GG/BrowseInfoWnd.h
include/GG/Button.h
include/GG/Clr.h
include/GG/Config.h
include/GG/Config.h.in
include/GG/Control.h
include/GG/Cursor.h
include/GG/DrawUtil.h
include/GG/DropDownList.h
include/GG/DynamicGraphic.h
@ -12,13 +12,14 @@ include/GG/Edit.h
include/GG/Enum.h
include/GG/EventPump.h
include/GG/Exception.h
include/GG/Flags.h
include/GG/Font.h
include/GG/GUI.h
include/GG/Layout.h
include/GG/ListBox.h
include/GG/Menu.h
include/GG/MultiEdit.h
include/GG/OgreSDL/OgreSDLGUI.h
include/GG/Ogre/OgreGUI.h
include/GG/PluginInterface.h
include/GG/PtRect.h
include/GG/SDL/SDLGUI.h
@ -50,15 +51,16 @@ include/GG/dialogs/ColorDlg.h
include/GG/dialogs/FileDlg.h
include/GG/dialogs/ThreeButtonDlg.h
include/GG/gen_signals.py
include/GG/glext.h
include/GG/ltdl.h
include/GG/ltdl_config.h
lib/libGiGi.so
lib/libGiGi.so.%%SHLIB_VER%%
lib/libGiGi.so.0
lib/libGiGiSDL.so
lib/libGiGiSDL.so.%%SHLIB_VER%%
lib/libGiGiSDL.so.0
libdata/pkgconfig/GiGi.pc
libdata/pkgconfig/GiGiSDL.pc
@dirrm include/GG/dialogs
@dirrm include/GG/SDL
@dirrm include/GG/OgreSDL
@dirrm include/GG/Ogre
@dirrm include/GG