- Update to 2.6.0
- Update MASTER_SITES - Add my LOCAL to MASTER_SITES - Use USE_CSTD - Use MAKE_CMD - Reformat pkg-descr - Update WWW - Take maintainership - Bump PORTREVISION for devel/protobuf shlib change Changes: https://code.google.com/p/protobuf/source/browse/trunk/CHANGES.txt
This commit is contained in:
parent
b2304fa09e
commit
c86b04b3b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=369969
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= libosmpbf
|
||||
PORTVERSION= 1.3.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= astro geography devel
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= osmium
|
||||
PORTVERSION= git20130522
|
||||
PORTREVISION= 7
|
||||
PORTREVISION= 8
|
||||
CATEGORIES= astro geography devel
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= clementine
|
||||
PORTVERSION= 1.2.3
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= audio
|
||||
PKGNAMESUFFIX= -player
|
||||
|
||||
|
@ -4,7 +4,7 @@
|
||||
PORTNAME= mixxx
|
||||
PORTVERSION= 1.11.0
|
||||
DISTVERSIONSUFFIX= -src
|
||||
PORTREVISION= 8
|
||||
PORTREVISION= 9
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://downloads.mixxx.org/${PORTNAME}-${PORTVERSION}/
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= mumble
|
||||
PORTVERSION= 1.2.8
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= SF/${PORTNAME}/Mumble/${PORTVERSION}
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= murmur
|
||||
PORTVERSION= 1.2.8
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= audio net
|
||||
MASTER_SITES= SF/mumble/Mumble/${PORTVERSION}
|
||||
DISTNAME= mumble-${PORTVERSION}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= plinkseq
|
||||
PORTVERSION= 0.08
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= biology science
|
||||
MASTER_SITES= http://atgu.mgh.harvard.edu/${PORTNAME}/dist/version-${PORTVERSION}/
|
||||
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pinba
|
||||
PORTVERSION= 2012.03.20
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://github.com/tony2001/pinba_extension/tarball/${GITVERSION}/
|
||||
PKGNAMEPREFIX= php5-
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pinba_engine
|
||||
PORTVERSION= 2011.08.18
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://github.com/tony2001/pinba_engine/tarball/${GITVERSION}/
|
||||
DISTNAME= tony2001-pinba_engine-${GITVERSION}
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= protobuf-c
|
||||
PORTVERSION= 1.0.2
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= https://github.com/${GITHUB_USER}/${GITHUB_REPO}/releases/download/v${PORTVERSION}/ \
|
||||
http://github.com/${GITHUB_USER}/${GITHUB_REPO}/releases/download/v${PORTVERSION}/
|
||||
|
@ -2,28 +2,28 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= protobuf
|
||||
PORTVERSION= 2.5.0
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 2.6.0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
MASTER_SITES= https://protobuf.googlecode.com/svn/rc/ \
|
||||
LOCAL/sunpoet
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= sunpoet@FreeBSD.org
|
||||
COMMENT= Data interchange format library
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING.txt
|
||||
|
||||
CFLAGS+= -DGOOGLE_PROTOBUF_NO_RTTI
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= gmake pathfix pkgconfig tar:bzip2 libtool
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
INSTALL_TARGET= install-strip
|
||||
ONLY_FOR_ARCHS= amd64 i386
|
||||
USE_LDCONFIG= yes
|
||||
USES= gmake libtool pathfix pkgconfig tar:bzip2
|
||||
|
||||
# clang will generate code that just doesn't work with clementine-player
|
||||
# Clang will generate code that just doesn't work with clementine-player
|
||||
# if this isn't compiled as though it were C99.
|
||||
CFLAGS+= -std=c99 -DGOOGLE_PROTOBUF_NO_RTTI
|
||||
USE_CSTD= c99
|
||||
|
||||
tests: build
|
||||
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
|
||||
regression-test test: build
|
||||
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} check
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (protobuf-2.5.0.tar.bz2) = 13bfc5ae543cf3aa180ac2485c0bc89495e3ae711fc6fab4f8ffe90dfb4bb677
|
||||
SIZE (protobuf-2.5.0.tar.bz2) = 1866763
|
||||
SHA256 (protobuf-2.6.0.tar.bz2) = 0a2f8533b2e0587a2b4efce0c4c8aea21bbfae1c41c466634d958dedf580f6aa
|
||||
SIZE (protobuf-2.6.0.tar.bz2) = 2021255
|
||||
|
@ -1,10 +0,0 @@
|
||||
--- src/google/protobuf/testing/zcgunzip.cc.orig 2014-09-30 23:01:39.718744075 +0800
|
||||
+++ src/google/protobuf/testing/zcgunzip.cc 2014-09-30 23:02:05.753740335 +0800
|
||||
@@ -44,6 +44,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
+#include <unistd.h> // for STDOUT_FILENO
|
||||
|
||||
#include <google/protobuf/io/gzip_stream.h>
|
||||
#include <google/protobuf/io/zero_copy_stream_impl.h>
|
@ -1,10 +0,0 @@
|
||||
--- src/google/protobuf/testing/zcgzip.cc.orig 2014-09-30 22:46:34.571804492 +0800
|
||||
+++ src/google/protobuf/testing/zcgzip.cc 2014-09-30 22:46:50.657816315 +0800
|
||||
@@ -43,6 +43,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <fcntl.h>
|
||||
+#include <unistd.h> // for STDOUT_FILENO
|
||||
|
||||
#include <google/protobuf/io/gzip_stream.h>
|
||||
#include <google/protobuf/io/zero_copy_stream_impl.h>
|
@ -1,5 +1,5 @@
|
||||
Protocol Buffers are a way of encoding structured data in an efficient yet
|
||||
extensible format. Google uses Protocol Buffers for almost all of its
|
||||
internal RPC protocols and file formats.
|
||||
extensible format. Google uses Protocol Buffers for almost all of its internal
|
||||
RPC protocols and file formats.
|
||||
|
||||
WWW: http://code.google.com/p/protobuf/
|
||||
WWW: https://code.google.com/p/protobuf/
|
||||
|
@ -21,6 +21,7 @@ include/google/protobuf/generated_message_util.h
|
||||
include/google/protobuf/io/coded_stream.h
|
||||
include/google/protobuf/io/gzip_stream.h
|
||||
include/google/protobuf/io/printer.h
|
||||
include/google/protobuf/io/strtod.h
|
||||
include/google/protobuf/io/tokenizer.h
|
||||
include/google/protobuf/io/zero_copy_stream.h
|
||||
include/google/protobuf/io/zero_copy_stream_impl.h
|
||||
@ -31,17 +32,21 @@ include/google/protobuf/reflection_ops.h
|
||||
include/google/protobuf/repeated_field.h
|
||||
include/google/protobuf/service.h
|
||||
include/google/protobuf/stubs/atomicops.h
|
||||
include/google/protobuf/stubs/atomicops_internals_arm64_gcc.h
|
||||
include/google/protobuf/stubs/atomicops_internals_arm_gcc.h
|
||||
include/google/protobuf/stubs/atomicops_internals_arm_qnx.h
|
||||
include/google/protobuf/stubs/atomicops_internals_atomicword_compat.h
|
||||
include/google/protobuf/stubs/atomicops_internals_generic_gcc.h
|
||||
include/google/protobuf/stubs/atomicops_internals_macosx.h
|
||||
include/google/protobuf/stubs/atomicops_internals_mips_gcc.h
|
||||
include/google/protobuf/stubs/atomicops_internals_pnacl.h
|
||||
include/google/protobuf/stubs/atomicops_internals_tsan.h
|
||||
include/google/protobuf/stubs/atomicops_internals_x86_gcc.h
|
||||
include/google/protobuf/stubs/atomicops_internals_x86_msvc.h
|
||||
include/google/protobuf/stubs/common.h
|
||||
include/google/protobuf/stubs/once.h
|
||||
include/google/protobuf/stubs/platform_macros.h
|
||||
include/google/protobuf/stubs/stl_util.h
|
||||
include/google/protobuf/stubs/template_util.h
|
||||
include/google/protobuf/stubs/type_traits.h
|
||||
include/google/protobuf/text_format.h
|
||||
@ -51,15 +56,15 @@ include/google/protobuf/wire_format_lite.h
|
||||
include/google/protobuf/wire_format_lite_inl.h
|
||||
lib/libprotobuf-lite.a
|
||||
lib/libprotobuf-lite.so
|
||||
lib/libprotobuf-lite.so.8
|
||||
lib/libprotobuf-lite.so.8.0.0
|
||||
lib/libprotobuf-lite.so.9
|
||||
lib/libprotobuf-lite.so.9.0.0
|
||||
lib/libprotobuf.a
|
||||
lib/libprotobuf.so
|
||||
lib/libprotobuf.so.8
|
||||
lib/libprotobuf.so.8.0.0
|
||||
lib/libprotobuf.so.9
|
||||
lib/libprotobuf.so.9.0.0
|
||||
lib/libprotoc.a
|
||||
lib/libprotoc.so
|
||||
lib/libprotoc.so.8
|
||||
lib/libprotoc.so.8.0.0
|
||||
lib/libprotoc.so.9
|
||||
lib/libprotoc.so.9.0.0
|
||||
libdata/pkgconfig/protobuf-lite.pc
|
||||
libdata/pkgconfig/protobuf.pc
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= tesla
|
||||
DISTVERSION= 0.0.20140425
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel lang
|
||||
|
||||
MAINTAINER= brooks@FreeBSD.org
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pink-pony
|
||||
PORTVERSION= 1.3.1
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= GOOGLE_CODE \
|
||||
http://mirror.amdmi3.ru/distfiles/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= pokerth
|
||||
PORTVERSION= 1.1.1
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.1
|
||||
DISTNAME= PokerTH-${PORTVERSION}-src
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= mozc
|
||||
PORTVERSION= 1.15.1868.102
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= japanese
|
||||
MASTER_SITES= LOCAL/hrs
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= namecoin
|
||||
PORTVERSION= Q.3.72
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= net-p2p dns
|
||||
MASTER_SITES= GH
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= mosh
|
||||
PORTVERSION= 1.2.4
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://mosh.mit.edu/ \
|
||||
http://mirrors.rit.edu/zi/
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= ostinato
|
||||
PORTVERSION= 0.5.1
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net security
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
|
||||
DISTNAME= ${PORTNAME}-src-${PORTVERSION}${EXTRACTSUFFIX}
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= chromium
|
||||
PORTVERSION= 37.0.2062.124
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://commondatastorage.googleapis.com/chromium-browser-official/
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
Loading…
Reference in New Issue
Block a user