1. Update 1.0.3 --> 1.3-rc7
2. Update master site list 3. As 5.x already ships with it's own pam_krb5, configure the port to only install on 4.x systems.
This commit is contained in:
parent
944ee2c819
commit
c84de390ec
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99427
@ -6,18 +6,30 @@
|
||||
#
|
||||
|
||||
PORTNAME= pam_krb5
|
||||
PORTVERSION= 1.0.3
|
||||
PORTVERSION= 1.3.r7
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://www.komquats.com/distfiles/
|
||||
MASTER_SITES= http://unc.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://umn.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://twtelecom.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://aleron.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://easynews.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://switch.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://cesnet.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://flow.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://easynews.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://keihanna.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://heanet.dl.sourceforge.net/sourceforge/pam-krb5/ \
|
||||
http://www.komquats.com/distfiles/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
|
||||
|
||||
MAINTAINER= cy@FreeBSD.org
|
||||
COMMENT= A Pluggable Authentication Module for Kerberos 5
|
||||
|
||||
MAN8= pam_krb5.8
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_PERL5= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
.if defined(PACKAGE_BUILDING)
|
||||
KRB5_IMPL= mit
|
||||
@ -37,21 +49,24 @@ KRB5_DIR?= ${KRB5_HOME}
|
||||
BROKEN= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
|
||||
.endif
|
||||
|
||||
.if defined(PREFIX)
|
||||
MANDIR= ${PREFIX}/man
|
||||
.else
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500000
|
||||
BROKEN= FreeBSD 5.x already ships with its own version of pam_krb5
|
||||
.endif
|
||||
MANDIR= ${MANPREFIX}/man
|
||||
PREFIX= ${DESTDIR}/usr
|
||||
MANPREFIX= ${DESTDIR}/usr/share
|
||||
MANDIR= ${PREFIX}/share/man
|
||||
.endif
|
||||
KRB5_DIR?= ${LOCALBASE}
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS}"
|
||||
CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
|
||||
--with-pamdir="${PREFIX}/lib" \
|
||||
--with-man-sect=8 \
|
||||
--mandir=${MANDIR}
|
||||
--mandir=${MANDIR} \
|
||||
--without-krbafs
|
||||
|
||||
post-install:
|
||||
cd ${WRKSRC} && ${MAKE} install-man
|
||||
cd ${WRKSRC} && ${GMAKE} install-man
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (pam_krb5-1.0.3.tar.bz2) = 9a3b26dc8a52e9882bdaf41f8e50d721
|
||||
MD5 (pam_krb5-1.3-rc7.tar.gz) = 2c7c8974604e5c325bb2e62d0066cdce
|
||||
|
11
security/pam_krb5/files/patch-configure
Normal file
11
security/pam_krb5/files/patch-configure
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.orig Mon Mar 17 09:31:46 2003
|
||||
+++ configure Wed Jan 21 15:26:38 2004
|
||||
@@ -11043,7 +11043,7 @@
|
||||
# Check whether --with-krbafs or --without-krbafs was given.
|
||||
if test "${with_krbafs+set}" = set; then
|
||||
withval="$with_krbafs"
|
||||
- if test x$withval != xyes ; then
|
||||
+ if test x$withval != xyes -a x$withval != xno; then
|
||||
KRBAFS=$withval
|
||||
CPPFLAGS="-I$withval/include $CPPFLAGS"
|
||||
CFLAGS="-I$withval/include $CFLAGS"
|
@ -1,12 +0,0 @@
|
||||
*** pam_krb5_sess.c.orig Sat Sep 7 10:42:40 2002
|
||||
--- pam_krb5_sess.c Sat Sep 7 10:43:02 2002
|
||||
***************
|
||||
*** 9,14 ****
|
||||
--- 9,15 ----
|
||||
static const char rcsid[] = "$Id: pam_krb5_sess.c,v 1.1.1.1.2.5 2001/09/24 14:58:15 nectar Exp $";
|
||||
|
||||
#include <krb5.h>
|
||||
+ #include <syslog.h>
|
||||
#include "pam_krb5.h"
|
||||
|
||||
/* Initiate session management */
|
10
security/pam_krb5/files/patch-pam_krb5afs.c
Normal file
10
security/pam_krb5/files/patch-pam_krb5afs.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- pam_krb5afs.c.orig Mon Mar 10 15:37:00 2003
|
||||
+++ pam_krb5afs.c Wed Jan 21 15:19:16 2004
|
||||
@@ -108,7 +108,6 @@
|
||||
#define MODULE_RET_NAME MODULE_NAME "_ret_stash"
|
||||
|
||||
#define PAM_SM_AUTH
|
||||
-#define PAM_SM_ACCT_MGMT
|
||||
#define PAM_SM_SESSION
|
||||
#define PAM_SM_PASSWORD
|
||||
|
@ -1,2 +1,2 @@
|
||||
lib/pam_krb5.so
|
||||
lib/pam_krb5.so.1
|
||||
lib/pam_krb5.la
|
||||
|
Loading…
Reference in New Issue
Block a user