biology/bioawk: BWK awk modified for biological data

Bioawk is an extension to Brian Kernighan's awk, adding the support of several
common biological data formats, including optionally gzip'ed BED, GFF, SAM,
VCF, FASTA/Q and TAB-delimited formats with column names. It also adds a few
built-in functions and an command line option to use TAB as the input/output
delimiter. When the new functionality is not used, bioawk is intended to behave
exactly the same as the original BWK awk.
This commit is contained in:
Jason W. Bacon 2020-06-05 02:45:33 +00:00
parent a156fdcf52
commit c81fc00817
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=537983
5 changed files with 79 additions and 0 deletions

View File

@ -10,6 +10,7 @@
SUBDIR += bamtools
SUBDIR += bcftools
SUBDIR += bedtools
SUBDIR += bioawk
SUBDIR += biococoa
SUBDIR += bolt-lmm
SUBDIR += bowtie

24
biology/bioawk/Makefile Normal file
View File

@ -0,0 +1,24 @@
# $FreeBSD$
PORTNAME= bioawk
DISTVERSIONPREFIX= v
DISTVERSION= 1.0-7
DISTVERSIONSUFFIX= -gfd40150
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
COMMENT= BWK awk modified for biological data
LICENSE= BSD3CLAUSE
USE_GITHUB= yes
GH_ACCOUNT= lh3
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= bioawk
INSTALL_TARGET= install-strip
PLIST_FILES= bin/bioawk
.include <bsd.port.mk>

3
biology/bioawk/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1591283068
SHA256 (lh3-bioawk-v1.0-7-gfd40150_GH0.tar.gz) = 4510ee9493d0acef846e66f7b370c83e6e731954437ef6128a2e0b1fa8a38874
SIZE (lh3-bioawk-v1.0-7-gfd40150_GH0.tar.gz) = 72209

View File

@ -0,0 +1,43 @@
--- Makefile.orig 2017-09-11 13:43:01 UTC
+++ Makefile
@@ -22,14 +22,20 @@
# THIS SOFTWARE.
# ****************************************************************/
-CFLAGS = -g -Wall -O2
+CFLAGS ?= -g -Wall -O2
-CC = gcc
+CC ?= gcc
-YACC = bison -y
+# YACC = bison -y
YACC = yacc
YFLAGS = -d
+MKDIR ?= mkdir
+INSTALL ?= install
+DESTDIR ?= .
+PREFIX ?= /usr/local
+STRIP ?= strip
+
OFILES = b.o main.o parse.o proctab.o tran.o lib.o run.o lex.o addon.o
SOURCE = awk.h ytab.c ytab.h proto.h awkgram.y lex.c b.c main.c \
@@ -61,5 +67,15 @@ maketab: ytab.h maketab.c
names:
@echo $(LISTING)
+.PHONY: intall-strip install clean
+
+install-strip: install
+ ${STRIP} ${DESTDIR}${PREFIX}/bin/bioawk
+
+install:
+ ${MKDIR} -p ${DESTDIR}${PREFIX}/bin
+ ${INSTALL} -c bioawk ${DESTDIR}${PREFIX}/bin
+
clean:
- rm -fr a.out *.o *.obj maketab maketab.exe *.bb *.bbg *.da *.gcov *.gcno *.gcda awk bioawk ytab.* proctab.c *.dSYM
+ rm -fr a.out *.o *.obj maketab maketab.exe *.bb *.bbg *.da *.gcov \
+ *.gcno *.gcda awk bioawk ytab.* proctab.c *.dSYM

8
biology/bioawk/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
Bioawk is an extension to Brian Kernighan's awk, adding the support of several
common biological data formats, including optionally gzip'ed BED, GFF, SAM,
VCF, FASTA/Q and TAB-delimited formats with column names. It also adds a few
built-in functions and an command line option to use TAB as the input/output
delimiter. When the new functionality is not used, bioawk is intended to behave
exactly the same as the original BWK awk.
WWW: https://github.com/lh3/bioawk