fix build on -current

PR:		46600
Submitted by:	Ports Fury
This commit is contained in:
Ying-Chieh Liao 2002-12-29 05:19:29 +00:00
parent 38aff81bad
commit c807fd461a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71970
21 changed files with 739 additions and 178 deletions

View File

@ -18,19 +18,17 @@ PATCH_DIST_STRIP=-p1
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= ${LOCALBASE}/lib/libnetpbm.a:${PORTSDIR}/graphics/netpbm
LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
EXTRACT_ONLY= urt-3.1b.tar.Z
NO_WRKSUBDIR= yes
USE_XLIB= yes
INSTALLS_SHLIB= yes
NO_WRKSUBDIR= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= config/urt
HAS_CONFIGURE= yes
MAKEFILE= makefile
ALL_TARGET=
ALL_TARGET= # none
INSTALLS_SHLIB= yes
MAN1= aliastorle.1 applymap.1 avg4.1 crop.1 cubitorle.1 dvirle.1 \
fant.1 getx11.1 giftorle.1 graytorle.1 into.1 mcut.1 mergechan.1\
@ -56,22 +54,17 @@ MAN3= buildmap.3 bwdithermap.3 colorquant.3 dither.3 ditherbw.3 \
rle_puteof.3 rle_putraw.3 rle_putrow.3 rle_raw_alloc.3 \
rle_raw_free.3 rle_rawtorow.3 rle_row_alloc.3 rle_row_free.3 \
rle_skiprow.3
#Note: Don't compress man5, it won't work !
MAN5= rle.5
MLINKS= rle.5 RLE.5
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/urt ${PREFIX}/share/examples/urt
cd ${PREFIX}/share/doc/urt; \
${TAR} xf $(DISTDIR)/urt-doc.tar; \
cd doc; \
${FIND} -d . | cpio -dump ..; \
cd ..; \
${RM} -rf doc; \
cd ${PREFIX}/share/examples/urt; \
${TAR} xf $(DISTDIR)/urt-img.tar; \
${CHOWN} -R root:wheel . ; \
${FIND} . -type d -exec ${CHMOD} 755 '{}' \; ; \
${FIND} . -type f -exec ${CHMOD} 644 '{}' \;
@${MKDIR} ${DOCSDIR}
cd ${WRKDIR}/doc && ${FIND} . | \
cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKDIR} && ${FIND} img | \
cpio -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

View File

@ -1,96 +0,0 @@
diff -ur ../urt-3.1b-orig/get/getx11/in_cmap.c ./get/getx11/in_cmap.c
--- ../urt-3.1b-orig/get/getx11/in_cmap.c Thu Apr 30 10:17:16 1992
+++ ./get/getx11/in_cmap.c Sat Sep 16 11:16:59 1995
@@ -70,10 +70,10 @@
if ( img->sep_colors ||
(img->img_channels == 1 && img->ncmap == 3 && img->cmlen) )
/* If using color map directly, apply display gamma, too. */
- img->in_cmap = buildmap( img_hdr, 3, img->gamma,
+ img->in_cmap = buildmap( img_hdr, 3, (double) img->gamma,
display_gamma );
else
- img->in_cmap = buildmap( img_hdr, 3, img->gamma, 1.0 );
+ img->in_cmap = buildmap( img_hdr, 3, (double) img->gamma, 1.0 );
for (i = 0; i < 3; i++ ) {
for (j = 0; j < 256; j++)
diff -ur ../urt-3.1b-orig/include/rle_config.tlr ./include/rle_config.tlr
--- ../urt-3.1b-orig/include/rle_config.tlr Thu Apr 30 10:06:23 1992
+++ ./include/rle_config.tlr Sat Sep 16 11:31:57 1995
@@ -48,7 +48,7 @@
#endif /* NO_DECLARE_MALLOC */
#ifdef USE_PROTOTYPES
-extern char *getenv( CONST_DECL char *name );
+extern char *getenv( CONST_DECL char *CONST_DECL name);
#else
extern char *getenv();
#endif
diff -ur ../urt-3.1b-orig/lib/buildmap.c ./lib/buildmap.c
--- ../urt-3.1b-orig/lib/buildmap.c Thu Feb 27 18:17:01 1992
+++ ./lib/buildmap.c Sat Sep 16 12:11:12 1995
@@ -26,6 +26,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include "rle.h"
#include <math.h>
diff -ur ../urt-3.1b-orig/makefile.src ./makefile.src
--- ../urt-3.1b-orig/makefile.src Fri Jun 7 11:58:13 1991
+++ ./makefile.src Fri Sep 15 22:09:01 1995
@@ -17,7 +17,7 @@
# clean deletes all but source, pristine (below) deletes installed stuff, too
default clean: doit
@for d in $(DIRS) ; do \
- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
+ ( cd $$d ; echo make $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
done
# install puts library, binaries and documentation into global location
@@ -29,7 +29,7 @@
install $(MAKE_TARGET) pristine depend:: doit
@for d in $(ALLDIRS) ; do \
- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
+ ( cd $$d ; echo make $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
done
diff -ur ../urt-3.1b-orig/tools/into.c ./tools/into.c
--- ../urt-3.1b-orig/tools/into.c Thu Apr 30 10:10:15 1992
+++ ./tools/into.c Sat Sep 16 10:32:26 1995
@@ -41,7 +41,10 @@
short forceflg; /* overwrite an unwritable file?
*/
extern int errno;
+
+#ifndef BSD
extern char *sys_errlist[];
+#endif
void
main(argc, argv)
diff -ur ../urt-3.1b-orig/tools/makefile.src ./tools/makefile.src
--- ../urt-3.1b-orig/tools/makefile.src Tue Jan 28 15:47:42 1992
+++ ./tools/makefile.src Sat Sep 16 10:33:14 1995
@@ -68,7 +68,7 @@
fant.out: fant.o mallocNd.o
$(CC) $(CFLAGS) -I$(RI) fant.o mallocNd.o $(LIBS) -lm -o fant.new
mv fant.new fant.out
-
+
# rlebox and crop use some common code.
rle_box.o: $(RI)/rle.h $(RI)/rle_config.h $(RI)/rle_raw.h
@@ -82,7 +82,7 @@
# rleClock has it's own directory, must be built special
rleClock.out: clock/font.c clock/font.h clock/font.src clock/rleClock.c
- (cd clock ; make)
+ (cd clock ; $(MAKE))
# Incremental install, copies everything ("$?") since last install to DEST dir.
install: $(PGMS) install-pgm

View File

@ -1,34 +0,0 @@
--- man/makefile.src.orig Thu Feb 27 22:26:52 1992
+++ man/makefile.src Wed Feb 11 09:22:16 1998
@@ -211,7 +211,6 @@
# Put the manual pages into a global location
install: install-1 install-3 install-5
- touch install
install-1: $(PAGES1)
@-sh -c "if test '$(DEST)X' != X ; then \
@@ -223,7 +222,6 @@
else \
true ; \
fi"
- touch install-1
install-3: $(PAGES3)
@-sh -c "if test '$(DEST)X' != X ; then \
@@ -235,7 +233,6 @@
else \
true ; \
fi"
- touch install-3
install-5: man5/*.5
@-sh -c "if test $(DEST)X != X; then \
@@ -243,7 +240,6 @@
cp $? $(DEST5); \
else true; \
fi"
- touch install-5
# Clean up installed man pages
pristine:

View File

@ -1,10 +0,0 @@
--- include/makefile.src.orig Sun Oct 4 23:45:39 1998
+++ include/makefile.src Sun Oct 4 23:45:50 1998
@@ -44,7 +44,6 @@
else \
true ; \
fi"
- touch install
# Nothing to clean
clean:

View File

@ -0,0 +1,11 @@
--- cnv/tex/makefile.src.orig Sat Jun 8 00:57:32 1991
+++ cnv/tex/makefile.src Sat Dec 28 00:47:13 2002
@@ -39,7 +39,7 @@
install-scripts: $(SCRIPTS)
for pgm in $?; do d=$(DEST)/`basename $$pgm .sh`; \
- cp $$pgm $$d; chmod +x $$d; done
+ ${BSD_INSTALL_SCRIPT} $$pgm $$d; chmod +x $$d; done
touch install-scripts
# Default rule for making a program from its .c file.

View File

@ -0,0 +1,253 @@
--- config/hp700-hpux10.orig Fri Dec 27 23:02:36 2002
+++ config/hp700-hpux10 Fri Dec 27 23:02:36 2002
@@ -0,0 +1,250 @@
+# Configuration file for HP 9000/700 series running HP-UX 10.01 with gcc
+# Note that you will probably need to change the INCX11 directive at the
+# end of this file
+
+#quiet on
+
+# Configuration file for the URT raster toolkit package. Modify all
+# entries in this file.
+
+# This file should be the only thing you have to edit to configure the
+# toolkit for a new system. If you are adding capabilities, please
+# keep this in mind and be sure to make those capabilities configurable
+# from this file.
+
+# The file "makefile.hdr" contains code common to all makefiles. It
+# should not be necessary to edit that file.
+
+# The following define the available "hardware" display configuration.
+# Remove one # sign to define a symbol (i.e., leaving #define at the
+# beginning of the line.)
+
+# Displays
+##define AMIGA Amiga computer display.
+##define APOLLO Apollo computer display.
+##define BOBCAT HP "bobcat" 9000 series (with Starbase).
+##define CX3D Chromatics CX3D system.
+##define FB BRL extended frame buffer library.
+##define GETICR Display for NCSA telnet. Requires PBMPLUS tools.
+##define GRINNELL Grinnell GMR27 frame buffer.
+##define HPQCR Matrix QCR-Z attached to HP series 300.
+##define IRIS Silicon Graphics Iris 2000/3000.
+##define IRIS4D Silicon Graphics Iris/4D.
+##define NEXT NeXT computer display.
+##define ORION High-Level Hardware Orion display.
+##define SUNTOOLS For Suns running SunTools.
+##define TAAC1 Suns with TAAC-1 board.
+##define X10 X10 Window system.
+#define X11 X11 Window system.
+
+# Conversion programs
+#define ABEKASA60 Abekas A60 conversions.
+#define ABEKASA62 Abekas A62 conversions.
+#define ALIAS Alias conversions.
+##define CGM RLE to CGM conversion.
+#define CUBICOMP Cubicomp conversions.
+#define GIF GIF image conversions.
+#define GRAYFILES Grayscale conversions.
+##define SGICONV SGI Image conversions.
+#define MACPAINT Macpaint conversions.
+##define PBMPLUS PBMPLUS conversions.
+#define POSTSCRIPT Postscript conversions.
+##define SUNRASTER For Sun raster conversions.
+#define TARGA Targa format conversions.
+##define TIFF TIFF image conversions.
+#define TIFF2p4 Define if libtiff is version 2.4 or greater
+#define VICAR VICAR image conversions.
+#define WASATCH Wasatch Paintbox conversions.
+#define WAVEFRONT Wavefront RLA file conversions.
+
+# The dvirle program requires the Maryland MC-TeX library. See the
+# README file in the cnv/tex subdirectory.
+##define DVIRLE Compile dvirle program
+
+# Control C compilation flags. Define according to your compiler.
+
+##define APOLLOCC Apollo computer.
+##define CONVEXCC Convex C 4.0 or greater
+##define CRAY2CC Cray-2 running UNICOS.
+#define GCC Gcc compiler.
+##define HPUX300CC HP 9000/300 running HP-UX.
+#define HPUX800CC HP 9000/800 running HP-UX.
+##define IBMR6000CC IBM RS6000.
+##define IRIS4DCC Silicon Graphics Iris 4D.
+##define IRISCC Silicon Graphics Iris 2400/3000.
+##define SUNCC Sun 3 computers.
+##define 386IXCC SVr3 386/ix 2.2
+
+# You can put any system dependent flags here.
+ExtraCFLAGS =
+
+# System specific or configuration parameters. Define according to your
+# environment and desires.
+
+##define ABEKAS_PAL Convert to PAL format in Abekas A60 tool.
+##define ALL_MAN Print/install all man pages.
+##define CONST_DECL If your compiler understands 'const' (ANSI)
+##define FILE_NAME_14_CHARS If filenames are limited to 14 characters.
+##define HAVE_CPROTO If you have the cproto command. Not normally required.
+##define NEED_BSTRING Your libc does not have bcopy or bzero (Sys V probably)
+##define NEED_GETOPT Your libc does not have the getopt function (BSD)
+##define NEED_RENAME Your libc does not have the rename function (Sys V)
+#define NEED_SETLINEBUF Your stdio does not have setlinebuf (Sys V)
+##define NO_MAKE_MAKEFILE If you don't want a "makefile" action.
+##define NO_OPEN_PIPES If file "names" "|..." and "*.Z" are not special.
+#define NO_RANLIB You don't have the ranlib program (Sys V)
+##define NO_ITIMER You don't have setitimer (e.g., Cray 2).
+##define NO_TOOLS Don't build tool directory.
+##define STDIO_NEEDS_BINARY Your fopen() needs "b" specified for binary io
+##define USE_TIME_H You need to include time.h for time_t (Sys V)
+#define SYS_V_SETPGRP Your system has the SysV setpgrp() call.
+##define USE_L_FLAG Use -Llibdir -lrle instead of libdir/liblre.a.
+#define USE_PROTOTYPES Declare library functions with ANSI-C prototypes.
+##define USE_RANDOM Your libc has the BSD random() function.
+#define USE_SHARED_LIB You want to link to shared libraries as possible.
+##define USE_STDARG Use 'stdarg' instead of 'varargs' (ANSI).
+##define USE_STDLIB_H You have "stdlib.h".
+##define USE_UNISTD_H You have "unistd.h".
+#define USE_STRING_H You have "string.h", not "strings.h"
+#define VOID_STAR Your C compiler understands the 'void *' declaration.
+##define USE_XLIBINT_H You have the include file <X11/Xlibint.h>.
+##define X_SHARED_MEMORY You have the XShm extension.
+
+# DEST is where all programs will be put. Can be overridden for specific
+# directories below.
+# RI is where the include files live. You probably shouldn't change this.
+# RL is where the tool directories find the RLE library. You can change
+# this, but see the README instructions about making the toolkit in this
+# case.
+
+# Path names not starting with a / are relative to this directory.
+# Path names starting with a / are absolute.
+
+#defpath DEST bin
+#defpath RI include
+#defpath RL lib
+
+# Note! LIB_DEST, INC_DEST, and MAN_DEST must be defined for the
+# library, include files, or manual pages, respectively, to be
+# installed anywhere.
+
+##defpath MAN_DEST /usr/site/man
+##defpath LIB_DEST
+##defpath GET_DEST
+##defpath CNV_DEST
+##defpath TOOLS_DEST
+##defpath INC_DEST
+
+# Control of formatting. If your "roff" program needs to be piped to
+# something to print, set ROFFPIPE to (e.g.) "| lpr"
+ROFF = nroff
+ROFFOPT = -man
+ROFFPIPE = | lpr
+
+# Stuff you like to have removed from directories to "make clean"
+OTHERJUNK = core *~ #*#
+
+# Files needed for the various options above.
+#ifdef BOBCAT
+#ifdef USE_SHARED_LIB
+LDOPTS = -a shared
+LIBBOBCAT = -L /usr/lib/X11R4 -lXwindow -lsb -ldld -lXhp11 -lX11
+# #endif /* shared library */
+# #ifndef USE_SHARED_LIB
+#else
+LDOPTS = -a archive
+LIBBOBCAT = -L /usr/lib/X11R4 -lXwindow -ldd98705 -ldd98721 -ldd98731 -ldd98736
+-lddgcrx -lddbyte -lddsox11 -lsb1 -lsb2 -lXhp11 -lX11
+#endif /* archive library */
+#endif /* BOBCAT */
+
+#ifdef CGM
+# Path to directory where CGM library and include files may be found
+# Absolute or relative to URT root
+#defpath CGMDIR
+INCCGM = -I$(CGMDIR)
+LIBCGM = $(CGMDIR)/libcgm.a
+#endif
+
+#ifdef CX3D
+# Where are the include files for the CX3D
+INCCX3D = /usr/site/include
+LIBCX3D = -lcx3d
+#endif
+
+#ifdef DVIRLE
+#define DVIRLE_LIBSUBDIR Defined if LIBMCTEX is under cnv/tex directory
+# The MC-TeX library.
+LIBMCTEX = lib/lib.a # Note! relative to cnv/tex directory
+# Where to find the MC-TeX include files.
+INCMCTEX = h # Note! relative to cnv/tex directory
+# where to find the font description file
+CONFFILE = /usr/local/lib/tex/fontdesc
+#endif
+
+#ifdef FB
+LIBFB = /usr/brl/lib/libfb.a
+#endif
+
+#ifdef GRINNELL
+# Library containing GMR27 functions.
+LIBGRINNELL = -lfb
+#endif
+
+#ifdef HPQCR
+# HP device io library.
+LIBHPQCR = -ldvio
+#endif
+
+#ifdef IRIS
+LIBIRIS = -Zg
+#endif
+
+#ifdef IRIS4D
+LIBIRIS4D = -lgl_s
+#endif
+
+#ifdef PBMPLUS
+# PBMDIR should refer to the root of your PBM source tree.
+# If relative, it's relative to root of URT source tree.
+#defpath PBMDIR
+
+INCPBMPLUS = -I$(PBMDIR) -I$(PBMDIR)/ppm -I$(PBMDIR)/pgm -I$(PBMDIR)/pbm
+LIBPBMPLUS = $(PBMDIR)/ppm/libppm.a $(PBMDIR)/pgm/libpgm.a \
+ $(PBMDIR)/pbm/libpbm.a
+#endif
+
+#ifdef SUNRASTER|SUNTOOLS|TAAC1
+LIBSUNTOOLS_COM = -lsuntool -lsunwindow -lpixrect
+#endif
+
+#ifdef SUNRASTER
+LIBSUNRASTER = $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef SUNTOOLS
+LIBSUNTOOLS = $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef TAAC1
+LIBTAAC1 = -ltaac1 $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef TIFF
+# Location of tiff library and include files. Relative to URT root directory.
+#defpath TIFFDIR
+INCTIFF = -I$(TIFFDIR)
+LIBTIFF = $(TIFFDIR)/libtiff.a
+#endif
+
+#ifdef X10
+LIBX10 = -lX
+INCX10 =
+#endif
+
+#ifdef X11
+# Fetch the X11 library from /usr/lib/X11R4/libX11.sl
+LIBX11 = /usr/lib/X11R4/libX11.sl
+# You will probably need to change this
+INCX11 = -I/usr/sww/X11/include
+#endif

View File

@ -0,0 +1,243 @@
--- config/sol2-5.orig Fri Dec 27 23:02:36 2002
+++ config/sol2-5 Fri Dec 27 23:02:36 2002
@@ -0,0 +1,240 @@
+# Solaris 2.x configuration file. (Tested on Solaris2.4 and 2.5)
+# With X11
+# All conversion programs compiled.
+
+##quiet on
+
+# Configuration file for the URT raster toolkit package. Modify all
+# entries in this file.
+
+# This file should be the only thing you have to edit to configure the
+# toolkit for a new system. If you are adding capabilities, please
+# keep this in mind and be sure to make those capabilities configurable
+# from this file.
+
+# The file "makefile.hdr" contains code common to all makefiles. It
+# should not be necessary to edit that file.
+
+# The following define the available "hardware" display configuration.
+# Remove one # sign to define a symbol (i.e., leaving #define at the
+# beginning of the line.)
+
+# Displays
+##define AMIGA Amiga computer display.
+##define APOLLO Apollo computer display.
+##define BOBCAT HP "bobcat" 9000 series (with Starbase).
+##define CX3D Chromatics CX3D system.
+##define FB BRL extended frame buffer library.
+##define GETICR Display for NCSA telnet. Requires PBMPLUS tools.
+##define GRINNELL Grinnell GMR27 frame buffer.
+##define HPQCR Matrix QCR-Z attached to HP series 300.
+##define IRIS Silicon Graphics Iris 2000/3000.
+##define IRIS4D Silicon Graphics Iris/4D.
+##define NEXT NeXT computer display.
+##define ORION High-Level Hardware Orion display.
+##define SUNTOOLS For Suns running SunTools.
+##define TAAC1 Suns with TAAC-1 board.
+##define X10 X10 Window system.
+#define X11 X11 Window system.
+
+# Conversion programs
+#define ABEKASA60 Abekas A60 conversions.
+#define ABEKASA62 Abekas A62 conversions.
+#define ALIAS Alias conversions.
+##define CGM RLE to CGM conversion.
+#define CUBICOMP Cubicomp conversions.
+#define GIF GIF image conversions.
+#define GRAYFILES Grayscale conversions.
+##define SGICONV SGI Image conversions.
+#define MACPAINT Macpaint conversions.
+##define PBMPLUS PBMPLUS conversions.
+#define POSTSCRIPT Postscript conversions.
+##define SUNRASTER For Sun raster conversions.
+#define TARGA Targa format conversions.
+##define TIFF TIFF image conversions.
+#define TIFF2p4 Define if libtiff is version 2.4 or greater
+#define VICAR VICAR image conversions.
+#define WASATCH Wasatch Paintbox conversions.
+##define WAVEFRONT Wavefront RLA file conversions.
+
+# The dvirle program requires the Maryland MC-TeX library. See the
+# README file in the cnv/tex subdirectory.
+##define DVIRLE Compile dvirle program
+
+# Control C compilation flags. Define according to your compiler.
+
+##define APOLLOCC Apollo computer.
+##define CONVEXCC Convex C 4.0 or greater
+##define CRAY2CC Cray-2 running UNICOS.
+#define GCC Gcc compiler.
+##define HPUX300CC HP 9000/300 running HP-UX.
+##define HPUX800CC HP 9000/800 running HP-UX.
+##define IBMR6000CC IBM RS6000.
+##define IRIS4DCC Silicon Graphics Iris 4D.
+##define IRISCC Silicon Graphics Iris 2400/3000.
+##define SUNCC Sun 3 computers.
+##define 386IXCC SVr3 386/ix 2.2
+
+# You can put any system dependent flags here.
+ExtraCFLAGS =
+
+# System specific or configuration parameters. Define according to your
+# environment and desires.
+
+##define ABEKAS_PAL Convert to PAL format in Abekas A60 tool.
+##define ALL_MAN Print/install all man pages.
+##define CONST_DECL If your compiler understands 'const' (ANSI)
+##define FILE_NAME_14_CHARS If filenames are limited to 14 characters.
+##define HAVE_CPROTO If you have the cproto command. Not normally required.
+#define NEED_BSTRING Your libc does not have bcopy or bzero (Sys V probably)
+##define NEED_GETOPT Your libc does not have the getopt function (BSD)
+##define NEED_RENAME Your libc does not have the rename function (Sys V)
+#define NEED_SETLINEBUF Your stdio does not have setlinebuf (Sys V)
+#define NO_MAKE_MAKEFILE If you don't want a "makefile" action.
+##define NO_OPEN_PIPES If file "names" "|..." and "*.Z" are not special.
+#define NO_RANLIB You don't have the ranlib program (Sys V)
+##define NO_ITIMER You don't have setitimer (e.g., Cray 2).
+##define NO_TOOLS Don't build tool directory.
+##define STDIO_NEEDS_BINARY Your fopen() needs "b" specified for binary io
+##define USE_TIME_H You need to include time.h for time_t (Sys V)
+##define SYS_V_SETPGRP Your system has the SysV setpgrp() call.
+##define USE_L_FLAG Use -Llibdir -lrle instead of libdir/liblre.a.
+##define USE_PROTOTYPES Declare library functions with ANSI-C prototypes.
+##define USE_RANDOM Your libc has the BSD random() function.
+##define USE_STDARG Use 'stdarg' instead of 'varargs' (ANSI).
+#define USE_STDLIB_H You have "stdlib.h".
+#define USE_UNISTD_H You have "unistd.h".
+#define USE_STRING_H You have "string.h", not "strings.h"
+#define VOID_STAR Your C compiler understands the 'void *' declaration.
+#define USE_XLIBINT_H You have the include file <X11/Xlibint.h>.
+#define X_SHARED_MEMORY You have the XShm extension.
+
+#define NO_GETHOSTNAME You don't have gethostnamem, use sysinfo() (Sys V)
+
+# directories below.
+# RI is where the include files live. You probably shouldn't change this.
+# RL is where the tool directories find the RLE library. You can change
+# this, but see the README instructions about making the toolkit in this
+# case.
+
+# Path names not starting with a / are relative to this directory.
+# Path names starting with a / are absolute.
+
+#defpath DEST bin
+#defpath RI include
+#defpath RL lib
+
+# Note! LIB_DEST, INC_DEST, and MAN_DEST must be defined for the
+# library, include files, or manual pages, respectively, to be
+# installed anywhere.
+
+#defpath MAN_DEST
+#defpath LIB_DEST
+##defpath GET_DEST
+#defpath CNV_DEST
+#defpath TOOLS_DEST
+#defpath INC_DEST
+
+# Control of formatting. If your "roff" program needs to be piped to
+# something to print, set ROFFPIPE to (e.g.) "| lpr"
+ROFF = nroff
+ROFFOPT = -man
+ROFFPIPE = | lpr
+
+# Stuff you like to have removed from directories to "make clean"
+OTHERJUNK = core *~ #*#
+
+# Files needed for the various options above.
+#ifdef BOBCAT
+LIBBOBCAT = -ldd98700 -ldd98710 -ldd98721 -ldd98731 -ldd98736 -ldd300h -lddbyte -lsb1 -lsb2
+#endif
+
+#ifdef CGM
+# Path to directory where CGM library and include files may be found
+# Absolute or relative to URT root
+#defpath CGMDIR
+INCCGM = -I$(CGMDIR)
+LIBCGM = $(CGMDIR)/libcgm.a
+#endif
+
+#ifdef CX3D
+# Where are the include files for the CX3D
+INCCX3D = /usr/site/include
+LIBCX3D = -lcx3d
+#endif
+
+#ifdef DVIRLE
+#define DVIRLE_LIBSUBDIR Defined if LIBMCTEX is under cnv/tex directory
+# The MC-TeX library.
+LIBMCTEX = lib/lib.a # Note! relative to cnv/tex directory
+# Where to find the MC-TeX include files.
+INCMCTEX = h # Note! relative to cnv/tex directory
+# where to find the font description file
+CONFFILE = /usr/local/lib/tex/fontdesc
+#endif
+
+#ifdef FB
+LIBFB = /usr/brl/lib/libfb.a
+#endif
+
+#ifdef GRINNELL
+# Library containing GMR27 functions.
+LIBGRINNELL = -lfb
+#endif
+
+#ifdef HPQCR
+# HP device io library.
+LIBHPQCR = -ldvio
+#endif
+
+#ifdef IRIS
+LIBIRIS = -Zg
+#endif
+
+#ifdef IRIS4D
+LIBIRIS4D = -lgl_s
+#endif
+
+#ifdef PBMPLUS
+# PBMDIR should refer to the root of your PBM source tree.
+# If relative, it's relative to root of URT source tree.
+#defpath PBMDIR
+
+INCPBMPLUS = -I$(PBMDIR) -I$(PBMDIR)/ppm -I$(PBMDIR)/pgm -I$(PBMDIR)/pbm
+LIBPBMPLUS = $(PBMDIR)/ppm/libppm.a $(PBMDIR)/pgm/libpgm.a \
+ $(PBMDIR)/pbm/libpbm.a
+#endif
+
+#ifdef SUNRASTER|SUNTOOLS|TAAC1
+LIBSUNTOOLS_COM = -lsuntool -lsunwindow -lpixrect
+#endif
+
+#ifdef SUNRASTER
+LIBSUNRASTER = $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef SUNTOOLS
+LIBSUNTOOLS = $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef TAAC1
+LIBTAAC1 = -ltaac1 $(LIBSUNTOOLS_COM)
+#endif
+
+#ifdef TIFF
+# Location of tiff library and include files. Relative to URT root directory.
+#defpath TIFFDIR
+INCTIFF = -I$(TIFFDIR)
+LIBTIFF = $(TIFFDIR)/libtiff.a
+#endif
+
+#ifdef X10
+LIBX10 = -lX
+INCX10 =
+#endif
+
+#ifdef X11
+LIBX11 = -lX11
+# Sun Specific
+INCX11 = -I/usr/openwin/include
+#endif

View File

@ -1,5 +1,5 @@
--- config/urt.orig Wed Jul 15 14:47:15 1992
+++ config/urt Sun Oct 4 22:57:47 1998
--- config/urt.orig Thu Jul 16 04:47:15 1992
+++ config/urt Fri Dec 27 23:19:11 2002
@@ -1,3 +1,7 @@
+# Configuration for HP 9000/300 series running BSD4.3
+
@ -45,7 +45,7 @@
# You can put any system dependent flags here.
-ExtraCFLAGS =
+ExtraCFLAGS = -O2 -pipe -fno-strength-reduce
+ExtraCFLAGS = -fno-strength-reduce
# System specific or configuration parameters. Define according to your
# environment and desires.

View File

@ -0,0 +1,15 @@
--- get/getx11/in_cmap.c.orig Thu Apr 30 23:17:16 1992
+++ get/getx11/in_cmap.c Fri Dec 27 23:02:36 2002
@@ -70,10 +70,10 @@
if ( img->sep_colors ||
(img->img_channels == 1 && img->ncmap == 3 && img->cmlen) )
/* If using color map directly, apply display gamma, too. */
- img->in_cmap = buildmap( img_hdr, 3, img->gamma,
+ img->in_cmap = buildmap( img_hdr, 3, (double) img->gamma,
display_gamma );
else
- img->in_cmap = buildmap( img_hdr, 3, img->gamma, 1.0 );
+ img->in_cmap = buildmap( img_hdr, 3, (double) img->gamma, 1.0 );
for (i = 0; i < 3; i++ ) {
for (j = 0; j < 256; j++)

View File

@ -0,0 +1,21 @@
--- include/makefile.src.orig Sat Jun 8 00:56:22 1991
+++ include/makefile.src Sat Dec 28 00:45:11 2002
@@ -35,8 +35,8 @@
@sh -c "if test 'x$(DEST)' != x ; then \
if test 'x$(HDRS)' != x ; then eval \
'for hdr in $?; do \
- echo cp \$$hdr $(DEST)/\$$hdr ; \
- cp \$$hdr $(DEST)/\$$hdr; \
+ echo install \$$hdr $(DEST)/\$$hdr ; \
+ ${BSD_INSTALL_DATA} \$$hdr $(DEST)/\$$hdr; \
done' ; \
else \
true ; \
@@ -44,7 +44,6 @@
else \
true ; \
fi"
- touch install
# Nothing to clean
clean:

View File

@ -0,0 +1,11 @@
--- include/rle_config.tlr.orig Thu Apr 30 23:06:23 1992
+++ include/rle_config.tlr Fri Dec 27 23:02:36 2002
@@ -48,7 +48,7 @@
#endif /* NO_DECLARE_MALLOC */
#ifdef USE_PROTOTYPES
-extern char *getenv( CONST_DECL char *name );
+extern char *getenv( CONST_DECL char *CONST_DECL name);
#else
extern char *getenv();
#endif

View File

@ -0,0 +1,10 @@
--- lib/buildmap.c.orig Fri Feb 28 06:17:01 1992
+++ lib/buildmap.c Fri Dec 27 23:02:36 2002
@@ -26,6 +26,7 @@
*/
#include <stdio.h>
+#include <stdlib.h>
#include "rle.h"
#include <math.h>

View File

@ -1,5 +1,5 @@
--- lib/makefile.src.orig Wed Mar 4 13:32:53 1992
+++ lib/makefile.src Sun Oct 4 23:38:40 1998
--- lib/makefile.src.orig Thu Mar 5 04:32:53 1992
+++ lib/makefile.src Sat Dec 28 00:41:59 2002
@@ -26,7 +26,14 @@
vaxshort.o \
$(OPT_OBJS)
@ -22,10 +22,10 @@
@sh -c "if test '$(DEST)x' != x ; then \
- echo cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
- cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
+ echo cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
+ cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
+ echo cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
+ cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
+ echo install $(LIBANAME) $(DEST)/$(LIBANAME) ; \
+ ${BSD_INSTALL_DATA} $(LIBANAME) $(DEST)/$(LIBANAME) ; \
+ echo install $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
+ ${BSD_INSTALL_DATA} $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
+ ln -sf $(LIBSONAME) $(DEST)/librle.so ; \
if test x$(RANLIB) != x ; then \
- echo ranlib $(DEST)/$(LIBNAME) ; \

View File

@ -0,0 +1,13 @@
--- lib/rle_global.c.orig Wed Jan 29 03:23:03 1992
+++ lib/rle_global.c Fri Dec 27 23:20:42 2002
@@ -76,8 +76,10 @@
8, /* cmaplen (log2 of length of color map) */
NULL, /* pointer to color map */
NULL, /* pointer to comment strings */
+#if 0
stdout, /* output file */
{ 7 }, /* RGB channels only */
+#endif
0L, /* Can't free name and file fields. */
"Urt", /* Default "program name". */
"no file", /* No file name given. */

View File

@ -0,0 +1,16 @@
--- makefile.hdr.orig Fri Mar 6 23:04:57 1992
+++ makefile.hdr Fri Dec 27 23:15:13 2002
@@ -45,11 +45,11 @@
#emit MachFLAGS
MachFLAGS =
-CFLAGS = -O $(DFLAGS) $(DIRFLAGS) $(ExtraCFLAGS) $(IFLAGS) $(MachFLAGS)
+CFLAGS += $(DFLAGS) $(DIRFLAGS) $(ExtraCFLAGS) $(IFLAGS) $(MachFLAGS)
IFLAGS = -I. -I$(RI)
#ifdef GCC
-CC=gcc
+CC ?= gcc
#endif

View File

@ -0,0 +1,20 @@
--- makefile.src.orig Sat Jun 8 00:58:13 1991
+++ makefile.src Fri Dec 27 23:02:36 2002
@@ -17,7 +17,7 @@
# clean deletes all but source, pristine (below) deletes installed stuff, too
default clean: doit
@for d in $(DIRS) ; do \
- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
+ ( cd $$d ; echo make $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
done
# install puts library, binaries and documentation into global location
@@ -29,7 +29,7 @@
install $(MAKE_TARGET) pristine depend:: doit
@for d in $(ALLDIRS) ; do \
- ( cd $$d ; echo make $@ on $$d ; make $(MFLAGS) $@ ) ; \
+ ( cd $$d ; echo make $@ on $$d ; $(MAKE) $(MFLAGS) $@ ) ; \
done

View File

@ -1,5 +1,5 @@
--- makefile.tlr.orig Tue Aug 4 12:17:57 1992
+++ makefile.tlr Sun Oct 4 23:37:05 1998
--- makefile.tlr.orig Wed Aug 5 02:17:57 1992
+++ makefile.tlr Sat Dec 28 00:48:28 2002
@@ -7,7 +7,7 @@
@sh -c "if test 'x$(DIRS)' != x ; then eval \
'set -e ; for dir in $(DIRS) ; do \
@ -9,7 +9,15 @@
done' ; \
else \
true ; \
@@ -24,7 +24,6 @@
@@ -18,35 +18,31 @@
@sh -c "if test 'x$?' != x ; then eval \
'for pgm in $? ; do \
dpgm=\`basename \$$pgm .out\` ; \
- echo cp \$$pgm $(DEST)/\$$dpgm ; \
- cp \$$pgm $(DEST)/\$$dpgm; \
+ echo install \$$pgm $(DEST)/\$$dpgm ; \
+ ${BSD_INSTALL_PROGRAM} \$$pgm $(DEST)/\$$dpgm; \
done' ; \
else \
true ; \
fi"
@ -17,7 +25,16 @@
# Install all scripts
install-script: $(SCRIPTS)
@@ -39,14 +38,13 @@
@sh -c "if test 'x$?' != x ; then eval \
'for pgm in $? ; do \
dpgm=\`basename \$$pgm .sh\` ; \
- echo cp \$$pgm $(DEST)/\$$dpgm ; \
- cp \$$pgm $(DEST)/\$$dpgm; \
- echo chmod a+rx $(DEST)/\$$dpgm ; \
- chmod a+rx $(DEST)/\$$dpgm; \
+ echo install \$$pgm $(DEST)/\$$dpgm ; \
+ ${BSD_INSTALL_SCRIPT} \$$pgm $(DEST)/\$$dpgm; \
done' ; \
else \
true ; \
fi"
@ -33,7 +50,7 @@
done' ; \
else \
true ; \
@@ -105,7 +103,7 @@
@@ -105,7 +101,7 @@
'for dir in $(ALLDIRS); do \
if test -d $$dir ; then \
(cd $$dir; echo Make ${HERE}$$dir pristine ; \
@ -42,7 +59,7 @@
else \
true; \
fi; \
@@ -124,7 +122,7 @@
@@ -124,7 +120,7 @@
'for dir in $(ALLDIRS); do \
if test -d $$dir ; then \
(cd $$dir; echo Clean ${HERE}$$dir ; \

View File

@ -0,0 +1,48 @@
--- man/makefile.src.orig Fri Feb 28 06:26:52 1992
+++ man/makefile.src Sat Dec 28 00:43:57 2002
@@ -211,39 +211,35 @@
# Put the manual pages into a global location
install: install-1 install-3 install-5
- touch install
install-1: $(PAGES1)
@-sh -c "if test '$(DEST)X' != X ; then \
for i in $? ; do \
dpgm=\`basename \$$i .1\`.$(SUFF1) ; \
- echo cp \$$i $(DEST1)/\$$dpgm ; \
- cp \$$i $(DEST1)/\$$dpgm ; \
+ echo install \$$i $(DEST1)/\$$dpgm ; \
+ ${BSD_INSTALL_MAN} \$$i $(DEST1)/\$$dpgm ; \
done ; \
else \
true ; \
fi"
- touch install-1
install-3: $(PAGES3)
@-sh -c "if test '$(DEST)X' != X ; then \
for i in $? ; do \
dpgm=${PAGE3_INSTALL_NAME} ; \
- echo cp \$$i $(DEST3)/\$$dpgm ; \
- cp \$$i $(DEST3)/\$$dpgm ; \
+ echo install \$$i $(DEST3)/\$$dpgm ; \
+ ${BSD_INSTALL_MAN} \$$i $(DEST3)/\$$dpgm ; \
done ; \
else \
true ; \
fi"
- touch install-3
install-5: man5/*.5
@-sh -c "if test $(DEST)X != X; then \
- echo cp $? $(DEST5); \
- cp $? $(DEST5); \
+ echo install $? $(DEST5); \
+ ${BSD_INSTALL_MAN} $? $(DEST5); \
else true; \
fi"
- touch install-5
# Clean up installed man pages
pristine:

View File

@ -0,0 +1,13 @@
--- tools/into.c.orig Thu Apr 30 23:10:15 1992
+++ tools/into.c Fri Dec 27 23:23:48 2002
@@ -41,7 +41,10 @@
short forceflg; /* overwrite an unwritable file? */
extern int errno;
+
+#ifndef BSD
extern char *sys_errlist[];
+#endif
void
main(argc, argv)

View File

@ -0,0 +1,20 @@
--- tools/makefile.src.orig Wed Jan 29 03:47:42 1992
+++ tools/makefile.src Fri Dec 27 23:02:36 2002
@@ -68,7 +68,7 @@
fant.out: fant.o mallocNd.o
$(CC) $(CFLAGS) -I$(RI) fant.o mallocNd.o $(LIBS) -lm -o fant.new
mv fant.new fant.out
-
+
# rlebox and crop use some common code.
rle_box.o: $(RI)/rle.h $(RI)/rle_config.h $(RI)/rle_raw.h
@@ -82,7 +82,7 @@
# rleClock has it's own directory, must be built special
rleClock.out: clock/font.c clock/font.h clock/font.src clock/rleClock.c
- (cd clock ; make)
+ (cd clock ; $(MAKE))
# Incremental install, copies everything ("$?") since last install to DEST dir.
install: $(PGMS) install-pgm

View File

@ -76,9 +76,6 @@ include/rle_raw.h
lib/librle.a
lib/librle.so
lib/librle.so.1
@comment if compressed RLE.5 doesn't work.
man/man5/RLE.5
man/man5/rle.5
%%PORTDOCS%%share/doc/urt/README
%%PORTDOCS%%share/doc/urt/pics/README
%%PORTDOCS%%share/doc/urt/pics/bullet_holes_and_shot_turb.ps.Z