- Unbreak on sparc64 and amd64

Approved by:	portmgr (pav)
This commit is contained in:
Pietro Cerutti 2008-09-15 19:50:09 +00:00
parent 5455ba55e5
commit c805158255
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=220388
2 changed files with 21 additions and 9 deletions

View File

@ -38,14 +38,6 @@ DOCS= ChangeLog \
doc/features.jp
EXAMPLES= doc/sample/bjorb.conf.doc
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile with GCC 4.2
.endif
.endif
post-install:
@${INSTALL_SCRIPT} ${DOCSRC}/doc/sample/bjorb.sh ${PREFIX}/etc/rc.d/bjorb.sh.sample
.if !defined(NOPORTDOCS)
@ -59,4 +51,4 @@ post-install:
.endfor
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,20 @@
--- log.cc.orig 2008-09-15 18:41:31.000000000 +0000
+++ log.cc 2008-09-15 18:43:17.000000000 +0000
@@ -183,7 +183,7 @@
va_start(ap, fmt);
#ifndef NO_SYSLOG
- if ((int)fp == -1) {
+ if (fp == (FILE *)-1) {
char buf[512];
int level;
vsprintf(buf, fmt, ap);
@@ -241,7 +241,7 @@
{
if (fp && fp != stderr
#ifndef NO_SYSLOG
- && (int)fp != -1
+ && fp != (FILE *)-1
#endif
) {
put("Close log file\n");