math/{,py-}spot: Update 2.10.6 -> 2.11

Reported by:	portscout
This commit is contained in:
Yuri Victorovich 2022-10-09 10:31:03 -07:00
parent 4110316e93
commit c7ef7f5241
8 changed files with 36 additions and 21 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= spot
DISTVERSION= 2.10.6
DISTVERSION= 2.11
CATEGORIES= math
MASTER_SITES= http://www.lrde.epita.fr/dload/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libspot.so:math/spot
USES= compiler:c++14-lang gmake libtool python:3.4+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-python --disable-static

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1652985587
SHA256 (spot-2.10.6.tar.gz) = c588d1cb53ccea3e592f99402b14c2f4367b349ecef8e17b6d391df146bc8ba4
SIZE (spot-2.10.6.tar.gz) = 7599871
TIMESTAMP = 1665335836
SHA256 (spot-2.11.tar.gz) = 5b20541f876b8cacb1df1a07fe18175e81345ac93030a11f3691d2b516b59679
SIZE (spot-2.11.tar.gz) = 7547899

View File

@ -1,16 +1,16 @@
--- Makefile.in.orig 2018-08-04 07:35:57 UTC
--- Makefile.in.orig 2022-10-08 19:12:24 UTC
+++ Makefile.in
@@ -223,8 +223,7 @@ am__define_uniq_tagged_files = \
ETAGS = etags
CTAGS = ctags
CSCOPE = cscope
@@ -224,8 +224,7 @@ am__define_uniq_tagged_files = \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | $(am__uniquify_input)`
-DIST_SUBDIRS = picosat buddy lib ltdl spot bin tests python doc bench \
- elisp
+DIST_SUBDIRS = python
am__DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/config.h.in \
$(top_srcdir)/doc/org/.dir-locals.el.in \
$(top_srcdir)/doc/org/g++wrap.in \
@@ -1153,8 +1152,7 @@ top_srcdir = @top_srcdir@
@@ -1229,8 +1228,7 @@ top_srcdir = @top_srcdir@
@NEVER_TRUE@NEVER_SUBDIRS = bench elisp
@USE_PYTHON_TRUE@PYTHON_SUBDIR = python
DOC_SUBDIR = doc
@ -18,5 +18,5 @@
- $(NEVER_SUBDIRS)
+SUBDIRS = $(PYTHON_SUBDIR)
UTF8 = utf8/README.md utf8/utf8.h \
utf8/utf8/checked.h utf8/utf8/core.h utf8/utf8/unchecked.h
UTF8 = utf8/README.md utf8/LICENSE utf8/utf8.h \
utf8/utf8/checked.h utf8/utf8/core.h utf8/utf8/unchecked.h \

View File

@ -1,5 +1,5 @@
PORTNAME= spot
DISTVERSION= 2.10.6
DISTVERSION= 2.11
CATEGORIES= math
MASTER_SITES= http://www.lrde.epita.fr/dload/${PORTNAME}/
@ -22,7 +22,7 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= tl.pdf
TEST_TARGET= check
TEST_TARGET= check # at least one test fails to run, see https://gitlab.lre.epita.fr/spot/spot/-/issues/517
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1652985604
SHA256 (spot-2.10.6.tar.gz) = c588d1cb53ccea3e592f99402b14c2f4367b349ecef8e17b6d391df146bc8ba4
SIZE (spot-2.10.6.tar.gz) = 7599871
TIMESTAMP = 1665334301
SHA256 (spot-2.11.tar.gz) = 5b20541f876b8cacb1df1a07fe18175e81345ac93030a11f3691d2b516b59679
SIZE (spot-2.11.tar.gz) = 7547899

View File

@ -1,10 +1,10 @@
--- spot/misc/tmpfile.cc.orig 2018-10-04 12:40:02 UTC
--- spot/misc/tmpfile.cc.orig 2022-10-08 19:11:32 UTC
+++ spot/misc/tmpfile.cc
@@ -23,6 +23,7 @@
#include <cstdlib>
#include <stdlib.h>
#include <unistd.h>
#include <string.h>
+#include <stdlib.h>
namespace spot
{
using namespace std::string_literals;

View File

@ -0,0 +1,12 @@
- workaround for https://gitlab.lre.epita.fr/spot/spot/-/issues/515
--- spot/twaalgos/hoa.hh.orig 2022-10-09 17:09:51 UTC
+++ spot/twaalgos/hoa.hh
@@ -23,6 +23,7 @@
#include <spot/misc/common.hh>
#include <spot/twa/fwd.hh>
#include <vector>
+#include <unordered_map>
#include <utility>
#include <functional>
#include <bddx.h>

View File

@ -105,6 +105,7 @@ include/spot/tl/relabel.hh
include/spot/tl/remove_x.hh
include/spot/tl/simplify.hh
include/spot/tl/snf.hh
include/spot/tl/sonf.hh
include/spot/tl/unabbrev.hh
include/spot/twa/acc.hh
include/spot/twa/bdddict.hh
@ -129,6 +130,7 @@ include/spot/twaalgos/contains.hh
include/spot/twaalgos/copy.hh
include/spot/twaalgos/couvreurnew.hh
include/spot/twaalgos/cycles.hh
include/spot/twaalgos/dbranch.hh
include/spot/twaalgos/degen.hh
include/spot/twaalgos/determinize.hh
include/spot/twaalgos/dot.hh