ports-mgmt/pkg: with build with WITH_PIE

This commit is contained in:
Baptiste Daroussin 2023-01-19 11:46:42 +01:00
parent 70070f043c
commit c79ec8590b
2 changed files with 12 additions and 0 deletions

View File

@ -24,6 +24,7 @@ CONFIGURE_ENV= CC_FOR_BUILD="${CC}"
USE_SUBMAKE= yes
CFLAGS+= -Wno-error
CFLAGS_powerpc64le= -DSQLITE_BYTEORDER=1234
MAKE_ARGS+= STATIC_ARG="${STATIC_PIE_ARG}"
OPTIONS_DEFINE= DOCS

View File

@ -0,0 +1,11 @@
--- src/Makefile.autosetup.orig 2022-12-11 18:22:41 UTC
+++ src/Makefile.autosetup
@@ -93,7 +93,7 @@ pkg-static: $(OBJS) $(top_builddir)/libpkg/libpkg_flat
install: install-static
pkg-static: $(OBJS) $(top_builddir)/libpkg/libpkg_flat.a
- $(CC) -o $@ $(OBJS) $(STATIC_ARG) $(LDFLAGS) $(STATIC_LDFLAGS)
+ $(CC) -o $@ $(OBJS) $(STATIC_ARG) $(STATIC_LDFLAGS)
install-static: pkg-static
install -d -m 755 $(DESTDIR)$(sbindir)