[NEW PORT] sysutils/fusefs-gunzip

PR:		ports/124625
Submitted by:	Evgeny Zhirnov <jirnov@gmail.com>
This commit is contained in:
Edwin Groothuis 2008-07-05 11:39:42 +00:00
parent 77837c3567
commit c7906ef2a5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216374
5 changed files with 64 additions and 0 deletions

View File

@ -232,6 +232,7 @@
SUBDIR += fusefs-encfs
SUBDIR += fusefs-funionfs
SUBDIR += fusefs-gnome-vfs
SUBDIR += fusefs-gunzip
SUBDIR += fusefs-httpfs
SUBDIR += fusefs-kmod
SUBDIR += fusefs-libs

View File

@ -0,0 +1,41 @@
# New ports collection makefile for: fusefs-gunzip
# Date created: 2008-06-16
# Whom: Evgeny Zhirnov <jirnov@gmail.com>
#
# $FreeBSD$
#
PORTNAME= fuse.gunzip
PORTVERSION= 20070320
CATEGORIES= sysutils
MASTER_SITES= http://fuse.gunzip.silverice.org/files/
MAINTAINER= jirnov@gmail.com
COMMENT= Fuse.gunzip provides transparent decompression of gzip compressed files
BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
WRKSRC= ${WRKDIR}/fuse.gunzip
PLIST_FILES= bin/fuse.gunzip
NO_INSTALL_MANPAGES= yes
do-build:
(cd ${WRKSRC} && \
${CC} ${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/fuse \
-D_FILE_OFFSET_BITS=64 \
-o fuse.gunzip fuse.gunzip.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} \
-lulockmgr -lz -lfuse -liconv -lm)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fuse.gunzip ${PREFIX}/bin
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 600000 # Inherited from fusefs-kmod
IGNORE= requires FreeBSD 6.x or above
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (fuse.gunzip-20070320.tar.gz) = ac08b1716285701042cb72936b3f7ec0
SHA256 (fuse.gunzip-20070320.tar.gz) = f7111805898ddd059da9b59002447ba44e94d77707d3d398579ce754d2cd23c2
SIZE (fuse.gunzip-20070320.tar.gz) = 16002

View File

@ -0,0 +1,12 @@
--- fuse.gunzip.c.orig 2007-03-21 01:19:26.000000000 +0300
+++ fuse.gunzip.c 2008-06-16 01:46:43.000000000 +0400
@@ -38,9 +38,6 @@
#include <config.h>
*/
-#define HAVE_SETXATTR 1
-#define HAVE_FDATASYNC 1
-
#define _GNU_SOURCE
#include <fuse.h>

View File

@ -0,0 +1,7 @@
fuse.gunzip provides transparent decompression of gzip compressed files.
Files read as if they were not compressed.
Typical usage is to provide transparent decompression for /usr
However, it can be enabled for /opt and /home also.
System administrators select which files to compress.
WWW: http://fuse.gunzip.silverice.org/