Initial import of zbackup 1.3.
Zbackup is a globally-deduplicating backup tool, based on the ideas found in rsync.
This commit is contained in:
parent
a67f5ea10b
commit
c75de50d41
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372323
@ -1059,6 +1059,7 @@
|
||||
SUBDIR += xsysstats
|
||||
SUBDIR += xvidcap
|
||||
SUBDIR += yum
|
||||
SUBDIR += zbackup
|
||||
SUBDIR += zeitgeist
|
||||
SUBDIR += zeroer
|
||||
SUBDIR += zetaback
|
||||
|
28
sysutils/zbackup/Makefile
Normal file
28
sysutils/zbackup/Makefile
Normal file
@ -0,0 +1,28 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zbackup
|
||||
PORTVERSION= 1.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= https://github.com/zbackup/zbackup/archive/
|
||||
DISTFILES= ${PORTVERSION}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= kevlo@FreeBSD.org
|
||||
COMMENT= Versatile deduplicating backup tool
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libprotobuf.so:${PORTSDIR}/devel/protobuf
|
||||
|
||||
USES= cmake
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
PLIST_FILES= bin/zbackup
|
||||
PORTDOCS= README.md
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/zbackup ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
2
sysutils/zbackup/distinfo
Normal file
2
sysutils/zbackup/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (1.3.tar.gz) = 0c85232918295984fccb35804dbaeaa38df13c923814640524a8d9de2c6db1ee
|
||||
SIZE (1.3.tar.gz) = 72268
|
11
sysutils/zbackup/files/patch-endian.hh
Normal file
11
sysutils/zbackup/files/patch-endian.hh
Normal file
@ -0,0 +1,11 @@
|
||||
--- endian.hh.orig 2014-11-08 22:55:49.000000000 +0800
|
||||
+++ endian.hh 2014-11-08 22:56:01.000000000 +0800
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#include <arpa/inet.h>
|
||||
-#ifdef __APPLE__
|
||||
+#if defined(__APPLE_) || defined(__FreeBSD__)
|
||||
#include <machine/endian.h>
|
||||
#else
|
||||
#include <endian.h>
|
20
sysutils/zbackup/files/patch-unbuffered_file.cc
Normal file
20
sysutils/zbackup/files/patch-unbuffered_file.cc
Normal file
@ -0,0 +1,20 @@
|
||||
--- unbuffered_file.cc.orig 2014-11-08 22:56:14.000000000 +0800
|
||||
+++ unbuffered_file.cc 2014-11-08 22:56:25.000000000 +0800
|
||||
@@ -13,7 +13,7 @@
|
||||
#include "unbuffered_file.hh"
|
||||
|
||||
|
||||
-#ifdef __APPLE__
|
||||
+#if defined(__APPLE_) || defined(__FreeBSD__)
|
||||
#define lseek64 lseek
|
||||
#endif
|
||||
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
int flags = ( mode == WriteOnly ? ( O_WRONLY | O_CREAT | O_TRUNC ) :
|
||||
O_RDONLY );
|
||||
-#ifndef __APPLE__
|
||||
+#if !defined(__APPLE__) && !defined(__FreeBSD__)
|
||||
flags |= O_LARGEFILE;
|
||||
#endif
|
||||
fd = open( fileName, flags, 0666 );
|
6
sysutils/zbackup/pkg-descr
Normal file
6
sysutils/zbackup/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
zbackup is a globally-deduplicating backup tool, based on the ideas found
|
||||
in rsync. Any of the backup files stored previously can be read back in full
|
||||
at any time. The program is format-agnostic, so you can feed virtually any
|
||||
files to it.
|
||||
|
||||
WWW: http://zbackup.org/
|
Loading…
Reference in New Issue
Block a user