www/py-flexget: update to 3.1.64

- Switch from flask-restplus to flask-restx, removing the former

Changes:	https://github.com/Flexget/Flexget/compare/v3.1.59...v3.1.64
PR:		244294
This commit is contained in:
Jan Beich 2020-06-17 12:36:41 +00:00
parent 9c23ac0442
commit c7566d79ab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=539422
11 changed files with 51 additions and 75 deletions

1
MOVED
View File

@ -15087,3 +15087,4 @@ mail/claws-mail-spamreport|mail/claws-mail-spam_report|2020-06-11|Renamed to ali
mail/claws-mail-tnef|mail/claws-mail-tnef_parse|2020-06-11|Renamed to align port name to plugin name
x11-themes/numix-theme|x11-themes/numix-gtk-theme|2020-06-15|Renamed to match upstream naming
www/py-djangorestframework36|www/py-djangorestframework|2020-06-15|Has expired: Not compatible with Django 2.0+, please use www/py-djangorestframework instead
www/py-flask-restplus|www/py-flask-restx|2020-06-17|No longer maintained upstream, use www/py-flask-restx instead

View File

@ -1603,7 +1603,7 @@
SUBDIR += py-flask-peewee
SUBDIR += py-flask-principal
SUBDIR += py-flask-restful
SUBDIR += py-flask-restplus
SUBDIR += py-flask-restx
SUBDIR += py-flask-script
SUBDIR += py-flask-security
SUBDIR += py-flask-smorest

View File

@ -1,50 +0,0 @@
# $FreeBSD$
PORTNAME= flask-restplus
PORTVERSION= 0.13.0
PORTREVISION= 1
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES+= f48b1d2403de.patch:-p1 119a6feb2950.patch:-p1
MAINTAINER= andrej@ebert.su
COMMENT= Extension for Flask that adds support for quickly building REST APIs
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0.8:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonschema>0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}aniso8601>=0.82:devel/py-aniso8601@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=3.2.3:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.5.1:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-flask>=0.10.0:devel/py-pytest-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mock>=1.6.3:devel/py-pytest-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-sugar>=0.9.0:devel/py-pytest-sugar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tzlocal>0:devel/py-tzlocal@${PY_FLAVOR}
#missing ports for tests:devel/py-pytest-benchmark, devel/py-pytest-profiling, devel/py-pytest-faker
USES= python
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= noirbizarre
NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>=2.0.0:devel/py-mock@${PY_FLAVOR}
.endif
do-test:
@${RM} -r ${TEST_WRKSRC}/build/lib/tests
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
.include <bsd.port.post.mk>

View File

@ -1,7 +0,0 @@
TIMESTAMP = 1582426379
SHA256 (noirbizarre-flask-restplus-0.13.0_GH0.tar.gz) = 5fd64c04bf224912965df54d29efbab423e65ea52ec61f37cf5d0aec553723da
SIZE (noirbizarre-flask-restplus-0.13.0_GH0.tar.gz) = 281618
SHA256 (f48b1d2403de.patch) = 43faca5fc256c745980fd0b05aa3aeee7728499754ea4884a815eb603b05c43b
SIZE (f48b1d2403de.patch) = 794
SHA256 (119a6feb2950.patch) = 9eb8d9e322f84c9c16113ea0d5128fec9c2f48388dbd3d8927bfbb443f4871f6
SIZE (119a6feb2950.patch) = 894

View File

@ -1,7 +0,0 @@
Extension for Flask that adds support for quickly building REST APIs.
Flask-RESTPlus encourages best practices with minimal setup.
If you are familiar with Flask, Flask-RESTPlus should be easy to pick up.
It provides a coherent collection of decorators and tools to describe your
API and expose its documentation properly using Swagger.
WWW: https://github.com/noirbizarre/flask-restplus

View File

@ -0,0 +1,27 @@
# $FreeBSD$
PORTNAME= flask-restx
PORTVERSION= 0.2.0
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Extension for Flask that adds support for quickly building REST APIs
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aniso8601>=0.82:devel/py-aniso8601@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jsonschema>0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Flask>=0.8:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}werkzeug>0:www/py-werkzeug@${PY_FLAVOR} \
${PY_ENUM34}
NO_ARCH= yes
USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1584919033
SHA256 (flask-restx-0.2.0.tar.gz) = ca87a1808333f4ec5a50a5740b44e6cd3879a4b940d559df3996877ec4a2f2a5
SIZE (flask-restx-0.2.0.tar.gz) = 2606161

View File

@ -0,0 +1,9 @@
Flask-RESTX is an extension for Flask that adds support for quickly
building REST APIs. Flask-RESTX encourages best practices with minimal
setup. If you are familiar with Flask, Flask-RESTX should be easy to
pick up. It provides a coherent collection of decorators and tools to
describe your API and expose its documentation properly using Swagger.
Flask-RESTX is a community driven fork of Flask-RESTPlus.
WWW: https://pypi.org/project/flask-restx/

View File

@ -3,7 +3,7 @@
PORTNAME= flexget
DISTVERSIONPREFIX= v
PORTVERSION= 3.1.59
PORTVERSION= 3.1.64
PORTEPOCH= 1
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy13>=1.3.10:databases/py-sqlalchemy
${PYTHON_PKGNAMEPREFIX}jsonschema>=2.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}loguru>=0.4.1:devel/py-loguru@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.3:devel/py-pyparsing@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.4.7:devel/py-pyparsing@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=4.2:devel/py-yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}progressbar>=2.5:misc/py-progressbar@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}guessit>=3.0.3:multimedia/py-guessit@${PY_FLAVOR} \
@ -41,7 +41,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy13>=1.3.10:databases/py-sqlalchemy
${PYTHON_PKGNAMEPREFIX}Flask-Cors>=2.1.2:www/py-flask-cors@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Flask-Login>=0.4.0:www/py-flask-login@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}Flask-RESTful>=0.3.3:www/py-flask-restful@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flask-restplus>=0.10.1:www/py-flask-restplus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}flask-restx>=0.2.0:www/py-flask-restx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>=0.11:www/py-html5lib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.20.0:www/py-requests@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.3:devel/py-pytest@${PY_FLAVOR} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1590764829
SHA256 (flexget-Flexget-v3.1.59_GH0.tar.gz) = a24e2f6a34af3714c6862b9ee1a3cb6ecb940b48c96af073d6ffca89ec7d7c3e
SIZE (flexget-Flexget-v3.1.59_GH0.tar.gz) = 7347028
TIMESTAMP = 1592233655
SHA256 (flexget-Flexget-v3.1.64_GH0.tar.gz) = d16664bb234f7c7268396c393e794212cd46a85f79b82df0d48b7ca8031dac95
SIZE (flexget-Flexget-v3.1.64_GH0.tar.gz) = 7347984

View File

@ -1,4 +1,4 @@
--- requirements.txt.orig 2020-05-21 15:04:40 UTC
--- requirements.txt.orig 2020-06-15 15:07:35 UTC
+++ requirements.txt
@@ -6,27 +6,27 @@ beautifulsoup4>=4.5
html5lib>=0.11
@ -24,12 +24,12 @@
+cherrypy>=3.7.0
flask>=0.7
flask-restful>=0.3.3
-flask-restplus==0.10.1
+flask-restplus>=0.10.1
-flask-restx==0.2.0
+flask-restx>=0.2.0
flask-compress>=1.2.1
flask-login>=0.4.0
flask-cors>=2.1.2
pyparsing>=2.0.3
pyparsing>=2.4.7
-zxcvbn-python
-progressbar==2.5
+zxcvbn