o Remove BROKEN, it actually does not build due to the lack of a
header file include required for __FreeBSD_version >= 700049: patch uppc.c accordingly o Fix uppcsetup: kldxref(8) module directory when it is installed o Bump PORTREVSION due to uppcsetup script change
This commit is contained in:
parent
fbf5c4eedb
commit
c74f714244
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=204863
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= uppc
|
||||
PORTVERSION= 0.8
|
||||
PORTREVISION= 2
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= palm kld
|
||||
MASTER_SITES= http://www.people.tecnik93.com/~sam/ports/
|
||||
PKGNAMESUFFIX= -kmod
|
||||
@ -24,10 +24,6 @@ IGNORE= Requires kernel source (/usr/src/sys) to build
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
@${REINPLACE_CMD} -e 's|%%INITIAL_INSTALLDIR%%|${PREFIX}/lib|g' ${BUILD_WRKSRC}/uppcsetup
|
||||
@${REINPLACE_CMD} -e 's|%%INITIAL_MODDIR%%|${KMODDIR}|g' ${WRKSRC}/uppcsetup
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- uppc.c.orig Sun Sep 12 05:39:44 2004
|
||||
+++ uppc.c Thu Jan 25 23:40:56 2007
|
||||
--- uppc.c.orig 2008-01-02 17:34:35.000000000 +0000
|
||||
+++ uppc.c 2008-01-02 17:34:47.000000000 +0000
|
||||
@@ -62,6 +62,8 @@
|
||||
#define USB_PRODUCT_TOSHIBA_E330 0x0707
|
||||
#define USB_PRODUCT_TOSHIBA_E740 0x0706
|
||||
@ -9,7 +9,18 @@
|
||||
#include <sys/cdefs.h>
|
||||
|
||||
#include <sys/param.h>
|
||||
@@ -93,6 +95,10 @@
|
||||
@@ -84,6 +86,10 @@
|
||||
|
||||
#include <sys/sysctl.h>
|
||||
|
||||
+#if __FreeBSD_version >= 700049
|
||||
+#include <dev/usb/usb_port.h>
|
||||
+#endif
|
||||
+
|
||||
#include <dev/usb/usb.h>
|
||||
|
||||
#include <dev/usb/usbcdc.h>
|
||||
@@ -93,6 +99,10 @@
|
||||
|
||||
#include <dev/usb/ucomvar.h>
|
||||
|
||||
@ -20,7 +31,7 @@
|
||||
static int uppcrtvendor = 0;
|
||||
static int uppcrtproduct = 0;
|
||||
|
||||
@@ -166,6 +172,7 @@
|
||||
@@ -166,6 +176,7 @@
|
||||
{{ USB_VENDOR_TOSHIBA, USB_PRODUCT_TOSHIBA_UNK }, 0},
|
||||
{{ USB_VENDOR_TOSHIBA, USB_PRODUCT_TOSHIBA_E330 }, 0},
|
||||
{{ USB_VENDOR_TOSHIBA, USB_PRODUCT_TOSHIBA_E740 }, 0},
|
||||
|
10
palm/uppc-kmod/files/patch-uppcsetup
Normal file
10
palm/uppc-kmod/files/patch-uppcsetup
Normal file
@ -0,0 +1,10 @@
|
||||
--- uppcsetup.orig 2008-01-02 14:09:25.000000000 +0000
|
||||
+++ uppcsetup 2008-01-02 14:09:57.000000000 +0000
|
||||
@@ -132,6 +132,7 @@
|
||||
dialog --msgbox "If your Pocket PC is physically connected to your computer, please disconnect it now and wait 60 seconds before continuing or your machine may PANIC." 8 65
|
||||
|
||||
cp ${INSTALLDIR}/uppc.ko ${MODDIR}/uppc.ko
|
||||
+kldxref ${MODDIR}
|
||||
|
||||
echo 'uppc_load="YES"' >> /boot/loader.conf
|
||||
|
Loading…
Reference in New Issue
Block a user