Fix parallel build and mark as MAKE_JOBS_SAFE.

This commit is contained in:
Alexey Dokuchaev 2009-03-30 10:56:11 +00:00
parent 0203c8761c
commit c7461e5281
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231298
4 changed files with 21 additions and 13 deletions

View File

@ -18,6 +18,7 @@ COMMENT= Advanced QuakeC compiler/decompiler
USE_ZIP= yes
MAKEFILE= ${FILESDIR}/Makefile
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/frikqcc bin/frikqcdec

View File

@ -15,12 +15,12 @@ DECOBJS= decompiler/cmdlib.o \
decompiler/main.o
.c.o:
${CC} ${CFLAGS} -c $< -o $*.o
${CC} ${CFLAGS} -o $@ -c $<
all: c dec
c: ${COBJS}
${CC} ${LDFLAGS} -o frikqcc ${COBJS}
${CC} ${LDFLAGS} -o frikqcc $>
dec: ${DECOBJS}
${CC} ${LDFLAGS} -o frikqcdec ${DECOBJS}
${CC} ${LDFLAGS} -o frikqcdec $>

View File

@ -17,13 +17,13 @@ COMMENT= A dockapp for monitoring of various Internet game servers
RUN_DEPENDS= qstat:${PORTSDIR}/games/qstat
USE_XORG= xpm x11 xext
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}

View File

@ -1,13 +1,13 @@
--- ./Makefile.orig 2003-04-24 21:31:39.000000000 +0200
+++ ./Makefile 2008-04-13 13:00:54.000000000 +0200
--- Makefile.orig
+++ Makefile
@@ -1,14 +1,11 @@
-CC = cc
-
+CC ?= cc
-X11BASE = /usr/X11R6
-LDIR = -L${X11BASE}/lib
-IDIR = -I${X11BASE}/include
+CC ?= cc
-
-INSTALL = install
+LDIR = -L${LOCALBASE}/lib
+IDIR = -I${LOCALBASE}/include
@ -19,12 +19,19 @@
OBJS = appcore/wmqstat.o\
appcore/srv_proc.o\
@@ -23,8 +20,5 @@
all: ${OBJS}
${CC} ${CFLAGS} -o wmqstat ${OBJS} ${LDIR} ${LIBS}
@@ -18,13 +15,10 @@
wmgeneral/list.o
.c.o:
- ${CC} ${CFLAGS} ${IDIR} -c $< -o $*.o
+ ${CC} ${CFLAGS} ${IDIR} -o $@ -c $<
all: ${OBJS}
- ${CC} ${CFLAGS} -o wmqstat ${OBJS} ${LDIR} ${LIBS}
-
-install:
- ${INSTALL} -o root -g wheel -m 755 wmqstat ${X11BASE}/bin
-
+ ${CC} ${CFLAGS} -o wmqstat $> ${LDIR} ${LIBS}
clean:
rm -f wmqstat appcore/*.o wmgeneral/*.o core