fixed the MOTIFLIB support, and added the manpages for cextract.

If you install thoteditor, and you write C codee, make a point of
reading the cextract man page.

Pointed out by: Satoshi
This commit is contained in:
Chuck Robey 1999-10-04 03:58:46 +00:00
parent 18cd8bfe65
commit c7218db3fd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22155
3 changed files with 17 additions and 2 deletions

View File

@ -27,8 +27,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-thot --enable-plugin --without-insure --without-amaya --disable-java --disable-intr --disable-jit --disable-math --disable-ilu
USE_GMAKE= yes
ALL_TARGET= all schemas
MAN1= cextract.1
MAN5= cextrc.5
do-configure:
$(CP) $(WRKSRC)/../thot/Makefile.in $(WRKSRC)/../thot/Makefile.in.patched
$(SED) -e "s&%%MOTIFLIB%%&$(MOTIFLIB)&" <$(WRKSRC)/../thot/Makefile.in.patched >$(WRKSRC)/../thot/Makefile.in
(cd $(WRKSRC);../configure $(CONFIGURE_ARGS))
post-configure:
@ -42,5 +46,7 @@ post-install:
${MKDIR} ${PREFIX}/share/thot/doc
$(SED) -e "s&%%PREFIX%%&$(PREFIX)&" < $(FILESDIR)/thoteditor > $(WRKDIR)/thoteditor
$(INSTALL_SCRIPT) $(WRKDIR)/thoteditor $(PREFIX)/bin
$(INSTALL_MAN) $(WRKSRC)/../tools/cextract-1.7/cextrc.5 $(PREFIX)/man/man5
$(INSTALL_MAN) $(WRKSRC)/../tools/cextract-1.7/cextract.1 $(PREFIX)/man/man1/cextract.1
.include <bsd.port.mk>

View File

@ -1,5 +1,14 @@
--- ../thot/Makefile.in.orig Wed Nov 19 05:41:49 1997
+++ ../thot/Makefile.in Sun Sep 26 23:08:12 1999
+++ ../thot/Makefile.in Sun Oct 3 23:42:28 1999
@@ -14,7 +14,7 @@
-I@top_srcdir@/drawlib -I@top_srcdir@/drawlib/f
LDFLAGS = @LDFLAGS@ -L../indexlib -L../drawlib -L../tablelib -L../thotlib -L..
LIBS = -lThotIndex -lThotDraw -lThotTable -lThotEditor @IMGLIBS@ \
- $(MOTIF_LIBRARIES) -lXm $(X_LIBS) -lXt -lXext $(X_PRE_LIBS) \
+ %%MOTIFLIB%% -lXm $(X_LIBS) -lXt -lXext $(X_PRE_LIBS) \
-lX11 $(X_EXTRA_LIBS) @LIBS@ @EXTRA_LIBS@ -lm
prefix = @prefix@
@@ -27,6 +27,7 @@
CONFIGFILES= \
XKeysymDB thot.ini thot.color thot.pattern thot.keyboard \

View File

@ -1,5 +1,5 @@
--- ../Makefile.in.orig Wed Oct 8 04:13:58 1997
+++ ../Makefile.in Sat Sep 25 13:24:41 1999
+++ ../Makefile.in Sun Oct 3 23:44:16 1999
@@ -17,6 +17,7 @@
SUBDIRS = tools tablelib thotlib batch drawlib indexlib thot amaya