add muse 0.7.1

Multiple Streaming Engine
This commit is contained in:
Ying-Chieh Liao 2002-06-06 18:47:52 +00:00
parent 2a112bea93
commit c6f7e8466b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60705
8 changed files with 91 additions and 0 deletions

View File

@ -151,6 +151,7 @@
SUBDIR += mpmf20
SUBDIR += mpt
SUBDIR += mq3
SUBDIR += muse
SUBDIR += musicbox
SUBDIR += musicbrainz
SUBDIR += mutemix

33
audio/muse/Makefile Normal file
View File

@ -0,0 +1,33 @@
# ex:ts=8
# Ports collection makefile for: muse
# Date created: Jun 7, 2002
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= muse
PORTVERSION= 0.7.1
CATEGORIES= audio
MASTER_SITES= http://freesoftware.fsf.org/download/muse/ \
http://muse.dyne.org/releases/
DISTNAME= MuSE-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame \
ogg:${PORTSDIR}/audio/libogg \
vorbis:${PORTSDIR}/audio/libvorbis \
gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_GTK= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
USE_GMAKE= yes
post-patch:
@${PERL} -pi -e "s,-lgthread,-lgthread12,g" ${WRKSRC}/configure
@${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile.in
.include <bsd.port.mk>

1
audio/muse/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (MuSE-0.7.1.tar.gz) = 98ccc46b79d67ec72391642270888654

View File

@ -0,0 +1,22 @@
--- Makefile.in.orig Fri Jun 7 02:45:04 2002
+++ Makefile.in Fri Jun 7 02:46:00 2002
@@ -98,7 +98,7 @@
docs_DATA = README COPYING USAGE AUTHORS NEWS KNOWN-BUGS ChangeLog TODO
-docsdir = ${prefix}/doc/MuSE
+docsdir = ${prefix}/share/doc/MuSE
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
@@ -197,8 +197,8 @@
$(mkinstalldirs) $(DESTDIR)$(bindir)
@list='$(bin_PROGRAMS)'; for p in $$list; do \
if test -f $$p; then \
- echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
- $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
+ echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed 's/$$/$(EXEEXT)/'`"; \
+ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed 's/$$/$(EXEEXT)/'`; \
else :; fi; \
done

View File

@ -0,0 +1,15 @@
--- outchannels.cpp.orig Fri Jun 7 02:44:42 2002
+++ outchannels.cpp Fri Jun 7 02:44:48 2002
@@ -20,11 +20,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <arpa/inet.h>
#include <netdb.h>
-#include <sys/types.h>
#include <sys/stat.h>
#include <fcntl.h>
#include <unistd.h>

1
audio/muse/pkg-comment Normal file
View File

@ -0,0 +1 @@
Multiple Streaming Engine

8
audio/muse/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
MuSE is an application for the mixing, encoding, and network streaming of
sound. MuSE can simultaniously mix up to 6 encoded audio bitstreams (from
files or network) plus a soundcard input signal. The resulting stream can
be played locally on the sound card and/or encoded as an mp3 bitstream sent
to a broadcast server. MuSE offers an intuitive interface to be operated
realtime and can run in "slick" mode from commandline.
WWW: http://muse.dyne.org/

10
audio/muse/pkg-plist Normal file
View File

@ -0,0 +1,10 @@
bin/muse
share/doc/MuSE/AUTHORS
share/doc/MuSE/COPYING
share/doc/MuSE/ChangeLog
share/doc/MuSE/KNOWN-BUGS
share/doc/MuSE/NEWS
share/doc/MuSE/README
share/doc/MuSE/TODO
share/doc/MuSE/USAGE
@dirrm share/doc/MuSE