- Support Mozilla plugin

This commit is contained in:
Pav Lucistnik 2006-05-26 22:21:20 +00:00
parent df85b83a62
commit c6e3f57eb3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=163554
3 changed files with 26 additions and 0 deletions

View File

@ -26,8 +26,20 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
OPTIONS= MOZILLA "Build mozilla plugin" off
.include <bsd.port.pre.mk>
.if defined(WITH_MOZILLA)
USE_GECKO= mozilla
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
CONFIGURE_ARGS+=--enable-mozilla-plugin
PLIST_SUB= MOZILLA=""
.else
CONFIGURE_ARGS+=--disable-mozilla-plugin
PLIST_SUB= MOZILLA="@comment "
.endif
.if ${OSVERSION} < 500000
BROKEN= does not link with openbabel
.endif

View File

@ -0,0 +1,11 @@
--- configure.orig Fri May 26 22:09:05 2006
+++ configure Fri May 26 22:21:37 2006
@@ -21444,7 +21444,7 @@
if test "x$MOZILLA_CONFIG" != "xno"; then
_mozilla_include_dir=`mozilla-config --cflags|sed 's/-I\(.*\) .*/\1/'`
- MOZILLA_CFLAGS="-I$_mozilla_include_dir/plugin -I$_mozilla_include_dir/java -I$_mozilla_include_dir/nspr"
+ MOZILLA_CFLAGS="`mozilla-config --cflags` -I$_mozilla_include_dir/plugin -I$_mozilla_include_dir/java -I$_mozilla_include_dir/nspr"
mozlibdir=`mozilla-config --libs|sed 's/-L//'`
else

View File

@ -26,7 +26,10 @@ include/gchemutils/gcu/xml-utils.h
lib/libgcu.la
lib/libgcu.so
lib/libgcu.so.6
%%MOZILLA%%lib/mozilla/plugins/libmozgcu.la
%%MOZILLA%%lib/mozilla/plugins/libmozgcu.so
libdata/pkgconfig/gcu.pc
%%MOZILLA%%libexec/chem-viewer
share/gnome/applications/gchem3d-viewer.desktop
share/gnome/applications/gchemcalc.desktop
share/gnome/applications/gchemtable.desktop