Update to 2.51.
2.51 fixes a target parsing bug which could in some cases cause Nmap to crash with the error "Assertion `t->nleft > 1' failed".
This commit is contained in:
parent
74f1274fa6
commit
c6da23405e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=28150
@ -7,12 +7,11 @@
|
||||
#
|
||||
|
||||
PORTNAME= nmap
|
||||
PORTVERSION= 2.3.b20
|
||||
PORTVERSION= 2.51
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://www.insecure.org/nmap/dist/ \
|
||||
ftp://nuxi.ucdavis.edu/pub/misc/ \
|
||||
http://www.mobis.com/ajax/projects/
|
||||
DISTNAME= ${PORTNAME}-2.30BETA20
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
#PATCH_SITES= http://www.mobis.com/ajax/projects/
|
||||
@ -22,7 +21,6 @@ MAINTAINER= obrien@FreeBSD.org
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --libdir=${PREFIX}/share/misc
|
||||
.if ${OSVERSION} < 300004
|
||||
CFLAGS+= -DDLT_RAW=12 # for obsoleted <net/bpf.h>
|
||||
.endif
|
||||
|
@ -1 +1 @@
|
||||
MD5 (nmap-2.30BETA20.tgz) = a697e4e5783e73fb3716d9133bb4ba58
|
||||
MD5 (nmap-2.51.tgz) = 9374b13c049c588c7067a5b49521e54d
|
||||
|
@ -1,19 +1,12 @@
|
||||
--- Makefile.in.orig Sun Mar 26 03:04:48 2000
|
||||
+++ Makefile.in Sun Mar 26 17:16:58 2000
|
||||
@@ -5,13 +5,13 @@
|
||||
sbindir = @sbindir@
|
||||
mandir = @mandir@
|
||||
srcdir = @srcdir@
|
||||
-libdir = @libdir@/nmap
|
||||
+libdir = @libdir@
|
||||
deskdir = $(prefix)/share/gnome/apps/Utilities
|
||||
|
||||
--- Makefile.in.orig Sat Apr 29 13:37:50 2000
|
||||
+++ Makefile.in Sun Apr 30 01:38:54 2000
|
||||
@@ -11,7 +11,7 @@
|
||||
CC = @CC@
|
||||
CCOPT =
|
||||
LIBPCAPDIR = @libpcapdir@
|
||||
-INCLS = -I. -I$(LIBPCAPDIR)
|
||||
+INCLS = -I. # -I$(LIBPCAPDIR)
|
||||
DEFS = @DEFS@ -DVERSION=\"$(VERSION)\" -DLIBDIR=\"$(libdir)\"
|
||||
DEFS = @DEFS@ -DVERSION=\"$(VERSION)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
|
||||
CFLAGS = @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
|
||||
# CFLAGS = -g -Wall $(DEFS) $(INCLS)
|
||||
@@ -36,7 +36,7 @@
|
||||
@ -25,12 +18,12 @@
|
||||
@echo Compiling nmap
|
||||
rm -f $@
|
||||
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
|
||||
@@ -128,7 +128,7 @@
|
||||
@@ -129,7 +129,7 @@
|
||||
$(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
|
||||
|
||||
install: $(TARGET)
|
||||
- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(libdir) $(deskdir)
|
||||
+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(libdir)
|
||||
- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir) $(deskdir)
|
||||
+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir)
|
||||
$(INSTALL) -c -m 755 nmap $(bindir)/nmap
|
||||
@echo "If the next command failes -- you cannot use the X front end"
|
||||
-test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 nmapfe/nmapfe $(bindir)/nmapfe && $(SHTOOL) mkln -f -s $(bindir)/nmapfe $(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(deskdir)/nmapfe.desktop
|
||||
|
@ -1,6 +1,6 @@
|
||||
@comment $FreeBSD$
|
||||
bin/nmap
|
||||
share/misc/nmap-os-fingerprints
|
||||
share/misc/nmap-services
|
||||
share/misc/nmap-rpc
|
||||
@dirrm share/misc
|
||||
share/nmap/nmap-os-fingerprints
|
||||
share/nmap/nmap-services
|
||||
share/nmap/nmap-rpc
|
||||
@dirrm share/nmap
|
||||
|
Loading…
Reference in New Issue
Block a user