MFH: r545512

www/pecl-solr: Fix build for php 7.4

PR:		247364
Submitted by:	hagabard@gmail.com
Approved by:	Hung-Yi Chen <gaod@hychen.org> (maintainer)

Approved by:	portmgr (blanket: build fix)
This commit is contained in:
Li-Wen Hsu 2020-08-20 09:32:55 +00:00
parent 0255083316
commit c6c3f09be3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q3/; revision=545513
2 changed files with 15 additions and 1 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= solr
PORTVERSION= 2.5.0
PORTREVISION= 1
CATEGORIES= www
MAINTAINER= gaod@hychen.org
@ -16,6 +17,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= php:pecl
USE_PHP= json:build
IGNORE_WITH_PHP= 74
CONFIGURE_ARGS= LIBXML_CFLAGS=-I${LOCALBASE}/include/libxml2 \
LIBXML_LIBS=-L${LOCALBASE}/include/libxml2
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- src/php7/solr_types.h.orig 2016-03-30 13:42:31 UTC
+++ src/php7/solr_types.h
@@ -53,6 +53,7 @@
#include <libxml/tree.h>
typedef unsigned char solr_bool;
+typedef unsigned long ulong; /* Short for unsigned long */
#include "solr_string.h"