Update to 1.2

- Relax USES=python

Changes:	https://cito.github.io/DBUtils/RelNotes-1.2.html
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2017-02-07 20:31:41 +00:00
parent 4a0e5379df
commit c6a9ecdb10
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=433589
3 changed files with 79 additions and 5 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dbutils
PORTVERSION= 1.1.1
PORTVERSION= 1.2
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -14,7 +14,7 @@ COMMENT= Providing solid, persistent, and pooled connections to a database
LICENSE= MIT
NO_ARCH= yes
USES= python:2
USES= python
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1486287417
SHA256 (DBUtils-1.1.1.tar.gz) = 4051d7fe0d5be6b0dff87cd2344247592de03bf25d58e4d8a4c7b3d5e35fdb8d
SIZE (DBUtils-1.1.1.tar.gz) = 92371
TIMESTAMP = 1486480831
SHA256 (DBUtils-1.2.tar.gz) = fc185892248ff2e008b4ef92192b4247308404464d8508b225f8900caa163c6b
SIZE (DBUtils-1.2.tar.gz) = 91239

View File

@ -0,0 +1,74 @@
--- DBUtils/Examples/DBUtilsExample.py.orig 2017-02-05 12:39:41 UTC
+++ DBUtils/Examples/DBUtilsExample.py
@@ -147,7 +147,7 @@ class DBUtilsExample(ExamplePage):
else:
db.cursor().execute(ddl)
db.commit()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
if self.dbapi_name != 'pg':
db.rollback()
self.outputMsg(error, True)
@@ -173,7 +173,7 @@ class DBUtilsExample(ExamplePage):
else:
db.cursor().execute(cmd)
db.commit()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
try:
if self.dbapi_name == 'pg':
db.query('end')
@@ -198,7 +198,7 @@ class DBUtilsExample(ExamplePage):
cursor.execute(query)
result = cursor.fetchall()
cursor.close()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
self.outputMsg(error, True)
return
if not result:
@@ -251,7 +251,7 @@ class DBUtilsExample(ExamplePage):
for cmd in cmds:
db.cursor().execute(cmd)
db.commit()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
if self.dbapi_name == 'pg':
db.query('end')
else:
@@ -275,7 +275,7 @@ class DBUtilsExample(ExamplePage):
cursor.execute(query)
result = cursor.fetchall()
cursor.close()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
self.outputMsg(error, True)
return
if not result:
@@ -335,7 +335,7 @@ class DBUtilsExample(ExamplePage):
else:
db.cursor().execute(cmd)
db.commit()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
if self.dbapi_name == 'pg':
db.query('end')
else:
@@ -359,7 +359,7 @@ class DBUtilsExample(ExamplePage):
cursor.execute(query)
result = cursor.fetchall()
cursor.close()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
self.outputMsg(error, True)
return
if not result:
@@ -422,7 +422,7 @@ class DBUtilsExample(ExamplePage):
db.cursor().execute(cmd)
cursor.close()
db.commit()
- except self.dbapi.Error, error:
+ except self.dbapi.Error as error:
if self.dbapi_name == 'pg':
db.query('end')
else: