New port: comms/soapyremote: SoapySDR module to use any Soapy SDR remotely

This commit is contained in:
Yuri Victorovich 2019-02-09 19:37:41 +00:00
parent 1a8ad33b8d
commit c64f30cc5d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=492507
5 changed files with 50 additions and 0 deletions

View File

@ -167,6 +167,7 @@
SUBDIR += smstools3
SUBDIR += snap7
SUBDIR += soapyairspy
SUBDIR += soapyremote
SUBDIR += soapyuhd
SUBDIR += spandsp
SUBDIR += splat

View File

@ -0,0 +1,25 @@
# $FreeBSD$
PORTNAME= SoapyRemote
DISTVERSIONPREFIX= soapy-remote-
DISTVERSION= 0.5.1
CATEGORIES= comms hamradio
MAINTAINER= yuri@FreeBSD.org
COMMENT= SoapySDR module to use any Soapy SDR remotely
LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
LIB_DEPENDS= libavahi-common.so:net/avahi-app \
libSoapySDR.so:misc/soapysdr
USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= pothosware
PLIST_FILES= bin/SoapySDRServer \
lib/SoapySDR/modules0.7/libremoteSupport.so \
man/man1/SoapySDRServer.1.gz
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1549740665
SHA256 (pothosware-SoapyRemote-soapy-remote-0.5.1_GH0.tar.gz) = f325c5dde26fc8d7a82bd4e893b9aac445bb736679724728fc1dd2f0aef7b5f6
SIZE (pothosware-SoapyRemote-soapy-remote-0.5.1_GH0.tar.gz) = 72668

View File

@ -0,0 +1,8 @@
--- server/CMakeLists.txt.orig 2019-02-09 19:33:21 UTC
+++ server/CMakeLists.txt
@@ -36,4 +36,4 @@ target_link_libraries(SoapySDRServer ${S
install(TARGETS SoapySDRServer DESTINATION bin)
#install man pages for the application executable
-install(FILES SoapySDRServer.1 DESTINATION share/man/man1)
+install(FILES SoapySDRServer.1 DESTINATION man/man1)

View File

@ -0,0 +1,13 @@
Use any SoapySDR supported device transparently over a local network link. The
remote support feature can turn any SDR into a network peripheral.
Potential use-cases for Soapy Remote:
* share the SDR device over a network
* use the device in multiple processes
* or use the device on multiple hosts
* a multi-threaded abstraction layer
* aid in embedded-device development
* or a work-around for software issues
* adapt an IPv4 SDR for an IPv6 network
WWW: https://github.com/pothosware/SoapyRemote/wiki