New port: multimedia/aravis

Aravis is a glib/gobject based viewer for video acquisition using
Genicam cameras.

It currently implements the gigabit ethernet and USB3 protocols
used by industrial cameras. It also provides a basic ethernet camera
simulator and a simple video viewer.

WWW: https://github.com/AravisProject/aravis

PR:		215908
Submitted by:	rozhuk.im@gmail.com
This commit is contained in:
Kurt Jaeger 2018-05-12 10:04:38 +00:00
parent f75dea71d5
commit c5eb59b55a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469721
6 changed files with 110 additions and 0 deletions

View File

@ -10,6 +10,7 @@
SUBDIR += abby
SUBDIR += acidrip
SUBDIR += aegisub
SUBDIR += aravis
SUBDIR += asdcplib
SUBDIR += assimp
SUBDIR += atomicparsley

View File

@ -0,0 +1,44 @@
# Created by: Rozhuk Ivan rozhuk.im@gmail.com
# $FreeBSD$
PORTNAME= aravis
DISTVERSIONPREFIX= ARAVIS_
DISTVERSION= 0_5_12
CATEGORIES= multimedia
MAINTAINER= rozhuk.im@gmail.com
COMMENT= Camera control and image acquisition viewer
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= ${PORTNAME}*
LIB_DEPENDS+= libaravis-0.6.so:devel/libaravis \
libnotify.so:devel/libnotify
USES= autoreconf gettext gmake libtool pkgconfig
USE_GNOME= cairo glib20 intltool gtk30
USE_GSTREAMER1= yes
GNU_CONFIGURE= yes
# USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GITHUB= yes
GH_ACCOUNT= AravisProject
GH_PROJECT= aravis
CONFIGURE_ARGS= --enable-packet-socket=no --enable-viewer=yes \
--enable-gst-plugin=no --enable-gst-0.10-plugin=no \
--enable-gtk-doc=no --enable-cpp-test=no \
--enable-usb=no --enable-zlib-pc=yes
MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
pre-configure:
${ECHO_CMD} "EXTRA_DIST =" >> ${WRKSRC}/gtk-doc.make
@${REINPLACE_CMD} -e 's|GTK_DOC_CHECK(\[1.14\],\[--flavour no-tmpl\])||' \
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|^arv_viewer_LDADD.*=.*|arv_viewer_LDADD = $${ARAVIS_VIEWER_LIBS} -laravis-0.6|' \
${WRKSRC}/viewer/Makefile.am
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1526106632
SHA256 (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 61467edecb96f7d315770f8d874860e42b2981200edb8bba879f46ec9a83e0b2
SIZE (AravisProject-aravis-ARAVIS_0_5_12_GH0.tar.gz) = 2986578

View File

@ -0,0 +1,41 @@
--- Makefile.am.orig 2018-05-03 12:25:25 UTC
+++ Makefile.am
@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I m4
DISTCHECK_CONFIGURE_FLAGS = --enable-introspection --enable-gtk-doc --enable-gst-plugin --enable-gst-0.10-plugin --enable-viewer --enable-cpp-test --enable-appstream-util
-SUBDIRS = src man
+SUBDIRS = man
if ARAVIS_BUILD_VIEWER
SUBDIRS += viewer
@@ -20,16 +20,9 @@ if ARAVIS_BUILD_GST_0_10_PLUGIN
SUBDIRS += gst-0.10
endif
-SUBDIRS += tests po docs
-aravisdocdir = ${docdir}/aravis-@ARAVIS_API_VERSION@
-aravisdoc_DATA = \
- README.md \
- COPYING \
- ChangeLog \
- AUTHORS \
- NEWS
+
EXTRA_DIST += m4/introspection.m4 README.md
# Copy all the spec files. Of cource, only one is actually used.
@@ -40,11 +33,5 @@ dist-hook:
fi \
done
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = aravis-@ARAVIS_API_VERSION@.pc
-CLEANFILES = $(pkgconfig_DATA)
-
-%-@ARAVIS_API_VERSION@.pc: %.pc
- cp $< $@

View File

@ -0,0 +1,8 @@
Aravis is a glib/gobject based viewer for video acquisition using
Genicam cameras.
It currently implements the gigabit ethernet and USB3 protocols
used by industrial cameras. It also provides a basic ethernet camera
simulator and a simple video viewer.
WWW: https://github.com/AravisProject/aravis

View File

@ -0,0 +1,13 @@
bin/arv-viewer
man/man1/arv-tool-0.6.1.gz
man/man1/arv-viewer.1.gz
share/appdata/arv-viewer.appdata.xml
share/applications/arv-viewer.desktop
%%DATADIR%%-0.6/arv-viewer.ui
share/icons/hicolor/22x22/apps/aravis.png
share/icons/hicolor/256x256/apps/aravis.png
share/icons/hicolor/32x32/apps/aravis.png
share/icons/hicolor/48x48/apps/aravis.png
share/icons/hicolor/scalable/devices/aravis-fake-symbolic.svg
share/icons/hicolor/scalable/devices/aravis-gigevision-symbolic.svg
share/icons/hicolor/scalable/devices/aravis-usb3vision-symbolic.svg