Add etc/ files management, and preserve etc/monitord.conf at "make install"

time (it was overwritten by the program's Makefile).
This commit is contained in:
Jimmy Olgeni 2001-06-17 17:26:49 +00:00
parent d3f7332086
commit c5c4c0d757
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44113
3 changed files with 9 additions and 4 deletions

View File

@ -14,4 +14,7 @@ MAINTAINER= walt@erudition.net
MAN8= monitord.8
post-install:
@${CP} ${WRKSRC}/monitord.conf ${PREFIX}/etc/monitord.conf.dist
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- Makefile.orig Thu Jun 15 12:17:14 2000
+++ Makefile Tue Jun 20 12:28:02 2000
--- Makefile.orig Thu Jun 15 11:17:14 2000
+++ Makefile Sun Jun 17 14:56:30 2001
@@ -6,7 +6,7 @@
TARGET = monitord
@ -17,5 +17,5 @@
- $(INSTALL) -c $(TARGET).conf /usr/local/etc
- $(INSTALL) -c $(TARGET).8 $(MANDIR)/man8
+ $(BSD_INSTALL_PROGRAM) $(TARGET) $(PREFIX)/bin
+ $(BSD_INSTALL_DATA) $(TARGET).conf $(PREFIX)/etc
+ if [ ! -e $(PREFIX)/etc/$(TARGET).conf ] ; then $(BSD_INSTALL_DATA) $(TARGET).conf $(PREFIX)/etc; fi
+ $(BSD_INSTALL_MAN) -c $(TARGET).8 $(MANDIR)/man8

View File

@ -1,2 +1,4 @@
etc/monitord.conf
@unexec if cmp -s %D/etc/monitord.conf %D/etc/monitord.conf.dist; then rm -f %D/etc/monitord.conf; fi
etc/monitord.conf.dist
@exec [ -f %B/monitord.conf ] || cp %B/%f %B/monitord.conf
bin/monitord