net/ceph-devel: Add port to the tree.

Ceph is a distributed object store and file system designed to
provide excellent performance, reliability and scalability.

PR:		217046
Submitted by:	Willem Jan Withagen <wjw@digiware.nl>
Reported by:	Willem Jan Withagen <wjw@digiware.nl>
Reviewed by:	asomers, feld, mat, mmokhi
Approved by:	asomers, feld (mentor)
Differential Revision:	https://reviews.freebsd.org/D9584
This commit is contained in:
Mahdi Mokhtari 2017-03-30 10:55:14 +00:00
parent 1f1190ebda
commit c59d4fa250
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437280
9 changed files with 525 additions and 2 deletions

2
GIDs
View File

@ -108,7 +108,7 @@ _iked:*:163:
lightdm:*:164:
uwsgi:*:165:
yule:*:166:
# free: 167
ceph:*:167:
# free: 168
# free: 169
tile38:*:170:

2
UIDs
View File

@ -113,7 +113,7 @@ _iked:*:163:163::0:0:IKEv2 Daemon:/var/empty:/usr/sbin/nologin
lightdm:*:164:164::0:0:Light Display Manager:/var/lib/lightdm-data:/usr/sbin/nologin
uwsgi:*:165:165::0:0:uwsgi Daemon:/nonexistent:/usr/sbin/nologin
yule:*:166:166::0:0:Samhain Daemon:/nonexistent:/usr/sbin/nologin
# free: 167
ceph:*:167:167::0:0:Ceph Daemons:/var/lib/ceph:/usr/sbin/nologin
# free: 168
# free: 169
tile38:*:170:170::0:0:Tile38 User:/var/db/tile38:/usr/sbin/nologin

View File

@ -67,6 +67,7 @@
SUBDIR += c3270
SUBDIR += cagibi
SUBDIR += ccxstream
SUBDIR += ceph-devel
SUBDIR += cf
SUBDIR += chrony
SUBDIR += citrix_ica

121
net/ceph-devel/Makefile Normal file
View File

@ -0,0 +1,121 @@
# Created by: Willem Jan Withagen <wjw@digiware.nl>
# $FreeBSD$
PORTNAME= ceph
DISTVERSION= wip.v2017-2-14
CATEGORIES= net
PKGNAMESUFFIX= -devel
MAINTAINER= wjw@digiware.nl
COMMENT=Ceph delivers object, block, and file storage in a unified system
LICENSE= GPLv2 LGPL3
LICENSE_COMB= dual
BUILD_DEPENDS= \
yasm:devel/yasm \
pkgconf:devel/pkgconf \
cython>=0.25.2:lang/cython \
sphinx-build:textproc/py-sphinx \
${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
LIB_DEPENDS= \
libboost_system.so:devel/boost-all \
libboost_python.so:devel/boost-python-libs \
libboost_thread.so:devel/boost-libs \
libleveldb.so:databases/leveldb \
libldap.so:net/openldap24-client \
libnss3.so:security/nss \
libcryptopp.so:security/cryptopp \
libsnappy.so:archivers/snappy \
libcurl.so:ftp/curl \
libxml2.so:textproc/libxml2 \
libexpat.so:textproc/expat2 \
liblz4.so:archivers/liblz4 \
libfcgi.so:www/fcgi \
libplds4.so:devel/nspr \
libtcmalloc.so:devel/google-perftools
RUN_DEPENDS= \
bash:shells/bash \
${LOCALBASE}/bin/getopt:misc/getopt \
xml:textproc/xmlstarlet \
jq:textproc/jq \
flock:sysutils/flock \
virtualenv:devel/py-virtualenv
USE_GITHUB= yes
GH_ACCOUNT= wjwithagen:DEFAULT
GH_TUPLE+= facebook:rocksdb:a0deec9:rocksdb/src/rocksdb
GH_TUPLE+= ceph:ceph-erasure-code-corpus:b5c8634:cepherasurecodecorpus/ceph-erasure-code-corpus
GH_TUPLE+= ceph:ceph-object-corpus:master:cephobjectcorpus/ceph-object-corpus
GH_TUPLE+= ceph:civetweb:v1.5-1809-g7f9f5d1:civetweb/src/civetweb
GH_TUPLE+= ceph:jerasure:v2-ceph:jerasure/src/erasure-code/jerasure/jerasure
GH_TUPLE+= ceph:gf-complete:v3-ceph:gfcomplete/src/erasure-code/jerasure/gf-complete
GH_TUPLE+= ceph:googletest:ceph-release-1.7.x:googletest/src/googletest
GH_TUPLE+= ceph:spdk:v1.2.0-39-g9322c25:spdk/src/spdk
GH_TUPLE+= ceph:xxHash:v0.5.1-2-g1f40c65:xxHash/src/xxHash
GH_TUPLE+= ceph:isa-l:v2.16.0:isal/src/isa-l
GH_TUPLE+= ceph:lua:lua-5.3-ceph:lua/src/lua
GH_TUPLE+= ceph:Beast:999e2fa:Beast/src/Beast
GH_TUPLE+= boostorg:boost:boost-1.61.0-275-g1790aff:boost/src/boost
GH_TUPLE+= ceph:dpdk:a38e5ec:dpd/src/dpd
GH_TUPLE+= facebook:zstd:v1.1.2:zstd/src/zstd
CMAKE_BUILD_TYPE= Release
CMAKE_ARGS= \
-D ENABLE_GIT_VERSION:BOOL=OFF \
-D WITH_SYSTEM_BOOST:BOOL=ON \
-D WITH_LTTNG:BOOL=OFF \
-D WITH_FUSE:BOOL=OFF \
-D WITH_KRBD:BOOL=OFF \
-D WITH_XFS:BOOL=OFF \
-D WITH_KVS:BOOL=OFF \
-D WITH_LIBCEPHFS:BOOL=OFF \
-D WITH_CEPHFS:BOOL=OFF \
-D WITH_EMBEDDED:BOOL=OFF
USES= gmake cmake:outsource python:2.7 gettext-runtime shebangfix
SHEBANG_FILES=src/rbdmap src/ceph-post-file.in src/rbd-replay-many
# even though i386 will build, it is not really advised.
ONLY_FOR_ARCHS= amd64
USE_RC_SUBR= ceph
USE_LDCONFIG= yes
USERS= ceph
GROUPS= ceph
pre-configure:
${LN} -s ${CONFIGURE_WRKSRC} ${WRKSRC}/build
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/ceph
${MKDIR} ${STAGEDIR}/var/lib/ceph/bootstrap-mds
${MKDIR} ${STAGEDIR}/var/lib/ceph/bootstrap-osd
${MKDIR} ${STAGEDIR}/var/lib/ceph/mds
${MKDIR} ${STAGEDIR}/var/lib/ceph/mon
${MKDIR} ${STAGEDIR}/var/lib/ceph/osd
${MKDIR} ${STAGEDIR}/var/lib/ceph/tmp
${MKDIR} ${STAGEDIR}/var/log/ceph
# Use the Ceph init.d script as the interface to regular
# starting and stopping deamons. rc.d work is done thru
# a separate rc.d/ceph script calling init-ceph again.
${MV} ${STAGEDIR}${PREFIX}/etc/init.d/ceph ${STAGEDIR}${PREFIX}/bin/init-ceph
# remove files not packaged
${RM} ${STAGEDIR}${DOCSDIR}/sample.fetch_config
${RM} ${STAGEDIR}${DOCSDIR}/sample.ceph.conf
${RMDIR} ${STAGEDIR}${DOCSDIR}
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_bench_log
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_multi_stress_watch
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_perf*
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_psim
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_scratchtoolpp
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_smalliobench*
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_test*
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_tpbench
${RM} ${STAGEDIR}${PREFIX}/bin/ceph_xattr_bench
${RM} ${STAGEDIR}${PREFIX}/sbin/ceph-disk-udev
${RMDIR} ${STAGEDIR}${PREFIX}/etc/init.d
${INSTALL_DATA} ${WRKSRC}/src/sample.ceph.conf ${STAGEDIR}${PREFIX}/etc/ceph/ceph.conf.sample
.include <bsd.port.mk>

33
net/ceph-devel/distinfo Normal file
View File

@ -0,0 +1,33 @@
TIMESTAMP = 1489750630
SHA256 (wjwithagen-ceph-wip.v2017-2-14_GH0.tar.gz) = 5216c970e7c7f38595f3dc61bb4fdf9a999a5926c7e3b8760ce97bcca1155a0e
SIZE (wjwithagen-ceph-wip.v2017-2-14_GH0.tar.gz) = 9473554
SHA256 (facebook-rocksdb-a0deec9_GH0.tar.gz) = bd3803c476c088b68815d6627a9b81da5e2b6447f3590885434c73534b1df62e
SIZE (facebook-rocksdb-a0deec9_GH0.tar.gz) = 2911761
SHA256 (ceph-ceph-erasure-code-corpus-b5c8634_GH0.tar.gz) = 2b72364ebfd6ba53b187a4503cf416c7182d83e757bf24a1aa14c642bb9ca9ed
SIZE (ceph-ceph-erasure-code-corpus-b5c8634_GH0.tar.gz) = 3577946
SHA256 (ceph-ceph-object-corpus-master_GH0.tar.gz) = a10b7e6fae4e91341cffe5565c2ea8e0e960255a5a22050964ef83aa479af234
SIZE (ceph-ceph-object-corpus-master_GH0.tar.gz) = 1328378
SHA256 (ceph-civetweb-v1.5-1809-g7f9f5d1_GH0.tar.gz) = 5d08d3c7b8d09cb055e8e67df4c956e7292efb7ae556e03b6c1f0d9f4fa7fd82
SIZE (ceph-civetweb-v1.5-1809-g7f9f5d1_GH0.tar.gz) = 6850432
SHA256 (ceph-jerasure-v2-ceph_GH0.tar.gz) = 94421f7249fca91af9076fa4ca38f16829c00a1fd05846cc0e09188ab9421f91
SIZE (ceph-jerasure-v2-ceph_GH0.tar.gz) = 806304
SHA256 (ceph-gf-complete-v3-ceph_GH0.tar.gz) = 4ce344235ed0fcb2776dc0fbef55f8753638f1fabd65c9d2f22c8f071fe2e4ac
SIZE (ceph-gf-complete-v3-ceph_GH0.tar.gz) = 342277
SHA256 (ceph-googletest-ceph-release-1.7.x_GH0.tar.gz) = 4a70b3a6b1a92ba0f623a560c9d1cdc84b925bd90458e080ebc2c4100225d54e
SIZE (ceph-googletest-ceph-release-1.7.x_GH0.tar.gz) = 1281303
SHA256 (ceph-spdk-v1.2.0-39-g9322c25_GH0.tar.gz) = 0730eb63fbc7d61e213aeb95f4def48525c7ec01fcf36aee1b3cce044e77447d
SIZE (ceph-spdk-v1.2.0-39-g9322c25_GH0.tar.gz) = 162759
SHA256 (ceph-xxHash-v0.5.1-2-g1f40c65_GH0.tar.gz) = bd0de02be53b8019f5844776a534439bee0b1f982cb1e8af4fae79f78cfb0924
SIZE (ceph-xxHash-v0.5.1-2-g1f40c65_GH0.tar.gz) = 25494
SHA256 (ceph-isa-l-v2.16.0_GH0.tar.gz) = 6fab1d920db76dc58f43df09020b0e8a1e08e455962dfb4dde111ea697ab8845
SIZE (ceph-isa-l-v2.16.0_GH0.tar.gz) = 364853
SHA256 (ceph-lua-lua-5.3-ceph_GH0.tar.gz) = 33ce7f79ea3dd1389b48cdcd6d8750fc9977994ea423f4a56f184affad1707be
SIZE (ceph-lua-lua-5.3-ceph_GH0.tar.gz) = 366804
SHA256 (ceph-Beast-999e2fa_GH0.tar.gz) = f3ac9a1c891b138e68137c0a1a2b37befa09b53f7e551f6ebb67fa8ed9b792f4
SIZE (ceph-Beast-999e2fa_GH0.tar.gz) = 521462
SHA256 (boostorg-boost-boost-1.61.0-275-g1790aff_GH0.tar.gz) = 22d2d0fcb83044a185ee0c1d009dd9eb43bf340c0d25432df4e889bdd67f2445
SIZE (boostorg-boost-boost-1.61.0-275-g1790aff_GH0.tar.gz) = 1096867
SHA256 (ceph-dpdk-a38e5ec_GH0.tar.gz) = 2f88c1e6361c99b4525dbc524c0c56cb5a45273028045d966190e73c416a0b24
SIZE (ceph-dpdk-a38e5ec_GH0.tar.gz) = 16158917
SHA256 (facebook-zstd-v1.1.2_GH0.tar.gz) = 980b8febb0118e22f6ed70d23b5b3e600995dbf7489c1f6d6122c1411cdda8d8
SIZE (facebook-zstd-v1.1.2_GH0.tar.gz) = 769017

View File

@ -0,0 +1,54 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: ceph
# REQUIRE: LOGIN
# BEFORE: securelevel
# KEYWORD: shutdown
# Add the following lines to /etc/rc.conf to enable `ceph':
#
# ceph_enable="YES"
#
. /etc/rc.subr
PATH=$PATH:%%PREFIX%%/bin:%%PREFIX%%/sbin
name="ceph"
rcvar=ceph_enable
extra_commands="condrestart"
# read configuration and set defaults
: ${ceph_enable="NO"}
: ${ceph_configfile:=%%PREFIX%%/etc/ceph/ceph.conf}
start_cmd="cephstart_cmd"
stop_cmd="cephstop_cmd"
restart_cmd="cephrestart_cmd"
condrestart_cmd="cephcondrestart_cmd"
cephstart_cmd()
{
%%PREFIX%%/bin/init-ceph start $*
}
cephstop_cmd()
{
%%PREFIX%%/bin/init-ceph stop $*
}
cephrestart_cmd()
{
%%PREFIX%%/bin/init-ceph restart $*
}
cephcondrestart_cmd()
{
%%PREFIX%%/bin/init-ceph condrestart $*
}
run_rc_command "$1"

View File

@ -0,0 +1,10 @@
--- src/rocksdb/CMakeLists.txt.orig 2016-11-21 02:24:12 UTC
+++ src/rocksdb/CMakeLists.txt
@@ -45,7 +45,6 @@ else()
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
# FreeBSD has jemaloc as default malloc
- add_definitions(-DROCKSDB_JEMALLOC)
set(WITH_JEMALLOC ON)
endif()
option(WITH_SNAPPY "build with SNAPPY" OFF)

21
net/ceph-devel/pkg-descr Normal file
View File

@ -0,0 +1,21 @@
Ceph is a distributed object store and file system designed to provide
excellent performance, reliability and scalability.
* Object Storage
Ceph provides seamless access to objects using native language bindings or
radosgw, a REST interface for applications written with S3 and Swift.
* Block Storage
Ceph's RADOS Block Device (RBD) provides access to block device images
that are striped and replicated across the entire storage cluster.
* File System
Ceph provides a POSIX-compliant network file system aiming for large data
storage, high performance, and maximum compatibility with legacy applications.
This FreeBSD build will build most of the tools in Ceph:
* Mon, OSD, rados, RadosGW, rbd
* init-ceph, and etc/rc.d/ceph on top of that
* ceph-disk {prepare, activate}
With these tools one can build a multi server, multi osd cluster fully
running on FreeBSD and do some testing...
WWW: http://ceph.com

283
net/ceph-devel/pkg-plist Normal file
View File

@ -0,0 +1,283 @@
bin/ceph
bin/ceph-authtool
bin/ceph-brag
bin/ceph-clsinfo
bin/ceph-conf
bin/ceph-coverage
bin/ceph-crush-location
bin/ceph-debugpack
bin/ceph-dencoder
bin/ceph-detect-init
bin/ceph-kvstore-tool
bin/ceph-mds
bin/ceph-mgr
bin/ceph-mon
bin/ceph-monstore-tool
bin/ceph-objectstore-tool
bin/ceph-osd
bin/ceph-osdomap-tool
bin/ceph-post-file
bin/ceph-rbdnamer
bin/ceph-rest-api
bin/ceph-run
bin/ceph_erasure_code
bin/ceph_erasure_code_benchmark
bin/ceph_objectstore_bench
bin/ceph_omapbench
bin/ceph_radosacl
bin/ceph_rgw_jsonparser
bin/ceph_rgw_multiparser
bin/ceph_scratchtool
bin/crushtool
bin/init-ceph
bin/librados-config
bin/monmaptool
bin/osdmaptool
bin/rados
bin/radosgw
bin/radosgw-admin
bin/radosgw-object-expirer
bin/radosgw-token
bin/rbd
bin/rbd-mirror
bin/rbd-replay
bin/rbd-replay-many
bin/rbdmap
etc/bash_completion.d/ceph
etc/bash_completion.d/rados
etc/bash_completion.d/radosgw-admin
etc/bash_completion.d/rbd
%%ETCDIR%%/ceph.conf.sample
include/rados/buffer.h
include/rados/buffer_fwd.h
include/rados/crc32c.h
include/rados/inline_memory.h
include/rados/librados.h
include/rados/librados.hpp
include/rados/librgw.h
include/rados/memory.h
include/rados/page.h
include/rados/rados_types.h
include/rados/rados_types.hpp
include/rados/rgw_file.h
include/radosstriper/libradosstriper.h
include/radosstriper/libradosstriper.hpp
include/rbd/features.h
include/rbd/librbd.h
include/rbd/librbd.hpp
lib/ceph/ceph-monstore-update-crush.sh
lib/ceph/compressor/libceph_snappy.so
lib/ceph/compressor/libceph_snappy.so.2
lib/ceph/compressor/libceph_snappy.so.2.0.0
lib/ceph/compressor/libceph_zlib.so
lib/ceph/compressor/libceph_zlib.so.2
lib/ceph/compressor/libceph_zlib.so.2.0.0
lib/ceph/compressor/libceph_zstd.so
lib/ceph/compressor/libceph_zstd.so.2
lib/ceph/compressor/libceph_zstd.so.2.0.0
lib/ceph/erasure-code/libec_isa.so
lib/ceph/erasure-code/libec_isa.so.2
lib/ceph/erasure-code/libec_isa.so.2.14.0
lib/ceph/erasure-code/libec_jerasure.so
lib/ceph/erasure-code/libec_jerasure_generic.so
lib/ceph/erasure-code/libec_jerasure_sse3.so
lib/ceph/erasure-code/libec_jerasure_sse4.so
lib/ceph/erasure-code/libec_lrc.so
lib/ceph/erasure-code/libec_shec.so
lib/ceph/erasure-code/libec_shec_generic.so
lib/ceph/erasure-code/libec_shec_sse3.so
lib/ceph/erasure-code/libec_shec_sse4.so
lib/ceph/libceph-common.so
lib/ceph/mgr/.gitignore
lib/ceph/mgr/fsstatus/__init__.py
lib/ceph/mgr/fsstatus/module.py
lib/ceph/mgr/mgr_module.py
lib/ceph/mgr/rest/__init__.py
lib/ceph/mgr/rest/app/__init__.py
lib/ceph/mgr/rest/app/fixtures/ceph_fake.json
lib/ceph/mgr/rest/app/management/__init__.py
lib/ceph/mgr/rest/app/management/commands/__init__.py
lib/ceph/mgr/rest/app/management/commands/api_docs.py
lib/ceph/mgr/rest/app/manager/__init__.py
lib/ceph/mgr/rest/app/manager/osd_request_factory.py
lib/ceph/mgr/rest/app/manager/pool_request_factory.py
lib/ceph/mgr/rest/app/manager/request_collection.py
lib/ceph/mgr/rest/app/manager/request_factory.py
lib/ceph/mgr/rest/app/manager/user_request.py
lib/ceph/mgr/rest/app/models.py
lib/ceph/mgr/rest/app/serializers/__init__.py
lib/ceph/mgr/rest/app/serializers/fields.py
lib/ceph/mgr/rest/app/serializers/v2.py
lib/ceph/mgr/rest/app/settings.py
lib/ceph/mgr/rest/app/types.py
lib/ceph/mgr/rest/app/urls/__init__.py
lib/ceph/mgr/rest/app/urls/v2.py
lib/ceph/mgr/rest/app/util.py
lib/ceph/mgr/rest/app/views/__init__.py
lib/ceph/mgr/rest/app/views/paginated_mixin.py
lib/ceph/mgr/rest/app/views/rpc_view.py
lib/ceph/mgr/rest/app/views/v2.py
lib/ceph/mgr/rest/logger.py
lib/ceph/mgr/rest/module.py
lib/librados.so
lib/librados.so.2
lib/librados.so.2.0.0
lib/libradosstriper.so
lib/libradosstriper.so.1
lib/libradosstriper.so.1.0.0
lib/librbd.so
lib/librbd.so.1
lib/librbd.so.1.0.0
lib/librgw.so
lib/librgw.so.2
lib/librgw.so.2.0.0
%%PYTHON_SITELIBDIR%%/ceph_argparse.py
%%PYTHON_SITELIBDIR%%/ceph_daemon.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/entry_points.txt
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/requires.txt
%%PYTHON_SITELIBDIR%%/ceph_detect_init-1.0.1-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/ceph_detect_init/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/alpine/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/alpine/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/arch/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/arch/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/centos/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/centos/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/debian/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/debian/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/exc.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/exc.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/fedora/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/fedora/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/freebsd/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/freebsd/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/gentoo/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/gentoo/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/main.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/main.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/rhel/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/rhel/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_detect_init/suse/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_detect_init/suse/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/entry_points.txt
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/requires.txt
%%PYTHON_SITELIBDIR%%/ceph_disk-1.0.0-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/ceph_disk/__init__.py
%%PYTHON_SITELIBDIR%%/ceph_disk/__init__.pyc
%%PYTHON_SITELIBDIR%%/ceph_disk/main.py
%%PYTHON_SITELIBDIR%%/ceph_disk/main.pyc
%%PYTHON_SITELIBDIR%%/ceph_rest_api.py
%%PYTHON_SITELIBDIR%%/ceph_volume_client.py
%%PYTHON_SITELIBDIR%%/rados-2.0.0-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/rados-2.0.0-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/rados-2.0.0-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/rados-2.0.0-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/rados.so
%%PYTHON_SITELIBDIR%%/rbd-2.0.0-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/rbd-2.0.0-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/rbd-2.0.0-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/rbd-2.0.0-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/rbd.so
%%PYTHON_SITELIBDIR%%/rgw-2.0.0-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON_SITELIBDIR%%/rgw-2.0.0-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON_SITELIBDIR%%/rgw-2.0.0-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%PYTHON_SITELIBDIR%%/rgw-2.0.0-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/rgw.so
lib/rados-classes/libcls_hello.so
lib/rados-classes/libcls_hello.so.1
lib/rados-classes/libcls_hello.so.1.0.0
lib/rados-classes/libcls_journal.so
lib/rados-classes/libcls_journal.so.1
lib/rados-classes/libcls_journal.so.1.0.0
lib/rados-classes/libcls_lock.so
lib/rados-classes/libcls_lock.so.1
lib/rados-classes/libcls_lock.so.1.0.0
lib/rados-classes/libcls_log.so
lib/rados-classes/libcls_log.so.1
lib/rados-classes/libcls_log.so.1.0.0
lib/rados-classes/libcls_lua.so
lib/rados-classes/libcls_lua.so.1
lib/rados-classes/libcls_lua.so.1.0.0
lib/rados-classes/libcls_numops.so
lib/rados-classes/libcls_numops.so.1
lib/rados-classes/libcls_numops.so.1.0.0
lib/rados-classes/libcls_rbd.so
lib/rados-classes/libcls_rbd.so.1
lib/rados-classes/libcls_rbd.so.1.0.0
lib/rados-classes/libcls_refcount.so
lib/rados-classes/libcls_refcount.so.1
lib/rados-classes/libcls_refcount.so.1.0.0
lib/rados-classes/libcls_replica_log.so
lib/rados-classes/libcls_replica_log.so.1
lib/rados-classes/libcls_replica_log.so.1.0.0
lib/rados-classes/libcls_rgw.so
lib/rados-classes/libcls_rgw.so.1
lib/rados-classes/libcls_rgw.so.1.0.0
lib/rados-classes/libcls_statelog.so
lib/rados-classes/libcls_statelog.so.1
lib/rados-classes/libcls_statelog.so.1.0.0
lib/rados-classes/libcls_timeindex.so
lib/rados-classes/libcls_timeindex.so.1
lib/rados-classes/libcls_timeindex.so.1.0.0
lib/rados-classes/libcls_user.so
lib/rados-classes/libcls_user.so.1
lib/rados-classes/libcls_user.so.1.0.0
lib/rados-classes/libcls_version.so
lib/rados-classes/libcls_version.so.1
lib/rados-classes/libcls_version.so.1.0.0
libexec/ceph/ceph-osd-prestart.sh
libexec/ceph/ceph_common.sh
man/man8/ceph-authtool.8.gz
man/man8/ceph-clsinfo.8.gz
man/man8/ceph-conf.8.gz
man/man8/ceph-create-keys.8.gz
man/man8/ceph-debugpack.8.gz
man/man8/ceph-dencoder.8.gz
man/man8/ceph-deploy.8.gz
man/man8/ceph-detect-init.8.gz
man/man8/ceph-disk.8.gz
man/man8/ceph-mds.8.gz
man/man8/ceph-mon.8.gz
man/man8/ceph-osd.8.gz
man/man8/ceph-post-file.8.gz
man/man8/ceph-rbdnamer.8.gz
man/man8/ceph-rest-api.8.gz
man/man8/ceph-run.8.gz
man/man8/ceph-syn.8.gz
man/man8/ceph.8.gz
man/man8/crushtool.8.gz
man/man8/librados-config.8.gz
man/man8/monmaptool.8.gz
man/man8/mount.ceph.8.gz
man/man8/osdmaptool.8.gz
man/man8/rados.8.gz
man/man8/radosgw-admin.8.gz
man/man8/radosgw.8.gz
man/man8/rbd-mirror.8.gz
man/man8/rbd-nbd.8.gz
man/man8/rbd-replay-many.8.gz
man/man8/rbd-replay-prep.8.gz
man/man8/rbd-replay.8.gz
man/man8/rbd.8.gz
man/man8/rbdmap.8.gz
sbin/ceph-create-keys
sbin/ceph-disk
%%DATADIR%%/id_rsa_drop.ceph.com
%%DATADIR%%/id_rsa_drop.ceph.com.pub
%%DATADIR%%/known_hosts_drop.ceph.com
@dir /var/lib/ceph/bootstrap-mds
@dir /var/lib/ceph/bootstrap-osd
@dir /var/lib/ceph/mds
@dir /var/lib/ceph/mon
@dir /var/lib/ceph/osd
@dir /var/lib/ceph/tmp
@dir /var/lib/ceph
@dir /var/lib
@dir /var/log/ceph