Update to 2.4.2; assign maintainership to perl@.

This commit is contained in:
Anton Berezin 2005-11-05 15:45:52 +00:00
parent db82c65b4c
commit c571642690
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147387
3 changed files with 11 additions and 20 deletions

View File

@ -7,8 +7,7 @@
#
PORTNAME= PDL
PORTVERSION= 2.4.1
PORTREVISION= 1
PORTVERSION= 2.4.2
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@ -17,24 +16,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}/:cpan \
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan \
${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:sf
MAINTAINER= ports@FreeBSD.org
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl Data Language
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/ExtUtils/F77.pm:${PORTSDIR}/lang/p5-F77 \
${SITE_PERL}/Inline.pm:${PORTSDIR}/devel/p5-Inline \
${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
${SITE_PERL}/Astro/FITS/Header.pm:${PORTSDIR}/astro/p5-Astro-FITS-Header
${SITE_PERL}/Astro/FITS/Header.pm:${PORTSDIR}/astro/p5-Astro-FITS-Header \
${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.10:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
gsl.7:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
PERL_CONFIGURE= yes
PLIST_DIRS= ${SITE_PERL:S,^${PREFIX}/,,}/${PERL_ARCH}/Inline
PLIST_FILES= bin/pdldoc bin/perldl bin/pptemplate \
PLIST_FILES= bin/pdl bin/pdldoc bin/perldl bin/pptemplate \
${SITE_PERL:S,^${PREFIX}/,,}/${PERL_ARCH}/Inline/Pdlpp.pm \
${SITE_PERL:S,^${PREFIX}/,,}/${PERL_ARCH}/Inline/MakePdlppInstallable.pm

View File

@ -1,2 +1,4 @@
MD5 (PDL-2.4.1.tar.gz) = 0d57eb5ccb4d9e63103622e1e1144793
SIZE (PDL-2.4.1.tar.gz) = 2086341
MD5 (PDL-2.4.2.tar.gz) = edd056a006eae8b46e8ef804b9774a93
SIZE (PDL-2.4.2.tar.gz) = 2151379
MD5 (PDL-2.4.2.tar.gz) = edd056a006eae8b46e8ef804b9774a93
SIZE (PDL-2.4.2.tar.gz) = 2151379

View File

@ -1,11 +0,0 @@
--- Graphics/PLplot/Makefile.PL.orig Fri Mar 12 08:38:52 2004
+++ Graphics/PLplot/Makefile.PL Fri Mar 12 08:39:43 2004
@@ -164,7 +164,7 @@
'PLplot.pm PLplot.xs PLplot.o PLplot.c PLplot.bs *.xfig temp* OPTIONS! Makefile.old'},
);
-sub MY::postamble { pdlpp_postamble($package); }
+sub MY::postamble { pdlpp_postamble_int($package); }
sub compileAndRun {
my $flags = shift;