GSmartControl is a graphical user interface for smartctl (from

sysutils/smartmontools port), which is a tool for querying and
controlling SMART (Self-Monitoring, Analysis, and Reporting
Technology) data on modern hard disk drives. It allows you to
inspect the drive's SMART data to determine its health, as well
as run various tests on it.

WWW:	http://gsmartcontrol.berlios.de

PR:		ports/133103
Submitted by:	Pawel Pekala <c0rn at o2.pl>
This commit is contained in:
Martin Wilke 2009-03-27 21:53:43 +00:00
parent 0efe214134
commit c55582e081
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=231141
8 changed files with 139 additions and 0 deletions

View File

@ -311,6 +311,7 @@
SUBDIR += grok
SUBDIR += growspd
SUBDIR += grub
SUBDIR += gsmartcontrol
SUBDIR += gstopd
SUBDIR += gstreamer-plugins-cdio
SUBDIR += gstreamer-plugins-hal

View File

@ -0,0 +1,35 @@
# New ports collection makefile for: gsmartcontrol
# Date created: 2009-03-25
# Whom: Pawel Pekala <c0rn@o2.pl>
#
# $FreeBSD$
#
PORTNAME= gsmartcontrol
PORTVERSION= 0.8.4
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= c0rn@o2.pl
COMMENT= Graphical user interface for smartmontools
LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= pkgconfig
INSTALLS_ICONS= yes
MAN1= gsmartcontrol.1
CONFIGURE_ARGS= --disable-libglade
post-patch:
.if defined(NOPORTDOCS)
EXTRA_PATCHES+= ${PATCHDIR}/extra-Makefile.in
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (gsmartcontrol-0.8.4.tar.bz2) = 90c8bbc95726a0c64201f9e51a5abbdd
SHA256 (gsmartcontrol-0.8.4.tar.bz2) = cbd3583c365bd1f5bb87976341c31a5d6a447e2d837660e2c00828cf2f27b8ee
SIZE (gsmartcontrol-0.8.4.tar.bz2) = 625264

View File

@ -0,0 +1,33 @@
--- ./Makefile.in.orig 2009-03-23 18:59:37.000000000 +0100
+++ Makefile.in 2009-03-26 17:34:55.000000000 +0100
@@ -328,14 +328,6 @@
compilation_flags: $(top_builddir)/config.status $(srcdir)/compilation_flags.in
cd $(top_builddir) && $(SHELL) ./config.status $@
install-dist_docDATA: $(dist_doc_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @list='$(dist_doc_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- f=$(am__strip_dir) \
- echo " $(dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
- $(dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
uninstall-dist_docDATA:
@$(NORMAL_UNINSTALL)
@@ -345,15 +337,6 @@
rm -f "$(DESTDIR)$(docdir)/$$f"; \
done
install-nobase_dist_docDATA: $(nobase_dist_doc_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
- @$(am__vpath_adj_setup) \
- list='$(nobase_dist_doc_DATA)'; for p in $$list; do \
- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
- $(am__vpath_adj) \
- echo " $(nobase_dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
- $(nobase_dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
- done
uninstall-nobase_dist_docDATA:
@$(NORMAL_UNINSTALL)

View File

@ -0,0 +1,11 @@
--- ./data/Makefile.in.orig 2009-03-26 11:27:18.000000000 +0100
+++ data/Makefile.in 2009-03-26 11:27:35.000000000 +0100
@@ -686,7 +686,7 @@
uninstall-extra-mans:
cd $(DESTDIR)$(mandir)/man1 && rm -f gsmartcontrol-root.1
-install-data-hook: install-extra-mans update-icon-cache
+install-data-hook: update-icon-cache
uninstall-hook: uninstall-extra-mans update-icon-cache
update-icon-cache:

View File

@ -0,0 +1,8 @@
--- ./data/gsmartcontrol-root.in.orig 2009-03-26 18:58:31.000000000 +0100
+++ data/gsmartcontrol-root.in 2009-03-26 18:58:44.000000000 +0100
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh
############################################################################
# Copyright:
# (C) 2008 Alexander Shaduri <ashaduri 'at' gmail.com>

View File

@ -0,0 +1,8 @@
GSmartControl is a graphical user interface for smartctl (from
sysutils/smartmontools port), which is a tool for querying and
controlling SMART (Self-Monitoring, Analysis, and Reporting
Technology) data on modern hard disk drives. It allows you to
inspect the drive's SMART data to determine its health, as well
as run various tests on it.
WWW: http://gsmartcontrol.berlios.de

View File

@ -0,0 +1,40 @@
bin/gsmartcontrol
bin/gsmartcontrol-root
share/applications/gsmartcontrol.desktop
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.txt
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_boost_1_0.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_bsd-ucb.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl2.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gpl3.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_gsmartcontrol.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_hz.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_pcrecpp.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_whatever.txt
%%PORTDOCS%%%%DOCSDIR%%/LICENSE_zlib.txt
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/README
%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/cron_gather_smart.sh
%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/crontab.example
%%PORTDOCS%%%%DOCSDIR%%/contrib/cron-based_noadmin/smartctl_subst.sh
%%DATADIR%%/icon_cddvd.png
%%DATADIR%%/icon_hdd.png
share/icons/hicolor/128x128/apps/gsmartcontrol.png
share/icons/hicolor/16x16/apps/gsmartcontrol.png
share/icons/hicolor/22x22/apps/gsmartcontrol.png
share/icons/hicolor/24x24/apps/gsmartcontrol.png
share/icons/hicolor/256x256/apps/gsmartcontrol.png
share/icons/hicolor/32x32/apps/gsmartcontrol.png
share/icons/hicolor/48x48/apps/gsmartcontrol.png
share/icons/hicolor/64x64/apps/gsmartcontrol.png
share/pixmaps/gsmartcontrol.png
share/pixmaps/gsmartcontrol.xpm
@dirrm share/icons/hicolor/256x256/apps
@dirrm share/icons/hicolor/256x256
@dirrm share/icons
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib/cron-based_noadmin
%%PORTDOCS%%@dirrm %%DOCSDIR%%/contrib
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications