- Remove games/quake3-q3base since it has been renamed to games/q3base.
PR: ports/97931 Submitted by: alepulver (myself)
This commit is contained in:
parent
16fc8996ad
commit
c554d9cee7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168511
@ -1,44 +0,0 @@
|
||||
# New ports collection makefile for: q3base
|
||||
# Date created: 17 Nov 2005
|
||||
# Whom: Ed Schouten <ed@fxq.nl>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= q3base
|
||||
PORTVERSION= 0.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://quake3.quakesrc.org/files/quake3/q3base/
|
||||
|
||||
MAINTAINER= ed@fxq.nl
|
||||
COMMENT= Quake III Arena fork using SDL
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= sdl net
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET=
|
||||
|
||||
OPTIONS= X11 "Build OpenGL client" on
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "i386"
|
||||
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_X11)
|
||||
CONFIGURE_ARGS= --disable-client
|
||||
.else
|
||||
USE_GL= yes
|
||||
USE_SDL+= image
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|\($${exec_prefix}/lib\)/quake3|\1/q3base|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|botlib\.log|/dev/null|' \
|
||||
${WRKSRC}/src/botlib/be_interface.c
|
||||
|
||||
.include "${.CURDIR}/../quake3-data/Makefile.include"
|
||||
.include <bsd.port.post.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (q3base-0.1.tar.bz2) = d68f1fd6d10ecf428e85f98d43d2abd8
|
||||
SHA256 (q3base-0.1.tar.bz2) = f4b78e9cf95df438c56976850dd5ba66716ac2ed0bb6ddf5e6e9f5d797244baf
|
||||
SIZE (q3base-0.1.tar.bz2) = 1510780
|
@ -1,31 +0,0 @@
|
||||
--- ./src/game/q_shared.h.orig Wed Oct 5 19:51:28 2005
|
||||
+++ ./src/game/q_shared.h Thu Jun 15 12:03:49 2006
|
||||
@@ -140,7 +140,9 @@
|
||||
int LongSwap (int l);
|
||||
float FloatSwap (const float *f);
|
||||
|
||||
-#if defined (__i386__) || defined (__MIPSEL__) || defined (__amd64__)
|
||||
+#include <machine/endian.h>
|
||||
+
|
||||
+#if BYTE_ORDER == LITTLE_ENDIAN
|
||||
/* Little Endian */
|
||||
#define BigShort ShortSwap
|
||||
#define LittleShort
|
||||
@@ -148,7 +150,7 @@
|
||||
#define LittleLong
|
||||
#define BigFloat(l) FloatSwap(&l)
|
||||
#define LittleFloat
|
||||
-#elif defined (__mips__) || defined (__ppc__) || defined (__sparc__)
|
||||
+#elif BYTE_ORDER == BIG_ENDIAN
|
||||
/* Big Endian */
|
||||
#define BigShort
|
||||
#define LittleShort ShortSwap
|
||||
@@ -199,7 +201,7 @@
|
||||
#elif defined (__axp__)
|
||||
#define CPUSTRING "alpha"
|
||||
#else
|
||||
-#error "Unknown processor family"
|
||||
+#define CPUSTRING "unknown"
|
||||
#endif
|
||||
|
||||
/*
|
@ -1,10 +0,0 @@
|
||||
--- ./src/qcommon/common.c.orig Wed Oct 5 19:51:26 2005
|
||||
+++ ./src/qcommon/common.c Thu Jun 15 12:03:49 2006
|
||||
@@ -27,6 +27,7 @@
|
||||
#ifdef _WIN32
|
||||
#include <winsock.h>
|
||||
#else
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
#endif
|
||||
|
@ -1,13 +0,0 @@
|
||||
Q3Base is a fork of Quake III Arena. It has the following advantages
|
||||
over Quake III Arena itself:
|
||||
|
||||
- It uses SDL for establishing network connections. The client also uses
|
||||
it for loading textures (thus adding PNG support) and OpenGL
|
||||
rendering.
|
||||
- It supports FreeBSD out of the box
|
||||
- It hardcodes the shared object and datafile directories, thus removing
|
||||
the need of startup scripts
|
||||
|
||||
Q3Base is developed by the folks at Quakesrc.org.
|
||||
|
||||
WWW: http://www.quakesrc.org/
|
@ -1,10 +0,0 @@
|
||||
bin/q3base
|
||||
lib/q3base/baseq3/cgame.so
|
||||
lib/q3base/baseq3/qagame.so
|
||||
lib/q3base/baseq3/ui.so
|
||||
lib/q3base/missionpack/cgame.so
|
||||
lib/q3base/missionpack/qagame.so
|
||||
lib/q3base/missionpack/ui.so
|
||||
@dirrm lib/q3base/baseq3
|
||||
@dirrm lib/q3base/missionpack
|
||||
@dirrm lib/q3base
|
Loading…
Reference in New Issue
Block a user