games/species: Refactor after wxgtk28 removal

- Pet portclippy
- Generate makepatch compatible patches
This commit is contained in:
Muhammad Moinur Rahman 2022-12-31 04:51:54 +01:00
parent f273887cfe
commit c4c1f581ad
3 changed files with 11 additions and 15 deletions

View File

@ -12,22 +12,18 @@ WWW= http://redcoder.sourceforge.net/?p=species
LICENSE= GPLv1+ # though COPYING files mention LGPL21 and GPLv2 instead
USES= gmake dos2unix tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= VISITOOL
VISITOOL_DESC= Build GUI tool for displaying evolution
OPTIONS_SUB= yes
VISITOOL_USE= WX=2.4
VISITOOL_DESC= Build GUI tool for displaying evolution
VISITOOL_USE= WX=3.0
VISITOOL_MAKE_ENV= WX_CONFIG="${TRUE}"
VISITOOL_ALL_TARGET= all visitool
.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MVISITOOL)
MAKE_ENV+= WX_CONFIG="${TRUE}"
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
@ -35,8 +31,8 @@ do-install:
.for i in bench evolver_hill wilfiz
@(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${DATADIR})
.endfor
.if ${PORT_OPTIONS:MVISITOOL}
do-install-VISITOOL-on:
${INSTALL_PROGRAM} ${WRKSRC}/visitool ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-visitool
.endif
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- ./Makefile.orig Sun Feb 22 03:54:24 2004
+++ ./Makefile Wed Jan 16 18:29:09 2008
--- Makefile.orig 2022-12-31 03:50:49 UTC
+++ Makefile
@@ -1,22 +1,22 @@
# makefile for species

View File

@ -1,6 +1,6 @@
--- main.cpp.orig
--- main.cpp.orig 2022-12-31 03:50:49 UTC
+++ main.cpp
@@ -29,7 +29,7 @@
@@ -29,7 +29,7 @@ using namespace std;
/***** main program entry point ********************/