irc/scrollz: Update to version 2.3.1
ChangeLog: https://www.scrollz.info/download/ChangeLog.2.3.1.txt Use online commit to avoid gcc. PR: 262693 Reported by: Christopher.petrik@usm.edu Approved by: freebsd@bitchx.org (maintainer, timeout > 2 weeks) Reviewed by: mikael@ MFH: 2022Q2 (bugfix release, security) Security: CVE-2021-29376
This commit is contained in:
parent
8cd785de15
commit
c4a3720505
@ -1,11 +1,14 @@
|
||||
# Created by: Will Andrews <andrews@technologist.com>
|
||||
|
||||
PORTNAME= ScrollZ
|
||||
PORTVERSION= 2.3
|
||||
PORTVERSION= 2.3.1
|
||||
DISTVERSIONPREFIX= ${PORTNAME}-
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= irc
|
||||
|
||||
# Fix build with clang
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES= c0dfa140341cf9a848a6e5f926392623d03d2c28.patch:-p1
|
||||
|
||||
MAINTAINER= freebsd@bitchx.org
|
||||
COMMENT= Enhanced ircII client that supports scripts, colors, and more
|
||||
|
||||
@ -20,9 +23,9 @@ DATADIR= ${PREFIX}/share/${PORTNAME:tl}
|
||||
PLIST_SUB= SCROLLZ_VER="${PORTVERSION}"
|
||||
|
||||
OPTIONS_DEFINE= IPV6 REGEX UTF8
|
||||
OPTIONS_DEFAULT= OPENSSL REGEX UTF8
|
||||
OPTIONS_RADIO= SSL
|
||||
OPTIONS_RADIO_SSL= GNUTLS OPENSSL
|
||||
OPTIONS_DEFAULT= OPENSSL REGEX UTF8
|
||||
|
||||
IPV6_CONFIGURE_ENABLE= ipv6
|
||||
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
|
||||
|
@ -1,2 +1,5 @@
|
||||
SHA256 (ScrollZ-ScrollZ-ScrollZ-2.3_GH0.tar.gz) = 22535bcc54ad752107ab181775d90d9cf1b37648f500d627f428388a9d3710e6
|
||||
SIZE (ScrollZ-ScrollZ-ScrollZ-2.3_GH0.tar.gz) = 981707
|
||||
TIMESTAMP = 1649327902
|
||||
SHA256 (ScrollZ-ScrollZ-ScrollZ-2.3.1_GH0.tar.gz) = 4ff4570020174b2ee9a859767c349e498e5ae68e2a76f11d69c08f12979b0452
|
||||
SIZE (ScrollZ-ScrollZ-ScrollZ-2.3.1_GH0.tar.gz) = 983428
|
||||
SHA256 (c0dfa140341cf9a848a6e5f926392623d03d2c28.patch) = 770cccf8e8931d72d0894602c2e151ed61d3ace5244f397446515452410c2e61
|
||||
SIZE (c0dfa140341cf9a848a6e5f926392623d03d2c28.patch) = 655
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.in.orig 2011-04-29 17:21:18.000000000 +0900
|
||||
+++ Makefile.in 2013-03-09 19:35:03.628110600 +0900
|
||||
--- Makefile.in.orig 2021-05-06 08:04:55 UTC
|
||||
+++ Makefile.in
|
||||
@@ -31,14 +31,14 @@
|
||||
# @(#)$Id: Makefile.in,v 1.23 2006-10-31 12:31:27 f Exp $
|
||||
|
||||
@ -28,10 +28,10 @@
|
||||
datarootdir = @datarootdir@
|
||||
-mandir = @mandir@
|
||||
+mandir = @mandir@/man1
|
||||
|
||||
|
||||
DESTDIR =
|
||||
|
||||
@@ -105,7 +105,7 @@
|
||||
@@ -106,7 +106,7 @@ INSTALL_IRCFLUSH = $(bindir)/ircflush
|
||||
|
||||
# This program allows you to use screen/xterm's to put new irc windows
|
||||
# on new screen/xterm windows.
|
||||
@ -40,7 +40,7 @@
|
||||
|
||||
# This command will be used to install the irc help files. If you don't
|
||||
# want to install them, replace with the following:
|
||||
@@ -126,14 +126,13 @@
|
||||
@@ -127,14 +127,13 @@ INSTALL_DATA = ./bsdinstall -c -m 644
|
||||
VERSION = @VERSION@
|
||||
|
||||
SHELL = /bin/sh
|
||||
@ -56,7 +56,7 @@
|
||||
'IRCSHARE=$(IRCSHARE)' \
|
||||
'IRCPATH=$(IRC_PATH)' \
|
||||
'LDFLAGS=$(LDFLAGS)' \
|
||||
@@ -143,32 +142,23 @@
|
||||
@@ -144,32 +143,23 @@ MFLAGS ='CC=$(CC)' \
|
||||
'LN=$(LN)' \
|
||||
'RM=$(RM)'
|
||||
|
||||
@ -95,7 +95,7 @@
|
||||
installbin: installirc
|
||||
|
||||
installirc: scrollz installdirs
|
||||
@@ -189,8 +179,8 @@
|
||||
@@ -190,8 +180,8 @@ installio: ircio installdirs
|
||||
installflush: ircflush installdirs
|
||||
$(INSTALL) source/ircflush $(DESTDIR)/$(INSTALL_IRCFLUSH)
|
||||
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff --git a/include/ircterm.h b/include/ircterm.h
|
||||
index 1fdbfeb..1da3fab 100644
|
||||
--- include/ircterm.h
|
||||
+++ include/ircterm.h
|
||||
@@ -89,9 +89,9 @@ extern char *CM,
|
||||
extern int SG;
|
||||
/**************************** PATCHED by Flier ******************************/
|
||||
#ifdef WANTANSI
|
||||
-char *SETAF,
|
||||
+extern char *SETAF,
|
||||
*SETAB;
|
||||
-int NUMCOLORS;
|
||||
+extern int NUMCOLORS;
|
||||
#endif /* WANTANSI */
|
||||
/****************************************************************************/
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- include/screen.h.orig 2011-04-29 17:21:18.000000000 +0900
|
||||
+++ include/screen.h 2013-03-11 23:30:07.063088471 +0900
|
||||
--- include/screen.h.orig 2021-05-06 08:04:55 UTC
|
||||
+++ include/screen.h
|
||||
@@ -47,6 +47,7 @@
|
||||
#define ST_NOTHING -1
|
||||
#define ST_SCREEN 0
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- include/window.h.orig 2011-04-29 17:21:18.000000000 +0900
|
||||
+++ include/window.h 2013-03-09 18:47:08.841093765 +0900
|
||||
--- include/window.h.orig 2021-05-06 08:04:55 UTC
|
||||
+++ include/window.h
|
||||
@@ -42,7 +42,7 @@
|
||||
* CREATE, that allows you to start new iscreen or xterm windows
|
||||
* connected to the ircII client.
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- source/Makefile.in.orig 2011-04-29 17:21:18.000000000 +0900
|
||||
+++ source/Makefile.in 2013-03-09 19:07:14.372106954 +0900
|
||||
@@ -47,7 +47,7 @@
|
||||
--- source/Makefile.in.orig 2021-05-06 08:04:55 UTC
|
||||
+++ source/Makefile.in
|
||||
@@ -47,7 +47,7 @@ IRCFLUSH_OBJECTS = ircflush.o ircsig.o
|
||||
INCLUDES = -I../include
|
||||
|
||||
default:
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
all: scrollz
|
||||
|
||||
@@ -63,7 +63,7 @@
|
||||
@@ -63,7 +63,7 @@ clean::
|
||||
$(RM) scrollz $(OBJECTS)
|
||||
|
||||
install: scrollz
|
||||
@ -18,7 +18,7 @@
|
||||
|
||||
# .o files needing special compilation flags
|
||||
|
||||
@@ -86,7 +86,7 @@
|
||||
@@ -86,7 +86,7 @@ translat.o: Makefile ../Makefile
|
||||
$(CC) $(CFLAGS) $(DEFS) $(PP_DEFS) $(INCLUDES) -DTRANSLATION_PATH=\"$(TRANS_DIR)/\" -c translat.c
|
||||
|
||||
screen.o: Makefile ../Makefile
|
||||
@ -27,7 +27,7 @@
|
||||
|
||||
# auxiliary programs
|
||||
|
||||
@@ -96,7 +96,7 @@
|
||||
@@ -96,7 +96,7 @@ ircflush: $(IRCFLUSH_OBJECTS)
|
||||
ircio: $(IRCIO_OBJECTS)
|
||||
$(CC) $(INCLUDES) $(CFLAGS) $(LDFLAGS) $(DEFS) $(PPS_DEFS) -o $@ $(IRCIO_OBJECTS) $(LIBS)
|
||||
|
||||
@ -36,7 +36,7 @@
|
||||
$(CC) $(INCLUDES) $(CFLAGS) $(LDFLAGS) $(DEFS) -o $@ $(WSERV_OBJECTS) $(LIBS)
|
||||
|
||||
clean::
|
||||
@@ -106,7 +106,7 @@
|
||||
@@ -106,7 +106,7 @@ clean::
|
||||
$(RM) ircio ircio.o newio.o
|
||||
|
||||
clean::
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./source/screen.c.orig 2011-04-29 03:21:18.000000000 -0500
|
||||
+++ ./source/screen.c 2013-07-13 07:45:53.092133202 -0500
|
||||
@@ -2424,6 +2424,10 @@
|
||||
--- source/screen.c.orig 2021-05-06 08:04:55 UTC
|
||||
+++ source/screen.c
|
||||
@@ -2425,6 +2425,10 @@ create_additional_screen()
|
||||
{
|
||||
screen_type = ST_SCREEN;
|
||||
}
|
||||
@ -11,7 +11,7 @@
|
||||
else if ((char *) 0 != (displayvar = getenv("DISPLAY")))
|
||||
{
|
||||
if ((char *) 0 == (termvar = getenv("TERM")))
|
||||
@@ -2462,6 +2466,7 @@
|
||||
@@ -2463,6 +2467,7 @@ create_additional_screen()
|
||||
say("Opening new %s...",
|
||||
screen_type == ST_XTERM ? "window" :
|
||||
screen_type == ST_SCREEN ? "screen" :
|
||||
@ -19,10 +19,11 @@
|
||||
"wound" );
|
||||
snprintf(sock.sun_path, sizeof sock.sun_path, "/tmp/irc_%08d_%x", (int) pid, mycycle);
|
||||
sock.sun_family = AF_UNIX;
|
||||
@@ -2577,6 +2582,22 @@
|
||||
@@ -2577,6 +2582,22 @@ create_additional_screen()
|
||||
args[i++] = error_sockaddr->sun_path;
|
||||
args[i] = NULL;
|
||||
execvp(xterm, args);
|
||||
}
|
||||
+ }
|
||||
+ else if (screen_type == ST_TMUX)
|
||||
+ {
|
||||
+ char *args[64],
|
||||
@ -38,7 +39,6 @@
|
||||
+ Debug((3, "added: %s %s '%s'", args[i-3], args[i-2], args[i-1]));
|
||||
+ args[i++] = NULL;
|
||||
+ execvp("tmux", args);
|
||||
+ }
|
||||
}
|
||||
perror("execve");
|
||||
unlink(sockaddr->sun_path);
|
||||
unlink(error_sockaddr->sun_path);
|
||||
|
@ -541,6 +541,7 @@ man/man1/scrollz.1.gz
|
||||
%%DATADIR%%/help/set/netsplit_time
|
||||
%%DATADIR%%/help/set/no_ask_nickname
|
||||
%%DATADIR%%/help/set/no_ctcp_flood
|
||||
%%DATADIR%%/help/set/notification_level
|
||||
%%DATADIR%%/help/set/notify_handler
|
||||
%%DATADIR%%/help/set/notify_level
|
||||
%%DATADIR%%/help/set/notify_on_termination
|
||||
|
Loading…
Reference in New Issue
Block a user