MFH: r467819 r468035

mysql57-{client, server}: Update port to 5.7.22
This update includes fixes for multiple CVEs including:
    CVE-2018-2755 in replication component, MySQL protocol
    CVE-2018-2805 in GIS extention
    CVE-2018-2782 in InnoDB
    and more info on http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html#AppendixMSQL

PR:		227621
Reported by:	Markus Kohlmeyer <rootservice@gmail.com>
Sponsored by:	Netzkommune GmbH

databases/mysql57-client: Fix build with 10.x default compiler/linker
The upstream seems merged our local-patches but
added a -R flag to its `c++` [actually ld] command.
The -R $DIR is like -rpath on 11.x and CURRENT bases but not on 10.x
We then use -rpath to make sure it works on all supported bases.

Reported by:	John W. O'Brien <john@saltant.com>
Sponsored by:	Netzkommune GmbH

Approved by:	ports-secteam (feld)
This commit is contained in:
Mahdi Mokhtari 2018-05-06 16:03:04 +00:00
parent 9cc7408017
commit c4a319df18
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=469236
5 changed files with 17 additions and 6 deletions

View File

@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= 57-client
COMMENT= Multithreaded SQL database (client)

View File

@ -0,0 +1,11 @@
--- libmysql/authentication_ldap/CMakeLists.txt.orig 2018-03-04 13:40:40 UTC
+++ libmysql/authentication_ldap/CMakeLists.txt
@@ -54,7 +54,7 @@ ENDIF()
IF (CMAKE_SYSTEM_NAME MATCHES "SunOS")
SET(SASL_LIBRARY "sasl")
ELSEIF(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
- SET(SASL_LIBRARY "-L/usr/local/lib -R/usr/local/lib -lsasl2")
+ SET(SASL_LIBRARY "-L/usr/local/lib -rpath /usr/local/lib -lsasl2")
ELSE()
SET(SASL_LIBRARY "sasl2")
ENDIF ()

View File

@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME?= mysql
PORTVERSION= 5.7.21
PORTREVISION?= 1
PORTVERSION= 5.7.22
PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= MYSQL/MySQL-5.7
PKGNAMESUFFIX?= 57-server

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1516137476
SHA256 (mysql-boost-5.7.21.tar.gz) = ad29ecb6fb3c3571394fe231633a2d1d188d49e9eb749daa4e8799b7630daa09
SIZE (mysql-boost-5.7.21.tar.gz) = 48931457
TIMESTAMP = 1524221054
SHA256 (mysql-boost-5.7.22.tar.gz) = 5b2a61700af7c99f5630a7dfdb099af9283c3029843cddd9e123bcdbcc4aad03
SIZE (mysql-boost-5.7.22.tar.gz) = 48985783

View File

@ -85,7 +85,6 @@ man/man1/mysqld_multi.1.gz
man/man1/mysqld_safe.1.gz
man/man1/mysqldumpslow.1.gz
man/man1/mysqlman.1.gz
man/man1/mysqltest.1.gz
man/man1/perror.1.gz
man/man1/replace.1.gz
man/man1/resolve_stack_dump.1.gz