Fix broken pkg-plist: the docs snuck in there, but they are also added

by the port at build-time.

Fix for FreeBSD-CURRENT:
= Remove use of malloc.h
= A fragment of this port actually provides its own prototype for time(), and
  probably only gets it right on DEC and HP systems.

PR:		ports/34183
Reported by:	Trish Lynch <trish@bsdunix.net>
This commit is contained in:
Jacques Vidrine 2002-01-22 22:40:36 +00:00
parent 91a02f9b6d
commit c49659f44d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53611
3 changed files with 21 additions and 23 deletions

View File

@ -0,0 +1,10 @@
--- base/pam_eps/pam_eps_passwd.c.orig Tue Jan 22 16:26:28 2002
+++ base/pam_eps/pam_eps_passwd.c Tue Jan 22 16:26:42 2002
@@ -75,7 +75,6 @@
#include <syslog.h>
#include <string.h>
#include <stdarg.h>
-#include <malloc.h>
#include <t_pwd.h>
#ifndef LINUX /* AGM added this as of 0.2 */

View File

@ -1,5 +1,5 @@
--- telnet/telnetd/sys_term.c.orig Tue Aug 21 09:02:37 2001
+++ telnet/telnetd/sys_term.c Tue Aug 21 09:03:33 2001
--- telnet/telnetd/sys_term.c.orig Tue Jul 31 01:27:05 2001
+++ telnet/telnetd/sys_term.c Tue Jan 22 16:31:27 2002
@@ -111,6 +111,9 @@
# else
char wtmpf[] = "/usr/adm/wtmp";
@ -10,3 +10,12 @@
# ifdef UTMP_FILE
char utmpf[] = UTMP_FILE;
# else
@@ -1473,7 +1476,7 @@
{
register int i;
int syncpipe[2];
-#if defined(OSF) || defined(ultrix) || defined(__hpux)
+#if defined(OSF) || defined(ultrix) || defined(__hpux) || defined(__FreeBSD__)
time_t time();
#else
long time();

View File

@ -18,24 +18,3 @@ lib/pam_eps_passwd.so
sbin/eps_chkpwd
sbin/ftpd
sbin/telnetd
share/doc/srp/Acknowledgements
share/doc/srp/Copyrights
share/doc/srp/LICENSE
share/doc/srp/copyright.c
share/doc/srp/draft-altman-rfc2942bis-00.txt
share/doc/srp/draft-altman-rfc2944bis-01.txt
share/doc/srp/draft-altman-telnet-fwdx-02.txt
share/doc/srp/draft-ietf-tn3270e-telnet-tls-05.txt
share/doc/srp/rfc2941.txt
share/doc/srp/rfc2942.txt
share/doc/srp/rfc2944.txt
share/doc/srp/rfc2945.txt
share/doc/srp/rfc2946.txt
share/doc/srp/rfc2947.txt
share/doc/srp/rfc2948.txt
share/doc/srp/rfc2949.txt
share/doc/srp/rfc2950.txt
share/doc/srp/rfc2952.txt
share/doc/srp/rfc2953.txt
share/doc/srp/srp.ps
@dirrm share/doc/srp