Update Phonon to 4.9.0.

Release notes:
- https://community.kde.org/Phonon/Releases/Core/4.9.0
- https://community.kde.org/Phonon/Releases/GStreamer/4.9.0
- https://community.kde.org/Phonon/Releases/VLC/0.9.0

This release fixes the build with the upcoming Qt 5.6, which was failing like
this:

    /usr/bin/c++   -O2 -pipe -fstack-protector -fno-strict-aliasing -Wnon-virtual-dtor -Wno-long-long -Wundef -Wcast-align -Wchar-subscripts -Wall -W -Wpointer-arith -Wformat-security -Woverloaded-virtual -fno-common -fvisibility=hidden -Werror=return-type -fvisibility-inlines-hidden -Wno-return-type-c-linkage     CMakeFiles/cmTC_08ed6.dir/check_qt_visibility.cpp.o  -o cmTC_08ed6
    CMakeFiles/cmTC_08ed6.dir/check_qt_visibility.cpp.o:(.qtversion[qt_version_tag]+0x0): undefined reference to `qt_version_tag'

Most of the work was done by tcberner@.

PR:		211916
This commit is contained in:
Raphael Kubo da Costa 2016-09-04 14:30:13 +00:00
parent 9d00fc2b3e
commit c4394b98d4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=421340
19 changed files with 65 additions and 55 deletions

View File

@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.3
PORTVERSION= 4.9.0
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
PKGNAMESUFFIX= -designerplugin
DIST_SUBDIR= KDE

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.2
PORTREVISION= 1
PORTVERSION= 4.9.0
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}
PKGNAMESUFFIX= -gstreamer
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
@ -15,6 +14,8 @@ COMMENT= GStreamer backend for Phonon
LICENSE= LGPL21
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
USES= cmake kde:4 pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 20e0f71f2beb4f859db8385079a13aef5473863ee6f27aad7b065aa7bfe931e0
SIZE (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 76044
TIMESTAMP = 1472999348
SHA256 (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = cec3e5ece1261d344b68363ef0606ebf49772628ba94bb55b0c0d18773b885f1
SIZE (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = 75960

View File

@ -1,10 +0,0 @@
--- CMakeLists.txt.orig 2015-09-28 21:27:35.073619000 +0200
+++ CMakeLists.txt 2015-09-28 21:44:28.823199000 +0200
@@ -50,6 +50,7 @@
macro_log_feature(LIBXML2_FOUND "LibXml2" "LibXml2 is required to compile the gstreamer backend for Phonon" "http://xmlsoft.org/downloads.html" TRUE)
+add_definitions(${GSTREAMER_DEFINITIONS})
add_subdirectory(gstreamer)

View File

@ -1,4 +1,5 @@
lib/kde4/plugins/phonon_backend/phonon_gstreamer.so
%%QT_PLUGINDIR%%/phonon_backend/libphonon_gstreamer.so
share/icons/hicolor/128x128/apps/phonon-gstreamer.png
share/icons/hicolor/16x16/apps/phonon-gstreamer.png
share/icons/hicolor/22x22/apps/phonon-gstreamer.png
@ -6,4 +7,3 @@ share/icons/hicolor/48x48/apps/phonon-gstreamer.png
share/icons/hicolor/64x64/apps/phonon-gstreamer.png
share/icons/hicolor/scalable/apps/phonon-gstreamer.svgz
share/kde4/services/phononbackends/gstreamer.desktop
%%QT_PREFIX%%/%%QT_PLUGINDIR%%/phonon_backend/libphonon_gstreamer.so

View File

@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 0.8.2
PORTREVISION= 1
PORTVERSION= 0.9.0
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}
PKGNAMESUFFIX= -vlc
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
@ -14,6 +13,8 @@ COMMENT= VLC backend for Phonon
LIB_DEPENDS= libvlc.so:multimedia/vlc-qt4
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
USES= cmake kde:4 pkgconfig tar:xz
USE_KDE= automoc4
USE_QT4= corelib gui phonon \

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-backend-vlc-0.8.2.tar.xz) = dab7f8edf53ee90998e5e3fcf2f6bd0a13750511b0ecde6939be0664d46bdaa3
SIZE (KDE/phonon-backend-vlc-0.8.2.tar.xz) = 59832
TIMESTAMP = 1472999353
SHA256 (KDE/phonon-backend-vlc-0.9.0.tar.xz) = c0ced7ca571acc22211eecf5158241714fa9ccdb82d4fe0a970ad702860ccdbe
SIZE (KDE/phonon-backend-vlc-0.9.0.tar.xz) = 60044

View File

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.3
PORTVERSION= 4.9.0
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-4.8.3.tar.xz) = a1149c961ca1570968d070bbd23671e614aa506f847ca93748960e309f85da16
SIZE (KDE/phonon-4.8.3.tar.xz) = 322012
TIMESTAMP = 1472999341
SHA256 (KDE/phonon-4.9.0.tar.xz) = bb74b40f18ade1d9ab89ffcd7aeb7555be797ca395f1224c488b394da6deb0e0
SIZE (KDE/phonon-4.9.0.tar.xz) = 321860

View File

@ -159,6 +159,10 @@ include/phonon/volumefaderinterface.h
include/phonon/volumeslider.h
lib/cmake/phonon/PhononConfig.cmake
lib/cmake/phonon/PhononConfigVersion.cmake
lib/cmake/phonon/PhononExperimentalConfig.cmake
lib/cmake/phonon/PhononExperimentalConfigVersion.cmake
lib/cmake/phonon/PhononExperimentalTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phonon/PhononExperimentalTargets.cmake
lib/cmake/phonon/PhononTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phonon/PhononTargets.cmake
lib/libphonon.so
@ -170,7 +174,6 @@ lib/libphononexperimental.so.%%SHLIB_VER%%
libdata/pkgconfig/phonon.pc
share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
%%DATADIR%%/buildsystem/COPYING-CMAKE-SCRIPTS
%%DATADIR%%/buildsystem/FindAutomoc4.cmake
%%DATADIR%%/buildsystem/FindPackageHandleStandardArgs.cmake
%%DATADIR%%/buildsystem/FindPhononInternal.cmake
%%DATADIR%%/buildsystem/MacroEnsureVersion.cmake
@ -178,6 +181,8 @@ share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
%%DATADIR%%/buildsystem/MacroOptionalFindPackage.cmake
%%DATADIR%%/buildsystem/MacroPushRequiredVars.cmake
%%DATADIR%%/buildsystem/PhononMacros.cmake
%%DATADIR%%/buildsystem/PhononQt4.cmake
%%DATADIR%%/buildsystem/PhononQt5.cmake
%%DATADIR%%/buildsystem/cmake_uninstall.cmake.in
%%QT_PREFIX%%/%%QT_INCDIR%%/Phonon
%%QT_PREFIX%%/%%QT_INCDIR%%/phonon

View File

@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.3
PORTVERSION= 4.9.0
CATEGORIES= multimedia kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= qt5-
PKGNAMESUFFIX= 4
PKGNAMESUFFIX= -designerplugin
@ -14,6 +14,8 @@ COMMENT= Qt 5 Designer plugin for Phonon 4
LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
USES= cmake tar:xz
USE_QT5= buildtools_build qmake_build designer phonon4
CMAKE_ARGS= -DPHONON_QT_PLUGIN_INSTALL_DIR=${PREFIX}/${QT_PLUGINDIR_REL}/designer \
@ -23,6 +25,6 @@ BUILD_WRKSRC= ${WRKSRC}/designer
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DISTINFO_FILE= ${.CURDIR:H}/qt5-phonon4/distinfo
PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/libphononwidgets.so
PLIST_FILES= ${QT_PLUGINDIR_REL}/designer/phononwidgets.so
.include <bsd.port.mk>

View File

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.2
PORTVERSION= 4.9.0
CATEGORIES= multimedia
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend-gstreamer/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend-gstreamer/${PORTVERSION}
PKGNAMEPREFIX= qt5-
PKGNAMESUFFIX= 4-gstreamer
DISTNAME= ${PORTNAME}-backend-gstreamer-${PORTVERSION}
@ -15,11 +15,16 @@ COMMENT= GStreamer backend for Phonon 4 Qt 5
LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
USES= cmake pkgconfig tar:xz
USE_GL= gl
USE_GNOME= glib20 libxml2
USE_GSTREAMER1= yes
USE_QT5= buildtools_build qmake_build core gui opengl widgets phonon4
USE_QT5= buildtools_build qmake_build core gui opengl phonon widgets \
x11extras
CMAKE_ARGS= -DPHONON_BUILD_PHONON4QT5=ON
OPTIONS_DEFINE= GST_PLUGINS

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 20e0f71f2beb4f859db8385079a13aef5473863ee6f27aad7b065aa7bfe931e0
SIZE (KDE/phonon-backend-gstreamer-4.8.2.tar.xz) = 76044
TIMESTAMP = 1472999371
SHA256 (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = cec3e5ece1261d344b68363ef0606ebf49772628ba94bb55b0c0d18773b885f1
SIZE (KDE/phonon-backend-gstreamer-4.9.0.tar.xz) = 75960

View File

@ -1,10 +0,0 @@
--- CMakeLists.txt.orig 2015-09-28 22:29:01.280860000 +0200
+++ CMakeLists.txt 2015-09-28 22:29:20.710032000 +0200
@@ -50,6 +50,7 @@
macro_log_feature(LIBXML2_FOUND "LibXml2" "LibXml2 is required to compile the gstreamer backend for Phonon" "http://xmlsoft.org/downloads.html" TRUE)
+add_definitions(${GSTREAMER_DEFINITIONS})
add_subdirectory(gstreamer)

View File

@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 0.8.2
PORTVERSION= 0.9.0
CATEGORIES= multimedia
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}
PKGNAMEPREFIX= qt5-
PKGNAMESUFFIX= -vlc
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
@ -12,8 +12,11 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= VLC backend for Phonon 4 Qt 5
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
LIB_DEPENDS= libvlc.so:multimedia/vlc
WRKSRC= ${WRKDIR}/${DISTNAME:S/-backend//}
USES= cmake pkgconfig tar:xz
USE_QT5= core gui widgets phonon4 \
buildtools_build qmake_build

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-backend-vlc-0.8.2.tar.xz) = dab7f8edf53ee90998e5e3fcf2f6bd0a13750511b0ecde6939be0664d46bdaa3
SIZE (KDE/phonon-backend-vlc-0.8.2.tar.xz) = 59832
TIMESTAMP = 1472999373
SHA256 (KDE/phonon-backend-vlc-0.9.0.tar.xz) = c0ced7ca571acc22211eecf5158241714fa9ccdb82d4fe0a970ad702860ccdbe
SIZE (KDE/phonon-backend-vlc-0.9.0.tar.xz) = 60044

View File

@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.8.3
PORTVERSION= 4.9.0
CATEGORIES= multimedia
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= qt5-
PKGNAMESUFFIX= 4
DIST_SUBDIR= KDE
@ -13,6 +13,8 @@ COMMENT= Phonon 4 transitional library for Qt 5
LICENSE= LGPL21
BUILD_DEPENDS= ${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
USES= cmake pathfix tar:xz
USE_QT5= core dbus declarative gui opengl widgets \
buildtools_build qmake_build

View File

@ -1,2 +1,3 @@
SHA256 (KDE/phonon-4.8.3.tar.xz) = a1149c961ca1570968d070bbd23671e614aa506f847ca93748960e309f85da16
SIZE (KDE/phonon-4.8.3.tar.xz) = 322012
TIMESTAMP = 1472999358
SHA256 (KDE/phonon-4.9.0.tar.xz) = bb74b40f18ade1d9ab89ffcd7aeb7555be797ca395f1224c488b394da6deb0e0
SIZE (KDE/phonon-4.9.0.tar.xz) = 321860

View File

@ -158,6 +158,10 @@ include/phonon4qt5/phonon/volumefaderinterface.h
include/phonon4qt5/phonon/volumeslider.h
lib/cmake/phonon4qt5/Phonon4Qt5Config.cmake
lib/cmake/phonon4qt5/Phonon4Qt5ConfigVersion.cmake
lib/cmake/phonon4qt5/Phonon4Qt5ExperimentalConfig.cmake
lib/cmake/phonon4qt5/Phonon4Qt5ExperimentalConfigVersion.cmake
lib/cmake/phonon4qt5/PhononExperimentalTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phonon4qt5/PhononExperimentalTargets.cmake
lib/cmake/phonon4qt5/PhononTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phonon4qt5/PhononTargets.cmake
lib/libphonon4qt5.so
@ -170,7 +174,6 @@ lib/libphonon4qt5experimental.so.%%SHLIB_VER%%
libdata/pkgconfig/phonon4qt5.pc
share/dbus-1/interfaces/org.kde.Phonon4Qt5.AudioOutput.xml
share/phonon4qt5/buildsystem/COPYING-CMAKE-SCRIPTS
share/phonon4qt5/buildsystem/FindAutomoc4.cmake
share/phonon4qt5/buildsystem/FindPackageHandleStandardArgs.cmake
share/phonon4qt5/buildsystem/FindPhononInternal.cmake
share/phonon4qt5/buildsystem/MacroEnsureVersion.cmake
@ -178,4 +181,6 @@ share/phonon4qt5/buildsystem/MacroLogFeature.cmake
share/phonon4qt5/buildsystem/MacroOptionalFindPackage.cmake
share/phonon4qt5/buildsystem/MacroPushRequiredVars.cmake
share/phonon4qt5/buildsystem/PhononMacros.cmake
share/phonon4qt5/buildsystem/PhononQt4.cmake
share/phonon4qt5/buildsystem/PhononQt5.cmake
share/phonon4qt5/buildsystem/cmake_uninstall.cmake.in