Add TrustedQSL, an Amateur Radio Station electronic trusted logbook
The mission of the Trusted QSL Group is to keep eQSL an open and free activity for amateur radio operators by promoting the Digital Signature Standard (DSS). PR: ports/70643 Submitted by: Diane Bruce <db@db.net>
This commit is contained in:
parent
5c2c865cae
commit
c428acb9f1
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=116984
@ -82,6 +82,7 @@
|
||||
SUBDIR += tits
|
||||
SUBDIR += tkhylafax
|
||||
SUBDIR += tkscanfax
|
||||
SUBDIR += trustedqsl
|
||||
SUBDIR += viewfax
|
||||
SUBDIR += vpb2
|
||||
SUBDIR += vrflash
|
||||
|
51
comms/trustedqsl/Makefile
Normal file
51
comms/trustedqsl/Makefile
Normal file
@ -0,0 +1,51 @@
|
||||
# New ports collection makefile for: TrustedQSL
|
||||
# Date created: 20th July 2004
|
||||
# Whom: Diane Bruce <db@db.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= trustedqsl
|
||||
PORTVERSION= 1.10
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= trustedqsl
|
||||
DISTFILES= tqsllib-1.4.tar.gz TrustedQSL-1.10.tar.gz
|
||||
|
||||
MAINTAINER= db@db.net
|
||||
COMMENT= Amateur Radio Station electronic trusted logbook
|
||||
|
||||
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2 \
|
||||
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
|
||||
|
||||
USE_GETOPT_LONG= yes
|
||||
USE_REINPLACE= yes
|
||||
MAKE_ENV= INCDIR="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
post-patch:
|
||||
${CP} ${FILESDIR}/Makefile ${WRKSRC}
|
||||
${CP} ${FILESDIR}/Makefile.tqsllib ${WRKSRC}/tqsllib/Makefile
|
||||
${CP} ${FILESDIR}/Makefile.tqsllib-apps ${WRKSRC}/tqsllib-apps/Makefile
|
||||
|
||||
do-extract:
|
||||
@${RM} -rf ${WRKDIR}
|
||||
@${MKDIR} ${WRKDIR}
|
||||
@${MKDIR} ${WRKSRC}
|
||||
@for file in ${EXTRACT_ONLY}; do \
|
||||
if ! (cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$file ${EXTRACT_AFTER_ARGS});\
|
||||
then \
|
||||
exit 1; \
|
||||
fi \
|
||||
done
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/doc/tqslcert
|
||||
@${MKDIR} ${PREFIX}/share/doc/tqslapp
|
||||
@${CP} ${WRKSRC}/tqsllib-apps/tqslcert_help/* ${PREFIX}/share/doc/tqslcert/
|
||||
@${CP} ${WRKSRC}/tqsllib-apps/tqsl_help/* ${PREFIX}/share/doc/tqslapp/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
4
comms/trustedqsl/distinfo
Normal file
4
comms/trustedqsl/distinfo
Normal file
@ -0,0 +1,4 @@
|
||||
MD5 (tqsllib-1.4.tar.gz) = 008705afbf39f52e0984e195d32e8378
|
||||
SIZE (tqsllib-1.4.tar.gz) = 160585
|
||||
MD5 (TrustedQSL-1.10.tar.gz) = c0b8108c744d574204649cd375474982
|
||||
SIZE (TrustedQSL-1.10.tar.gz) = 223927
|
9
comms/trustedqsl/files/Makefile
Normal file
9
comms/trustedqsl/files/Makefile
Normal file
@ -0,0 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
all:
|
||||
(cd tqsllib;make)
|
||||
(cd tqsllib-apps;make)
|
||||
|
||||
install:
|
||||
(cd tqsllib;make install)
|
||||
(cd tqsllib-apps;make install)
|
49
comms/trustedqsl/files/Makefile.tqsllib
Normal file
49
comms/trustedqsl/files/Makefile.tqsllib
Normal file
@ -0,0 +1,49 @@
|
||||
CXX = g++
|
||||
CC ?= gcc
|
||||
LIBS=-lcrypto -lexpat
|
||||
CXXFLAGS += -I. $(INCDIR) -DHAVE_CONFIG_H
|
||||
LDFLAGS += -L. $(LIBS) -lstdc++
|
||||
TARGETS = gen_crq load_cert station_loc dumptqsldata converter
|
||||
ZLIB=z
|
||||
MYLIB=tqsllib
|
||||
|
||||
OBJS= tqsllib.o openssl_cert.o adif.o xml.o\
|
||||
location.o tqslconvert.o cabrillo.o
|
||||
|
||||
all: $(TARGETS)
|
||||
|
||||
gen_crq: gen_crq.o lib$(MYLIB).a
|
||||
${CXX} -o gen_crq gen_crq.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
|
||||
|
||||
load_cert: load_cert.o lib$(MYLIB).a
|
||||
${CXX} -o load_cert load_cert.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
|
||||
|
||||
converter: converter.o lib$(MYLIB).a
|
||||
${CXX} -o converter converter.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
|
||||
|
||||
station_loc: station_loc.o lib$(MYLIB).a
|
||||
${CXX} -o station_loc station_loc.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
|
||||
|
||||
dumptqsldata: dumptqsldata.o lib$(MYLIB).a
|
||||
${CXX} -o dumptqsldata dumptqsldata.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
|
||||
|
||||
include tqsllib.depends
|
||||
|
||||
libtqsllib.a: $(OBJS)
|
||||
${AR} qc libtqsllib.a ${OBJS}
|
||||
|
||||
install:
|
||||
${INSTALL} gen_crq ${PREFIX}/bin
|
||||
${INSTALL} load_cert ${PREFIX}/bin
|
||||
${INSTALL} converter ${PREFIX}/bin
|
||||
${INSTALL} station_loc ${PREFIX}/bin
|
||||
${INSTALL} dumptqsldata ${PREFIX}/bin
|
||||
|
||||
clean:
|
||||
rm -f converter dumptqsldata gen_crq load_cert station_loc
|
||||
rm -f *.o *.lo *.a *.la *~ xxx.* *.a
|
||||
rm -rf .libs
|
||||
|
||||
%.o: %.cpp
|
||||
${CXX} ${CXXFLAGS} -c -o $@ $*.cpp
|
||||
|
56
comms/trustedqsl/files/Makefile.tqsllib-apps
Normal file
56
comms/trustedqsl/files/Makefile.tqsllib-apps
Normal file
@ -0,0 +1,56 @@
|
||||
TQSLLIB=../tqsllib
|
||||
TQSLINC=../tqsllib
|
||||
OPENSSL=/usr
|
||||
LIBS=-lz -lexpat -lcrypto
|
||||
INCDIR = -I$(TQSLINC)
|
||||
BUILD=unofficial
|
||||
WXFLAGS=`wx-config --cflags`
|
||||
WXLIBS=`wx-config --libs`
|
||||
CXXFLAGS += $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)
|
||||
LDLIBS = -L$(OPENSSL)/lib -L$(TQSLLIB) -ltqsllib $(LIBS) $(WXLIBS)
|
||||
TQSLLIBFILE=$(TQSLLIB)/libtqsllib.a
|
||||
|
||||
BINDIR=${PREFIX}/bin
|
||||
DOCDIR=${PREFIX}/share/doc
|
||||
ETCDIR=${PREFIX}/etc
|
||||
|
||||
TARGETS = tqslcert tqsl
|
||||
|
||||
all: $(TARGETS)
|
||||
|
||||
TQSLCERT_OBJ = tqslcert.o crqwiz.o dxcc.o certtree.o tqslcert_prefs.o \
|
||||
getpassword.o extwizard.o loadcertwiz.o wxutil.o
|
||||
|
||||
TQSL_OBJ = tqsl.o extwizard.o tqslwiz.o dxcc.o stationdial.o qsodatadialog.o \
|
||||
tqslvalidator.o tqsl_prefs.o wxutil.o
|
||||
|
||||
tqslcert: $(TQSLCERT_OBJ) $(TQSLLIBFILE)
|
||||
$(CC) $(CXXFLAGS) $(LDFLAGS) -o $@ $(TQSLCERT_OBJ) $(LDLIBS) -lstdc++
|
||||
|
||||
tqsl: $(TQSL_OBJ) $(TQSLLIBFILE)
|
||||
$(CC) $(CXXFLAGS) $(LDFLAGS) -o $@ $(TQSL_OBJ) $(LDLIBS) -lstdc++
|
||||
|
||||
include apps.depends
|
||||
|
||||
tqslcertbuild.h: buildskel.h
|
||||
cp buildskel.h tqslcertbuild.h
|
||||
|
||||
tqslcert.o:
|
||||
${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
|
||||
|
||||
tqslbuild.h: buildskel.h
|
||||
cp buildskel.h tqslbuild.h
|
||||
|
||||
tqsl.o:
|
||||
${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
|
||||
|
||||
%.o: %.cpp
|
||||
${CXX} $(CXXFLAGS) -c -o $@ $*.cpp
|
||||
|
||||
clean:
|
||||
rm -f $(TARGETS) *.o *.a *~ xxx.*
|
||||
|
||||
install:
|
||||
${INSTALL} -d $(BINDIR) $(ETCDIR)/tqsl
|
||||
${INSTALL} -C $(TARGETS) $(BINDIR)
|
||||
${INSTALL} -C ../tqsllib/config.xml $(ETCDIR)/tqsl
|
31
comms/trustedqsl/files/patch-tqsllib_sysconfig.h
Normal file
31
comms/trustedqsl/files/patch-tqsllib_sysconfig.h
Normal file
@ -0,0 +1,31 @@
|
||||
--- tqsllib/sysconfig.h.orig Wed Jul 21 11:51:59 2004
|
||||
+++ tqsllib/sysconfig.h Wed Jul 21 11:54:05 2004
|
||||
@@ -14,7 +14,7 @@
|
||||
/* #undef TM_IN_SYS_TIME */
|
||||
|
||||
/* Defined if this is LOTW server code */
|
||||
-#define LOTW_SERVER 1
|
||||
+#undef LOTW_SERVER
|
||||
|
||||
/* Define if you have the mkdir function. */
|
||||
#define HAVE_MKDIR 1
|
||||
@@ -29,7 +29,7 @@
|
||||
#define HAVE_UNISTD_H 1
|
||||
|
||||
/* Define if you have the <getopt.h> header file. */
|
||||
-/* #undef HAVE_GETOPT_H */
|
||||
+#define HAVE_GETOPT_H
|
||||
|
||||
/* Define if you have the crypto library (-lcrypto). */
|
||||
#define HAVE_LIBCRYPTO 1
|
||||
@@ -38,8 +38,8 @@
|
||||
#define HAVE_LIBDL 1
|
||||
|
||||
/* Define if you have the pcrl library (-lpcrl). */
|
||||
-#define HAVE_LIBPCRL 1
|
||||
+#undef HAVE_LIBPCRL
|
||||
|
||||
/* Define if you have the sqlca library (-lsqlca). */
|
||||
-#define HAVE_LIBSQLCA 1
|
||||
+#undef HAVE_LIBSQLCA
|
||||
|
10
comms/trustedqsl/pkg-descr
Normal file
10
comms/trustedqsl/pkg-descr
Normal file
@ -0,0 +1,10 @@
|
||||
TrustedQSL
|
||||
|
||||
The mission of the Trusted QSL Group is to keep eQSL an open and free
|
||||
activity for amateur radio operators by promoting the
|
||||
Digital Signature Standard (DSS).
|
||||
|
||||
WWW: http://www.trustedqsl.org
|
||||
|
||||
- Diane
|
||||
db@db.net
|
74
comms/trustedqsl/pkg-plist
Normal file
74
comms/trustedqsl/pkg-plist
Normal file
@ -0,0 +1,74 @@
|
||||
bin/converter
|
||||
bin/dumptqsldata
|
||||
bin/gen_crq
|
||||
bin/load_cert
|
||||
bin/station_loc
|
||||
bin/tqsl
|
||||
bin/tqslcert
|
||||
etc/tqsl/config.xml
|
||||
%%PORTDOCS%%share/doc/tqslapp/addcont.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/addstnl.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/addstnl0.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/adifdial.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/cmdline.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/contents.hhc
|
||||
%%PORTDOCS%%share/doc/tqslapp/daterng.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/daterng.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/glossary.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/main.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-adi.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-adi.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-cab.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-cab.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-opt.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref-opt.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/pref.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/qsodata.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/qsodata.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/savestnl.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/signconf.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/signdone.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/signing.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/stnloc.bmp
|
||||
%%PORTDOCS%%share/doc/tqslapp/stnloc.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/stnloc1.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/stnloc2.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/tqsl.htm
|
||||
%%PORTDOCS%%share/doc/tqslapp/tqslapp.hhp
|
||||
%%PORTDOCS%%share/doc/tqslcert/broken-cert.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/contents.hhc
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq0.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq0.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq1.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq1.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq2.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq2.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq3.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq3.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq4.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/crq4.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/crqsend.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/glossary.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf0.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf0.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf1.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf1.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/lcf2.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/loadcert.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/main.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/newp12pw.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/newpw.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/nocert.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/props.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/save.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/tqsl.htm
|
||||
%%PORTDOCS%%share/doc/tqslcert/tqslcert.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/tqslcert.hhp
|
||||
%%PORTDOCS%%share/doc/tqslcert/unlock.bmp
|
||||
%%PORTDOCS%%share/doc/tqslcert/unlock.htm
|
||||
%%PORTDOCS%%@dirrm share/doc/tqslcert
|
||||
%%PORTDOCS%%@dirrm share/doc/tqslapp
|
||||
@dirrm etc/tqsl
|
Loading…
Reference in New Issue
Block a user