Add gnome-screensaver, a simple screen saver and locker for the GNOME

desktop.  Gnome-screensaver only comes with a few modules of its own, but
can use all of the xscreensaver modules.  This is poised to be the default
screensaver in GNOME 2.14.
This commit is contained in:
Joe Marcus Clarke 2005-11-05 05:03:59 +00:00
parent f7bbf886ef
commit c3ef872f7e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=147263
7 changed files with 134 additions and 0 deletions

View File

@ -61,6 +61,7 @@
SUBDIR += gmrun
SUBDIR += gnome-clipboard-daemon
SUBDIR += gnome-menus
SUBDIR += gnome-screensaver
SUBDIR += gnome-swallow
SUBDIR += gnome2
SUBDIR += gnome2-fifth-toe

View File

@ -0,0 +1,62 @@
# New ports collection makefile for: gnome-screensaver
# Date created: 09 June 2005
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.23 2005/11/03 19:04:24 marcus Exp $
#
PORTNAME= gnome-screensaver
PORTVERSION= 0.0.18
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.0
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME screen saver and locker
LIB_DEPENDS= dbus-1.1:${PORTSDIR}/devel/dbus
RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gnomemenus
CONFIGURE_ARGS= --disable-pam \
--with-gdm-config=${X11BASE}/etc/gdm/gdm.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \
--with-xscreensaverhackdir=${X11BASE}/bin/xscreensaver-hacks
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= gnome-screensaver.schemas
PLIST= ${WRKDIR}/pkg-plist
XSCREENSAVER_DIR= ${X11BASE}/share/xscreensaver/config
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/configure
pre-install:
@${CP} ${.CURDIR}/pkg-plist ${PLIST}
@cd ${XSCREENSAVER_DIR} && ${FIND} -s * -maxdepth 1 -type f -name "*.xml" | \
${SED} -e 's:^:share/gnome/gnome-screensaver/themes/xscreensaver/:' | \
${SED} -e 's:[.]xml$$:.desktop:' >> ${PLIST}
@${ECHO_CMD} @dirrm share/gnome/gnome-screensaver/themes/xscreensaver >> ${PLIST}
@${ECHO_CMD} @dirrm share/gnome/gnome-screensaver/themes >> ${PLIST}
@${ECHO_CMD} @dirrm share/gnome/gnome-screensaver >> ${PLIST}
post-install:
${CHOWN} root ${PREFIX}/libexec/gnome-screensaver-dialog
${CHMOD} +s ${PREFIX}/libexec/gnome-screensaver-dialog
${MKDIR} ${PREFIX}/share/gnome/gnome-screensaver/themes/xscreensaver
cd ${PREFIX}/share/gnome/gnome-screensaver/themes/xscreensaver && \
${FIND} -s ${XSCREENSAVER_DIR} -maxdepth 1 -type f -name "*.xml" | \
${XARGS} ${WRKSRC}/data/migrate-xscreensaver-config.sh
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (gnome-screensaver-0.0.18.tar.bz2) = 56f8d50bd5971a85e25b9f8bf0cdfd2c
SIZE (gnome-screensaver-0.0.18.tar.bz2) = 1811328

View File

@ -0,0 +1,12 @@
--- src/gs-job.c.orig Wed Sep 7 09:23:59 2005
+++ src/gs-job.c Mon Sep 12 13:24:11 2005
@@ -29,7 +29,8 @@
#include <sys/wait.h>
#include <errno.h>
-#if defined(HAVE_SETPRIORITY) && defined(PRIO_PROCESS)
+#if defined(HAVE_SETPRIORITY)
+#include <sys/time.h>
#include <sys/resource.h>
#endif

View File

@ -0,0 +1,7 @@
Gnome-screensaver is GNOME-based screen saver and locker that aims to have
simple, sane, secure defaults and be well integrated with the desktop.
It is designed to support:
* the ability to lock down configuration settings
* translation into other languages
* user switching

View File

@ -0,0 +1,8 @@
**************************************************************************
Gnome-screensaver requires a D-BUS-enabled desktop session. Consult the
FreeBSD GNOME FAQ for instructions on setting up your desktop session
through D-BUS:
http://www.freebsd.org/gnome/docs/faq2.html#q25
**************************************************************************

View File

@ -0,0 +1,42 @@
bin/gnome-screensaver
bin/gnome-screensaver-command
bin/gnome-screensaver-preferences
etc/xdg/menus/gnome-screensavers.menu
libexec/gnome-screensaver-dialog
libexec/gnome-screensaver/popsquares
libexec/gnome-screensaver/slideshow
share/gnome/applications/gnome-screensaver-preferences.desktop
share/gnome/desktop-directories/gnome-screensaver.directory
share/gnome/gnome-screensaver/gnome-screensaver-preferences.glade
share/gnome/gnome-screensaver/themes/cosmos-slideshow.desktop
share/gnome/gnome-screensaver/themes/personal-slideshow.desktop
share/gnome/gnome-screensaver/themes/popsquares.desktop
share/gnome/pixmaps/backgrounds/cosmos/cloud.jpg
share/gnome/pixmaps/backgrounds/cosmos/comet.jpg
share/gnome/pixmaps/backgrounds/cosmos/earth-horizon.jpg
share/gnome/pixmaps/backgrounds/cosmos/earthrise.jpg
share/gnome/pixmaps/backgrounds/cosmos/galaxy-ngc3370.jpg
share/gnome/pixmaps/backgrounds/cosmos/helix-nebula.jpg
share/gnome/pixmaps/backgrounds/cosmos/jupiter.jpg
share/gnome/pixmaps/backgrounds/cosmos/sombrero.jpg
share/gnome/pixmaps/backgrounds/cosmos/whirlpool.jpg
share/locale/bg/LC_MESSAGES/gnome-screensaver.mo
share/locale/cs/LC_MESSAGES/gnome-screensaver.mo
share/locale/de/LC_MESSAGES/gnome-screensaver.mo
share/locale/en_CA/LC_MESSAGES/gnome-screensaver.mo
share/locale/en_GB/LC_MESSAGES/gnome-screensaver.mo
share/locale/es/LC_MESSAGES/gnome-screensaver.mo
share/locale/fi/LC_MESSAGES/gnome-screensaver.mo
share/locale/fr/LC_MESSAGES/gnome-screensaver.mo
share/locale/hu/LC_MESSAGES/gnome-screensaver.mo
share/locale/it/LC_MESSAGES/gnome-screensaver.mo
share/locale/ja/LC_MESSAGES/gnome-screensaver.mo
share/locale/lt/LC_MESSAGES/gnome-screensaver.mo
share/locale/nb/LC_MESSAGES/gnome-screensaver.mo
share/locale/no/LC_MESSAGES/gnome-screensaver.mo
share/locale/pt_BR/LC_MESSAGES/gnome-screensaver.mo
share/locale/sv/LC_MESSAGES/gnome-screensaver.mo
share/locale/uk/LC_MESSAGES/gnome-screensaver.mo
share/locale/zh_CN/LC_MESSAGES/gnome-screensaver.mo
share/locale/zh_TW/LC_MESSAGES/gnome-screensaver.mo
@dirrm libexec/gnome-screensaver