Add webreport 1.5, webReport is a web log statistics program for web
hosting sites. WebReport is a web log statistics reporting program especially designed for virtual web hosting sites. It is also very useful for signle hosting sites. the main difference between WebReport and other statics programs is a configuration file which allows for easy manipulation of the features. WWW: http://www.inter7.com/webreport2.html PR: ports/62904 Submitted by: ismail@enderunix.org
This commit is contained in:
parent
8d6b3d812f
commit
c3ed9d9db4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101216
@ -575,6 +575,7 @@
|
||||
SUBDIR += webglimpse
|
||||
SUBDIR += weblint
|
||||
SUBDIR += webredirect
|
||||
SUBDIR += webreport
|
||||
SUBDIR += webresolve
|
||||
SUBDIR += webstats
|
||||
SUBDIR += webstone
|
||||
|
36
www/webreport/Makefile
Normal file
36
www/webreport/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# New ports collection makefile for: webreport
|
||||
# Date created: 06 Feb 2004
|
||||
# Whom: ismail@enderunix.org
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= webreport
|
||||
PORTVERSION= 1.5
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://www.inter7.com/webreport/
|
||||
|
||||
MAINTAINER= ismail@EnderUNIX.org
|
||||
COMMENT= WebReport is a web log statistics program for web hosting sites
|
||||
|
||||
USE_REINPLACE= yes
|
||||
|
||||
PORTDOCS= INSTALL
|
||||
PLIST_FILES= bin/webreport etc/webreport.conf-dist
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,ulong,unsigned long,;s,/etc/,${PREFIX}/etc/,' ${WRKSRC}/webreport.h
|
||||
|
||||
do-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/webreport ${PREFIX}/bin
|
||||
@${INSTALL_DATA} ${WRKSRC}/webreport.conf ${PREFIX}/etc/webreport.conf-dist
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_MAN} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE} | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g'
|
||||
|
||||
.include <bsd.port.mk>
|
2
www/webreport/distinfo
Normal file
2
www/webreport/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (webreport-1.5.tar.gz) = 53775790be7b62839acfe22d00748b61
|
||||
SIZE (webreport-1.5.tar.gz) = 25501
|
22
www/webreport/files/patch-Makefile
Normal file
22
www/webreport/files/patch-Makefile
Normal file
@ -0,0 +1,22 @@
|
||||
--- Makefile.orig Mon Oct 8 18:09:18 2001
|
||||
+++ Makefile Tue Feb 17 15:22:44 2004
|
||||
@@ -24,8 +24,8 @@
|
||||
DEBUG= -g
|
||||
#OPT= -O2
|
||||
|
||||
-CFLAGS= -c $(OPT) $(DEBUG)
|
||||
-LDFLAGS= $(DEBUG)
|
||||
+CFLAGS+= -c $(OPT)
|
||||
+#LDFLAGS+= $(LDFLAGS)
|
||||
|
||||
.c.o:
|
||||
$(CC) $(CFLAGS) $<
|
||||
@@ -33,6 +33,8 @@
|
||||
BINS = webreport
|
||||
|
||||
OBJ = webreport.o
|
||||
+
|
||||
+all: webreport
|
||||
|
||||
webreport: $(OBJ) webreport.h
|
||||
$(CC) $(LDFLAGS) $(OBJ) -o webreport
|
42
www/webreport/files/patch-webreport.c
Normal file
42
www/webreport/files/patch-webreport.c
Normal file
@ -0,0 +1,42 @@
|
||||
--- webreport.c.org Sat Feb 7 17:06:38 2004
|
||||
+++ webreport.c Sat Feb 7 17:06:47 2004
|
||||
@@ -22,7 +22,7 @@
|
||||
#include <errno.h>
|
||||
#include <string.h>
|
||||
#include <time.h>
|
||||
-#include <getopt.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
@@ -808,7 +808,7 @@
|
||||
}
|
||||
|
||||
char *comma_string_long(in_long )
|
||||
- ulong in_long;
|
||||
+ unsigned long in_long;
|
||||
{
|
||||
char tmpbuf[MAX_TINY_BUF];
|
||||
static char tmpbuf1[MAX_TINY_BUF];
|
||||
@@ -1866,10 +1866,10 @@
|
||||
|
||||
report_open_files()
|
||||
{
|
||||
- strncpy( Globals.TextReportName, "/usr/tmp/webreport.text.XXXXXX", 100);
|
||||
+ strncpy( Globals.TextReportName, "/var/tmp/webreport.text.XXXXXX", 100);
|
||||
mkstemp(Globals.TextReportName);
|
||||
|
||||
- strncpy( Globals.HTMLReportName, "/usr/tmp/webreport.html.XXXXXX", 100);
|
||||
+ strncpy( Globals.HTMLReportName, "/var/tmp/webreport.html.XXXXXX", 100);
|
||||
mkstemp(Globals.HTMLReportName);
|
||||
|
||||
Globals.TextReport = fopen(Globals.TextReportName, "w");
|
||||
@@ -2084,7 +2084,7 @@
|
||||
fputs( Globals.TmpBuf, fs);
|
||||
}
|
||||
} else {
|
||||
- fprintf( Globals.HTMLReport,
|
||||
+ fprintf(Globals.HTMLReport,
|
||||
"Subject: %s\n", Globals.cur_site->title);
|
||||
fprintf( Globals.HTMLReport,
|
||||
"Content-Type: text/html; charset=us-ascii\n");
|
6
www/webreport/pkg-descr
Normal file
6
www/webreport/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
WebReport is a web log statistics reporting program especially designed for
|
||||
virtual web hosting sites. It is also very useful for signle hosting sites.
|
||||
the main difference between WebReport and other statics programs is a
|
||||
configuration file which allows for easy manipulation of the features.
|
||||
|
||||
WWW: http://www.inter7.com/webreport2.html
|
4
www/webreport/pkg-message
Normal file
4
www/webreport/pkg-message
Normal file
@ -0,0 +1,4 @@
|
||||
|
||||
Read the %%PREFIX%%/share/doc/webreport/INSTALL to configure webreport
|
||||
|
||||
Edit the %%PREFIX%%/etc/webreport.conf
|
Loading…
Reference in New Issue
Block a user