Revert the PERL-to-REINPLACE conversion attempts. They were never
finished, despite several related commits, but, most importantly, the port uses PERL anyway... This prevented USB detection -- fixed by this committer in April. Pointy hats available upon request... Make sure __BSD_VISIBLE is defined -- too many of _our headers_ trip over u_int et al without that. Include netinet6/in6.h and force it in by defining what it is looking for. The "official" way of doing it -- simply through the netinet/in.h does not work. May be, there is no __POSIX_VISIBLE in case of __BSD_VISIBLE? Fixes to files/patch-in6 are welcome! The last two fixed compile on -current, justifying this commit without explicit approval. PR: ports/43532 ports/46472 Submitted by: Larry Rosenman, David Magda
This commit is contained in:
parent
171d775e64
commit
c3c62c297a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71847
@ -15,10 +15,9 @@ MAINTAINER= arensb+freebsd-ports@ooblick.com
|
||||
|
||||
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
|
||||
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm
|
||||
USE_PERL= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_REINPLACE= yes
|
||||
REINPLACE_ARGS= -i.bak -E
|
||||
|
||||
# The ColdSync.3 man page describes a Perl package. That's why it goes
|
||||
# in the Perl manpage directory.
|
||||
@ -32,14 +31,15 @@ MANCOMPRESSED= no
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
CONFIGURE_ARGS+= --with-i18n
|
||||
CFLAGS+= -D__BSD_VISIBLE=1
|
||||
CONFIGURE_ARGS+= --with-i18n --disable-pedantic
|
||||
|
||||
# I don't know how to test for a version of {Net,Open}BSD that supports USB.
|
||||
.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 400000
|
||||
CONFIGURE_ARGS+= --with-usb
|
||||
.if ${OSVERSION} >= 450000
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,udi\.(\S+),udi.udi_\1,g;' \
|
||||
${PERL} -pi -e 's,udi\.(\S+),udi.udi_\1,g;' \
|
||||
-e 's,ur\.(\S+),ur.ucr_\1,g;' \
|
||||
${WRKSRC}/configure ${WRKSRC}/libpconn/PConnection_usb.c
|
||||
.endif
|
||||
|
23
palm/coldsync/files/patch-in6
Normal file
23
palm/coldsync/files/patch-in6
Normal file
@ -0,0 +1,23 @@
|
||||
--- libpconn/PConnection_net.c Sun Apr 15 06:33:56 2001
|
||||
+++ libpconn/PConnection_net.c Wed Dec 25 20:09:52 2002
|
||||
@@ -10,5 +10,7 @@
|
||||
#include <string.h> /* For bzero() */
|
||||
#include <arpa/nameser.h> /* Solaris's <resolv.h> requires this */
|
||||
+#ifndef __FreeBSD__ /* resolv.h without in6.h blows up on FreeBSD */
|
||||
#include <resolv.h> /* For inet_ntop() under Solaris */
|
||||
+#endif
|
||||
|
||||
#if HAVE_LIBINTL_H
|
||||
--- src/coldsync.c Tue May 15 15:23:40 2001
|
||||
+++ src/coldsync.c Wed Dec 25 20:12:40 2002
|
||||
@@ -25,5 +25,9 @@
|
||||
|
||||
#include <arpa/nameser.h> /* Solaris's <resolv.h> requires this */
|
||||
+#ifdef __FreeBSD__
|
||||
+#define __KAME_NETINET_IN_H_INCLUDED_
|
||||
+#include <netinet6/in6.h>
|
||||
+#undef __KAME_NETINET_IN_H_INCLUDED_ /* XXX: you are welcome to fix this */
|
||||
-#include <resolv.h> /* For inet_ntop() under Solaris */
|
||||
+#endif
|
||||
#include <unistd.h> /* For sleep(), getopt() */
|
||||
#include <ctype.h> /* For isalpha() and friends */
|
Loading…
Reference in New Issue
Block a user