biology/kallisto: Revert to 0.46.1

0.46.2 has long-standing regressions that are not being addressed, including
a seg fault when using --genomebam.
Also revert to bundled htslib in preparation for biology/htslib upgrade
to 1.10.  Kallisto source contains modified bits of htslib 1.4.1 that are
incompatible with htslib > 1.9.
This commit is contained in:
Jason W. Bacon 2020-08-03 15:45:21 +00:00
parent 52b815fde4
commit c3b030a079
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544077
5 changed files with 32 additions and 60 deletions

View File

@ -2,8 +2,8 @@
PORTNAME= kallisto
DISTVERSIONPREFIX= v
DISTVERSION= 0.46.2
PORTREVISION= 1
DISTVERSION= 0.46.1
PORTEPOCH= 1
CATEGORIES= biology
MAINTAINER= jwb@FreeBSD.org
@ -12,11 +12,11 @@ COMMENT= Quantify abundances of transcripts from RNA-Seq data
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
BUILD_DEPENDS= autoconf>=0:devel/autoconf
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/szip \
libhts.so:biology/htslib
libsz.so:science/szip
USES= cmake:noninja compiler:c++11-lang localbase:ldflags
USES= cmake:noninja compiler:c++11-lang gmake localbase:ldflags
USE_GITHUB= yes
GH_ACCOUNT= pachterlab
@ -26,10 +26,11 @@ PORTEXAMPLES= *
PLIST_FILES= bin/kallisto
EXAMPLES_PLIST_FILES= bin/kallisto-test
# hdf5 is being phased out and is no longer build in by default, but is still
# required for Sleuth and other downstream tools. Remove this after Sleuth
# et all catch up.
CMAKE_ARGS+= -DUSE_HDF5:BOOL=ON
# hdf5 is being phased out and is no longer built in by default, but is still
# required for Sleuth (requires kallisto bootstrap estimates) and other
# downstream tools. Remove this after Sleuth et all catch up.
CMAKE_ARGS+= -DUSE_HDF5:BOOL=ON
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= EXAMPLES

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1581611719
SHA256 (pachterlab-kallisto-v0.46.2_GH0.tar.gz) = 10bab0c2929d8c345750e02735b305bbbfa89e8a48f42c4b9af44f3d44ff4c82
SIZE (pachterlab-kallisto-v0.46.2_GH0.tar.gz) = 2693857
TIMESTAMP = 1595454023
SHA256 (pachterlab-kallisto-v0.46.1_GH0.tar.gz) = 492ef081395e8858fcd9832aceb8b61c79358f00afb45e6709146c0fb51dd231
SIZE (pachterlab-kallisto-v0.46.1_GH0.tar.gz) = 2254560

View File

@ -1,25 +1,11 @@
--- CMakeLists.txt.orig 2018-12-20 14:20:05 UTC
--- CMakeLists.txt.orig 2020-07-22 22:36:50 UTC
+++ CMakeLists.txt
@@ -34,22 +34,6 @@ ELSE(LINK MATCHES shared)
message("shared build")
ENDIF(LINK MATCHES static)
-
-include(ExternalProject)
-ExternalProject_Add(htslib
- PREFIX ${PROJECT_SOURCE_DIR}/ext/htslib
- SOURCE_DIR ${PROJECT_SOURCE_DIR}/ext/htslib
- BUILD_IN_SOURCE 1
- CONFIGURE_COMMAND autoheader && autoconf && ${PROJECT_SOURCE_DIR}/ext/htslib/configure
- --prefix=${PREFIX} --disable-bz2 --disable-lzma --disable-libcurl
@@ -42,7 +42,7 @@ ExternalProject_Add(htslib
BUILD_IN_SOURCE 1
CONFIGURE_COMMAND autoheader && autoconf && ${PROJECT_SOURCE_DIR}/ext/htslib/configure
--prefix=${PREFIX} --disable-bz2 --disable-lzma --disable-libcurl
- BUILD_COMMAND make lib-static
- INSTALL_COMMAND ""
-)
-
-include_directories(${htslib_PREFIX}/src/htslib)
-
-
-
# add_compile_options(-Wdeprecated-register)
+ BUILD_COMMAND gmake lib-static
INSTALL_COMMAND ""
)
add_subdirectory(src)

View File

@ -0,0 +1,11 @@
--- ext/htslib/configure.ac.orig 2019-11-04 16:28:52 UTC
+++ ext/htslib/configure.ac
@@ -23,7 +23,7 @@
# DEALINGS IN THE SOFTWARE.
dnl Process this file with autoconf to produce a configure script
-AC_INIT([HTSlib], m4_esyscmd_s([make print-version]),
+AC_INIT([HTSlib], [1.4.1],
[samtools-help@lists.sourceforge.net], [], [http://www.htslib.org/])
AC_PREREQ(2.63) dnl This version introduced 4-argument AC_CHECK_HEADER
AC_CONFIG_SRCDIR(hts.c)

View File

@ -1,26 +0,0 @@
--- src/CMakeLists.txt.orig 2018-10-17 23:58:22 UTC
+++ src/CMakeLists.txt
@@ -3,15 +3,13 @@ file(GLOB headers *.h *.hpp)
list(REMOVE_ITEM sources main.cpp)
-include_directories(../ext/htslib)
-
add_library(kallisto_core ${sources} ${headers})
target_include_directories(kallisto_core PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})
add_executable(kallisto main.cpp)
find_package( Threads REQUIRED )
-target_link_libraries(kallisto kallisto_core pthread ${CMAKE_CURRENT_SOURCE_DIR}/../ext/htslib/libhts.a)
+target_link_libraries(kallisto kallisto_core pthread hts)
if(LINK MATCHES static)
set(BUILD_SHARED_LIBS OFF)
@@ -56,4 +54,4 @@ else()
endif(LINK MATCHES static)
-install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")
\ No newline at end of file
+install(TARGETS kallisto DESTINATION "${CMAKE_INSTALL_BINDIR}")