x11/libsynaptics: Update to 0.14.6c

Additional port changes:
* Changed to DISTVERSION
* Added LICENSE and LICENSE_FILE
* Added USES=localbase

Reported by:	portscout
Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-02-13 19:15:13 +00:00
parent b1b5502c10
commit c39ab192be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461734
4 changed files with 18 additions and 94 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libsynaptics
PORTVERSION= 0.14.6b
PORTREVISION= 4
DISTVERSION= 0.14.6c
CATEGORIES= x11
MASTER_SITES= http://qsynaptics.sourceforge.net/ \
http://www.hitnet.rwth-aachen.de/~brueffer/distfiles/
@ -11,13 +10,13 @@ MASTER_SITES= http://qsynaptics.sourceforge.net/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to access the Xorg/XFree86 Synaptics TouchPad Driver
USES= libtool tar:bzip2
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= libtool localbase tar:bzip2
GNU_CONFIGURE= yes
USE_XORG= x11
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (libsynaptics-0.14.6b.tar.bz2) = 05fd6d067a735e0534968acdad3276a87b7180f3c118e1cb75301132357c560f
SIZE (libsynaptics-0.14.6b.tar.bz2) = 273936
TIMESTAMP = 1518548190
SHA256 (libsynaptics-0.14.6c.tar.bz2) = 5732c30fd2284da2f5e9ccd8511061846de78896f79c40c46227218ff85df900
SIZE (libsynaptics-0.14.6c.tar.bz2) = 221401

View File

@ -1,86 +1,11 @@
--- pad.cpp.orig Thu Sep 14 13:51:00 2006
+++ pad.cpp Thu Sep 14 13:53:35 2006
@@ -15,12 +15,14 @@
#include "version.h"
#include <X11/Xdefs.h> // for typedef Bool
+#include <sys/types.h>
#include <sys/shm.h>
#include <stdlib.h>
+#include <stdio.h>
#include <unistd.h>
#include <pthread.h>
-static pthread_mutex_t lock;
+static pthread_mutex_t mylock;
#define PAROFF( verId, par ) \
offsetof( SynShm, verId ) + offsetof( ShmSegment##verId, par )
@@ -32,7 +34,7 @@
p.max_val = max;
#define NODRIVERVER VER( 0, 0, 0 )
-#define RETURN( val ) pthread_mutex_unlock( &lock ); return ( val )
+#define RETURN( val ) pthread_mutex_unlock( &mylock ); return ( val )
--- pad.cpp.orig 2018-02-13 19:06:19 UTC
+++ pad.cpp
@@ -9,7 +9,7 @@
// singleton specific code
//
@@ -82,7 +84,7 @@
mSelf = new Synaptics::Pad(); // call constructor
else
{
- pthread_mutex_lock( &lock );
+ pthread_mutex_lock( &mylock );
return;
}
@@ -333,7 +335,7 @@
PadType pt = PT_NONE;
-pthread_mutex_t Synaptics::Pad::mMutex = PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
+pthread_mutex_t Synaptics::Pad::mMutex = PTHREAD_MUTEX_INITIALIZER; // PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP;
// FIXME: detection just based on the assumption that the driver will register as unknown
- if ( mHasShm and mDetectedDriver == DV_UNKNOWN )
+ if ( mHasShm && mDetectedDriver == DV_UNKNOWN )
pt = PT_UNKNOWN;
else
Synaptics::Pad* Synaptics::Pad::getInstance()
{
@@ -368,19 +370,19 @@
{
Param p = mSupportedDriver[ DRIVERSTR ][ param ];
- if ( ( p.type == PT_BOOL ) or ( p.type == PT_BOOL_RO ) )
+ if ( ( p.type == PT_BOOL ) || ( p.type == PT_BOOL_RO ) )
{
rb = *(Bool*)(((char*)mSynShm) + p.offset );
RETURN( rb );
}
- if ( ( p.type == PT_INT ) or ( p.type == PT_INT_RO ) )
+ if ( ( p.type == PT_INT ) || ( p.type == PT_INT_RO ) )
{
ri = *(int*)(((char*)mSynShm) + p.offset );
RETURN( ri );
}
- if ( ( p.type == PT_DOUBLE ) or ( p.type == PT_DOUBLE_RO ) )
+ if ( ( p.type == PT_DOUBLE ) || ( p.type == PT_DOUBLE_RO ) )
{
rd = *(double*)(((char*)mSynShm) + p.offset );
RETURN( rd );
@@ -399,7 +401,7 @@
{
Param p = mSupportedDriver[ DRIVERSTR ][ param ];
- if ( ( p.min_val <= v ) and ( p.max_val >= v ) )
+ if ( ( p.min_val <= v ) && ( p.max_val >= v ) )
{
if ( p.type == PT_BOOL )
(*(Bool*)(((char*)mSynShm) + p.offset)) = (Bool)v;
@@ -414,7 +416,7 @@
}
}
// instead of RETURN(void)
- pthread_mutex_unlock( &lock );
+ pthread_mutex_unlock( &mylock );
}
int Synaptics::Pad::driverVersion()

View File

@ -4,10 +4,9 @@ include/synaptics/Shm_0_14_6
include/synaptics/pad.h
include/synaptics/synaptics.h
include/synaptics/syndebug.h
include/synaptics/synparams.h
include/synaptics/synparam.h
include/synaptics/synshm.h
include/synaptics/version.h
lib/libsynaptics.a
lib/libsynaptics.so
lib/libsynaptics.so.0
lib/libsynaptics.so.0.0.0
lib/libsynaptics.so.0.0.1