Add new port openvpn: Secure IP/Ethernet tunnel daemon

PR:		ports/39750
Submitted by:	Matthias Andree <matthias.andree@web.de>
This commit is contained in:
Patrick Li 2002-06-24 16:13:10 +00:00
parent 66087db901
commit c37c057b2e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61883
22 changed files with 454 additions and 0 deletions

View File

@ -121,6 +121,7 @@
SUBDIR += openssh-askpass
SUBDIR += openssh-portable
SUBDIR += openssl
SUBDIR += openvpn
SUBDIR += outguess
SUBDIR += p5-Authen-Krb4
SUBDIR += p5-Authen-Krb5

View File

@ -0,0 +1,39 @@
# New ports collection makefile for: openvpn
# Date created: 2002-06-23
# Whom: Matthias Andree <matthias.andree@web.de>
#
# $FreeBSD$
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@web.de
LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
--with-lzo-headers=${LOCALBASE}/include \
--program-transform-name="s/x/x/"
MAN8= openvpn.8
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
PORTS README
@${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.for dirs in easy-rsa sample-config-files sample-scripts
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0

View File

@ -0,0 +1,11 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View File

@ -0,0 +1,53 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View File

@ -0,0 +1 @@
Secure IP/Ethernet tunnel daemon

View File

@ -0,0 +1,10 @@
OpenVPN is a robust and highly configurable VPN (Virtual Private
Network) daemon which can be used to securely link two or more private
networks using an encrypted tunnel over the internet. It uses UDP as its
transport, avoiding TCP-over-TCP retransmission congestion. SSL can be
used to authenticate the sites, or they can use a pre-shared secret.
WWW: http://openvpn.sourceforge.net/
- Matthias Andree
matthias.andree@web.de

View File

@ -0,0 +1,36 @@
sbin/openvpn
%%PORTDOCS%%share/doc/openvpn/AUTHORS
%%PORTDOCS%%share/doc/openvpn/COPYING
%%PORTDOCS%%share/doc/openvpn/COPYRIGHT.GPL
%%PORTDOCS%%share/doc/openvpn/ChangeLog
%%PORTDOCS%%share/doc/openvpn/INSTALL
%%PORTDOCS%%share/doc/openvpn/NEWS
%%PORTDOCS%%share/doc/openvpn/PORTS
%%PORTDOCS%%share/doc/openvpn/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-ca
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-dh
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/clean-all
%%PORTDOCS%%share/doc/openvpn/easy-rsa/openssl.cnf
%%PORTDOCS%%share/doc/openvpn/easy-rsa/sign-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/vars
%%PORTDOCS%%share/doc/openvpn/sample-config-files/README
%%PORTDOCS%%share/doc/openvpn/sample-config-files/firewall.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/home.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/office.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-shutdown.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-startup.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-scripts/openvpn.init
%%PORTDOCS%%share/doc/openvpn/sample-scripts/verify-cn
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-scripts
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-config-files
%%PORTDOCS%%@dirrm share/doc/openvpn/easy-rsa
%%PORTDOCS%%@dirrm share/doc/openvpn/

39
security/openvpn/Makefile Normal file
View File

@ -0,0 +1,39 @@
# New ports collection makefile for: openvpn
# Date created: 2002-06-23
# Whom: Matthias Andree <matthias.andree@web.de>
#
# $FreeBSD$
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@web.de
LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
--with-lzo-headers=${LOCALBASE}/include \
--program-transform-name="s/x/x/"
MAN8= openvpn.8
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
PORTS README
@${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.for dirs in easy-rsa sample-config-files sample-scripts
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0

View File

@ -0,0 +1,11 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View File

@ -0,0 +1,53 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View File

@ -0,0 +1 @@
Secure IP/Ethernet tunnel daemon

View File

@ -0,0 +1,10 @@
OpenVPN is a robust and highly configurable VPN (Virtual Private
Network) daemon which can be used to securely link two or more private
networks using an encrypted tunnel over the internet. It uses UDP as its
transport, avoiding TCP-over-TCP retransmission congestion. SSL can be
used to authenticate the sites, or they can use a pre-shared secret.
WWW: http://openvpn.sourceforge.net/
- Matthias Andree
matthias.andree@web.de

View File

@ -0,0 +1,36 @@
sbin/openvpn
%%PORTDOCS%%share/doc/openvpn/AUTHORS
%%PORTDOCS%%share/doc/openvpn/COPYING
%%PORTDOCS%%share/doc/openvpn/COPYRIGHT.GPL
%%PORTDOCS%%share/doc/openvpn/ChangeLog
%%PORTDOCS%%share/doc/openvpn/INSTALL
%%PORTDOCS%%share/doc/openvpn/NEWS
%%PORTDOCS%%share/doc/openvpn/PORTS
%%PORTDOCS%%share/doc/openvpn/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-ca
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-dh
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/clean-all
%%PORTDOCS%%share/doc/openvpn/easy-rsa/openssl.cnf
%%PORTDOCS%%share/doc/openvpn/easy-rsa/sign-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/vars
%%PORTDOCS%%share/doc/openvpn/sample-config-files/README
%%PORTDOCS%%share/doc/openvpn/sample-config-files/firewall.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/home.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/office.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-shutdown.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-startup.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-scripts/openvpn.init
%%PORTDOCS%%share/doc/openvpn/sample-scripts/verify-cn
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-scripts
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-config-files
%%PORTDOCS%%@dirrm share/doc/openvpn/easy-rsa
%%PORTDOCS%%@dirrm share/doc/openvpn/

View File

@ -0,0 +1,39 @@
# New ports collection makefile for: openvpn
# Date created: 2002-06-23
# Whom: Matthias Andree <matthias.andree@web.de>
#
# $FreeBSD$
#
PORTNAME= openvpn
PORTVERSION= 1.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= matthias.andree@web.de
LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
--with-lzo-headers=${LOCALBASE}/include \
--program-transform-name="s/x/x/"
MAN8= openvpn.8
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
PORTS README
@${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.for dirs in easy-rsa sample-config-files sample-scripts
@${MKDIR} ${DOCSDIR}/${dirs}
@${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (openvpn-1.2.1.tar.gz) = 9a41f775bb5045d225483c8a2a9b0ad0

View File

@ -0,0 +1,11 @@
--- error.c.orig Mon Jun 24 02:27:37 2002
+++ error.c Mon Jun 24 02:28:05 2002
@@ -215,7 +215,7 @@
#if defined(HAVE_OPENLOG) && defined(HAVE_SYSLOG)
if (daemon (cd != NULL, 0) < 0)
msg (M_ERR, "daemon() failed");
- openlog ("openvpn", LOG_PID, 0);
+ openlog ("openvpn", LOG_PID, LOG_DAEMON);
#else
msg (M_WARN, "Warning: this operating system lacks daemon logging features, therefore when I become a daemon, I won't be able to log status or error messages");
if (daemon (cd != NULL, 0) < 0)

View File

@ -0,0 +1,53 @@
--- tun.c.orig Sun Jun 23 23:43:57 2002
+++ tun.c Sun Jun 23 23:45:54 2002
@@ -76,7 +76,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "linux ifconfig failed");
+ msg (M_ERR, "Linux ifconfig failed");
#elif defined(TARGET_SOLARIS)
@@ -90,7 +90,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "solaris ifconfig failed");
+ msg (M_ERR, "Solaris ifconfig failed");
#elif defined(TARGET_OPENBSD)
@@ -118,7 +118,7 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "openbsd ifconfig failed");
+ msg (M_ERR, "OpenBSD ifconfig failed");
#elif defined(TARGET_DARWIN)
@@ -144,7 +144,22 @@
);
msg (M_INFO, "%s", command_line);
if (openvpn_system (command_line) != 0)
- msg (M_ERR, "darwin ifconfig failed");
+ msg (M_ERR, "Darwin ifconfig failed");
+
+#elif defined(TARGET_FREEBSD)
+ /* example: ifconfig tun2 10.2.0.2 10.2.0.1 mtu 1450 netmask 255.255.255.255 up */
+ snprintf (command_line, sizeof (command_line),
+ IFCONFIG_PATH " %s %s %s mtu %d netmask 255.255.255.255 up",
+ dev,
+ ifconfig_local,
+ ifconfig_remote,
+ tun_mtu
+ );
+ msg (M_INFO, "%s", command_line);
+ if (openvpn_system (command_line) != 0)
+ msg (M_ERR, "FreeBSD ifconfig failed");
+
+
#else
msg (M_FATAL, "Sorry, but I don't know how to do 'ifconfig' commands on this operating system. You should ifconfig your tun/tap device manually or use an --up script.");

View File

@ -0,0 +1 @@
Secure IP/Ethernet tunnel daemon

View File

@ -0,0 +1,10 @@
OpenVPN is a robust and highly configurable VPN (Virtual Private
Network) daemon which can be used to securely link two or more private
networks using an encrypted tunnel over the internet. It uses UDP as its
transport, avoiding TCP-over-TCP retransmission congestion. SSL can be
used to authenticate the sites, or they can use a pre-shared secret.
WWW: http://openvpn.sourceforge.net/
- Matthias Andree
matthias.andree@web.de

View File

@ -0,0 +1,36 @@
sbin/openvpn
%%PORTDOCS%%share/doc/openvpn/AUTHORS
%%PORTDOCS%%share/doc/openvpn/COPYING
%%PORTDOCS%%share/doc/openvpn/COPYRIGHT.GPL
%%PORTDOCS%%share/doc/openvpn/ChangeLog
%%PORTDOCS%%share/doc/openvpn/INSTALL
%%PORTDOCS%%share/doc/openvpn/NEWS
%%PORTDOCS%%share/doc/openvpn/PORTS
%%PORTDOCS%%share/doc/openvpn/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/README
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-ca
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-dh
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-key-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/build-req-pass
%%PORTDOCS%%share/doc/openvpn/easy-rsa/clean-all
%%PORTDOCS%%share/doc/openvpn/easy-rsa/openssl.cnf
%%PORTDOCS%%share/doc/openvpn/easy-rsa/sign-req
%%PORTDOCS%%share/doc/openvpn/easy-rsa/vars
%%PORTDOCS%%share/doc/openvpn/sample-config-files/README
%%PORTDOCS%%share/doc/openvpn/sample-config-files/firewall.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/home.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/office.up
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-shutdown.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/openvpn-startup.sh
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/static-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-home.conf
%%PORTDOCS%%share/doc/openvpn/sample-config-files/tls-office.conf
%%PORTDOCS%%share/doc/openvpn/sample-scripts/openvpn.init
%%PORTDOCS%%share/doc/openvpn/sample-scripts/verify-cn
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-scripts
%%PORTDOCS%%@dirrm share/doc/openvpn/sample-config-files
%%PORTDOCS%%@dirrm share/doc/openvpn/easy-rsa
%%PORTDOCS%%@dirrm share/doc/openvpn/