cleanup: Remove expired ports:
2022-12-23 math/vtk6: Old version not used anywhere in the ports tree
This commit is contained in:
parent
5f09224333
commit
c376234da6
1
MOVED
1
MOVED
@ -17640,3 +17640,4 @@ net/samba412||2022-12-18|Has expired: Reached its EoL on September 20, 2021
|
||||
graphics/opencoloriov1|graphics/opencolorio|2022-12-20|Used by blender-lts28 which is EOL'd
|
||||
graphics/openimageio-ociov1|graphics/openimageio|2022-12-20|Used by blender-lts28 which is EOL'd
|
||||
textproc/retext|editors/retext|2022-12-21|Moved to a better category
|
||||
math/vtk6||2022-12-24|Has expired: Old version not used anywhere in the ports tree
|
||||
|
@ -1171,7 +1171,6 @@
|
||||
SUBDIR += vinci
|
||||
SUBDIR += visualpolylib
|
||||
SUBDIR += vowpal_wabbit
|
||||
SUBDIR += vtk6
|
||||
SUBDIR += vtk8
|
||||
SUBDIR += vtk9
|
||||
SUBDIR += wavelib
|
||||
|
@ -1,204 +0,0 @@
|
||||
PORTNAME= vtk
|
||||
PORTVERSION= 6.2.0
|
||||
PORTREVISION= 15
|
||||
CATEGORIES= math graphics
|
||||
MASTER_SITES= http://www.vtk.org/files/release/${VTK_SHORT_VER}/
|
||||
PKGNAMESUFFIX= 6
|
||||
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= stephen@FreeBSD.org
|
||||
COMMENT= Visualization toolkit
|
||||
WWW= https://www.vtk.org
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
|
||||
DEPRECATED= Old version not used anywhere in the ports tree
|
||||
EXPIRATION_DATE= 2022-12-23
|
||||
|
||||
LIB_DEPENDS= libtiff.so:graphics/tiff \
|
||||
libpng.so:graphics/png \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libexpat.so:textproc/expat2
|
||||
|
||||
#
|
||||
# TODO
|
||||
# * VTK Groups
|
||||
|
||||
CONFLICTS= vtk8 vtk9
|
||||
USES= alias cmake jpeg localbase xorg
|
||||
USE_LDCONFIG= ${PREFIX}/lib/vtk-${VTK_SHORT_VER}
|
||||
USE_XORG= xt sm ice x11 xext
|
||||
VTK_SHORT_VER= ${PORTVERSION:R}
|
||||
PLIST_SUB+= VER2=${VTK_SHORT_VER}
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/vtk-${VTK_SHORT_VER}
|
||||
DATADIR= ${PREFIX}/share/vtk-${VTK_SHORT_VER}
|
||||
|
||||
# Options
|
||||
OPTIONS_DEFINE= DESIGNER DOCS OSMESA EXAMPLES SHARED QT5
|
||||
OPTIONS_DEFAULT=SHARED
|
||||
#OPTIONS_DEFAULT=MPI Qt JAVA TCLTK DESIGNER
|
||||
OSMESA_DESC= Use Mesa for off-screen rendering
|
||||
DESIGNER_DESC= Build the Qt Designer plugin
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
# Options groups
|
||||
#VTK_GROUPS= Imaging MPI Qt Rendering StandAlone Views
|
||||
VTK_GROUPS= MPI
|
||||
VTK_WRAPS= JAVA TCLTK
|
||||
OPTIONS_GROUP= GROUPS WRAPPING
|
||||
OPTIONS_GROUP_GROUPS=${VTK_GROUPS}
|
||||
OPTIONS_GROUP_WRAPPING=${VTK_WRAPS}
|
||||
GROUPS_DESC= Groups
|
||||
WRAPPING_DESC= Wrapping
|
||||
.for g in ${VTK_GROUPS}
|
||||
$g_DESC= Build the $g group
|
||||
.endfor
|
||||
.for w in ${VTK_WRAPS}
|
||||
$w_DESC= $w wrapping
|
||||
.endfor
|
||||
|
||||
CMAKE_ARGS+= -DVTK_INSTALL_LIBRARY_DIR=lib/vtk-${VTK_SHORT_VER} \
|
||||
-DVTK_INSTALL_ARCHIVE_DIR=lib/vtk-${VTK_SHORT_VER} \
|
||||
-DVTK_INSTALL_NO_DOCUMENTATION=ON \
|
||||
-DVTK_INSTALL_QT_DIR=/${QT_LIBDIR_REL}/plugins/designer \
|
||||
-DVTK_USE_SYSTEM_EXPAT:BOOL=ON \
|
||||
-DVTK_USE_SYSTEM_TIFF:BOOL=ON \
|
||||
-DVTK_USE_SYSTEM_PNG:BOOL=ON \
|
||||
-DVTK_USE_SYSTEM_JPEG:BOOL=ON \
|
||||
-DVTK_USE_SYSTEM_FREETYPE:BOOL=ON \
|
||||
-DVTK_USE_SYSTEM_ZLIB:BOOL=ON \
|
||||
-DSTAGEDIR=${STAGEDIR} \
|
||||
-DModule_vtkTestingCore:BOOL=ON \
|
||||
-DModule_vtkTestingRendering:BOOL=ON \
|
||||
-DVTK_WRAP_PYTHON:BOOL=OFF
|
||||
|
||||
SHARED_CMAKE_ON= -DBUILD_SHARED_LIBS:BOOL=ON
|
||||
SHARED_CMAKE_OFF= -DBUILD_SHARED_LIBS:BOOL=OFF
|
||||
|
||||
# Mangling so that it will build when science/netcdf is installed.
|
||||
post-patch:
|
||||
${MV} ${WRKSRC}/ThirdParty/netcdf/vtknetcdf/include/netcdf.h \
|
||||
${WRKSRC}/ThirdParty/netcdf/vtknetcdf/include/xxxnetcdf.h
|
||||
${FIND} ${WRKSRC}/ThirdParty/netcdf -type f | ${XARGS} ${REINPLACE_CMD} \
|
||||
-E 's/[[:<:]]netcdf\.h[[:>:]]/xxxnetcdf.h/'
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.for g in ${VTK_GROUPS}
|
||||
. if ${PORT_OPTIONS:M${g}}
|
||||
CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=ON
|
||||
. else
|
||||
CMAKE_ARGS+= -DVTK_Group_${g}:BOOL=OFF
|
||||
. endif
|
||||
.endfor
|
||||
|
||||
.if ${PORT_OPTIONS:MOSMESA}
|
||||
LIB_DEPENDS+= libOSMesa.so:graphics/libosmesa
|
||||
CMAKE_ARGS+= -DVTK_OPENGL_HAS_OSMESA:BOOL=ON \
|
||||
-DOSMESA_INCLUDE_DIR:PATH=${LOCALBASE}/include/Mesa \
|
||||
-DOSMESA_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa.so \
|
||||
-DOPENGL_gl_LIBRARY:FILEPATH=${LOCALBASE}/lib/libOSMesa.so \
|
||||
-DVTK_USE_X:BOOL=OFF
|
||||
PLIST_SUB+= X11="@comment " \
|
||||
OSMESA=""
|
||||
.else
|
||||
USES+= gl
|
||||
USE_GL= gl glu
|
||||
PLIST_SUB+= X11="" \
|
||||
OSMESA="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MEXAMPLES}
|
||||
CMAKE_ARGS+= -DBUILD_EXAMPLES:BOOL=ON
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMPI}
|
||||
LIB_DEPENDS+= libmpi.so:net/openmpi3
|
||||
CMAKE_ARGS+= -DMPIEXEC=${LOCALBASE}/mpi/openmpi3/bin/mpiexec
|
||||
PLIST_SUB+= MPI=""
|
||||
.else
|
||||
PLIST_SUB+= MPI="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MQT5}
|
||||
USES+= qt:5
|
||||
USE_QT= gui:build gui:run network:build network:run sql:build sql:run \
|
||||
qmake:build opengl webkit:build buildtools webkit:run
|
||||
CMAKE_ARGS+= -DVTK_QT_VERSION:STRING="5" \
|
||||
-DCMAKE_PREFIX_PATH:STRING=${LOCALBASE}/lib/qt5
|
||||
PLIST_SUB+= QTV="qt5"
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MQT5}
|
||||
CMAKE_ARGS+= -DVTK_Group_Qt:BOOL=ON
|
||||
PLIST_SUB+= QT=""
|
||||
.else
|
||||
PLIST_SUB+= QT="@comment "
|
||||
CMAKE_ARGS+= -DVTK_Group_Qt:BOOL=OFF
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDESIGNER}
|
||||
.if ${PORT_OPTIONS:MQT5}
|
||||
USE_QT+= designer
|
||||
.else
|
||||
IGNORE= designer requires QT5
|
||||
.endif
|
||||
PLIST_SUB+= DESIGNER=""
|
||||
CMAKE_ARGS+= -DQT_DESIGNER_PLUGIN:BOOL=ON
|
||||
.else
|
||||
PLIST_SUB+= DESIGNER="@comment "
|
||||
CMAKE_ARGS+= -DQT_DESIGNER_PLUGIN:BOOL=OFF
|
||||
.endif
|
||||
|
||||
# Wrapping
|
||||
.if ${PORT_OPTIONS:MJAVA}
|
||||
CATEGORIES+= java
|
||||
USE_JAVA= yes
|
||||
CMAKE_ARGS+= -DVTK_WRAP_JAVA:BOOL=ON \
|
||||
-DJAVA_INCLUDE_PATH:PATH=${JAVA_HOME}/include \
|
||||
-DJAVA_AWT_LIBRARY:PATH=${JAVA_HOME}/jre/lib/${ARCH}/libjawt.so \
|
||||
-DJAVA_JVM_LIBRARY:PATH=${JAVA_HOME}/jre/lib/${ATCH}/libjava.so
|
||||
PLIST_SUB+= JAVA=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DVTK_WRAP_JAVA:BOOL=OFF \
|
||||
-DModule_vtkWrappingJava:BOOL=OFF
|
||||
PLIST_SUB+= JAVA="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MTCLTK}
|
||||
USES+= tk
|
||||
CMAKE_ARGS+= -DVTK_WRAP_TCL:BOOL=ON \
|
||||
-DVTK_Group_Tk:BOOL=ON \
|
||||
-DTCL_INCLUDE_PATH:PATH=${TCL_INCLUDEDIR} \
|
||||
-DTK_INCLUDE_PATH:PATH=${TK_INCLUDEDIR} \
|
||||
-DVTK_INSTALL_TCL_DIR=lib/vtk-${VTK_SHORT_VER}
|
||||
PLIST_SUB+= TCLTK=""
|
||||
.else
|
||||
CMAKE_ARGS+= -DVTK_WRAP_TCL:BOOL=OFF \
|
||||
-DVTK_Group_Tk:BOOL=OFF
|
||||
PLIST_SUB+= TCLTK="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MJAVA} || ${PORT_OPTIONS:MTCLTK}
|
||||
PLIST_SUB+= WRAP=""
|
||||
.else
|
||||
PLIST_SUB+= WRAP="@comment "
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=ON
|
||||
BUILD_DEPENDS+= doxygen:devel/doxygen
|
||||
USES+= perl5
|
||||
USE_PERL5+= build
|
||||
.else
|
||||
CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=OFF
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
|
||||
CXXFLAGS+= -mminimal-toc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (VTK-6.2.0.tar.gz) = efa3ddfba118f3988ead08bdaf9441d33f23a4245d78511a6ce7f267b4f13277
|
||||
SIZE (VTK-6.2.0.tar.gz) = 30114472
|
@ -1,11 +0,0 @@
|
||||
--- Examples/GUI/Qt/GraphicsView/CMakeLists.txt.orig 2014-03-10 16:31:13.000000000 +0100
|
||||
+++ Examples/GUI/Qt/GraphicsView/CMakeLists.txt 2014-03-10 16:31:19.000000000 +0100
|
||||
@@ -60,7 +60,7 @@
|
||||
add_executable(qtgraphicsview MACOSX_BUNDLE
|
||||
${Srcs} ${Hdrs} ${MOC_Hdrs} ${QRC_Srcs})
|
||||
qt5_use_modules(qtgraphicsview Core Gui Widgets
|
||||
- WebKit WebKitWidgets OpenGL OpenGLExtensions)
|
||||
+ WebKit WebKitWidgets OpenGL)
|
||||
target_link_libraries(qtgraphicsview ${VTK_LIBRARIES})
|
||||
else()
|
||||
find_package(Qt4 REQUIRED)
|
@ -1,31 +0,0 @@
|
||||
--- GUISupport/Qt/CMakeLists.txt.orig 2015-03-03 14:37:14.000000000 -0600
|
||||
+++ GUISupport/Qt/CMakeLists.txt 2015-11-25 17:08:37.840001000 -0600
|
||||
@@ -104,7 +104,7 @@
|
||||
endif()
|
||||
|
||||
# This build plugin logic should just get migrated into a module I think.
|
||||
-if(BUILD_SHARED_LIBS)
|
||||
+if(BUILD_SHARED_LIBS AND QT_DESIGNER_PLUGIN)
|
||||
set(PluginLibSrcs Q4VTKWidgetPlugin.cxx)
|
||||
|
||||
set(PluginMocHeaders Q4VTKWidgetPlugin.h)
|
||||
@@ -124,16 +124,16 @@
|
||||
|
||||
# add QVTK plugin from sources
|
||||
# stand-alone as it doesn't depend on QVTK library
|
||||
- add_library(QVTKWidgetPlugin
|
||||
+ add_library(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION}
|
||||
SHARED
|
||||
${PluginLibSrcs}
|
||||
${PluginMocSrcs}
|
||||
)
|
||||
|
||||
- set_target_properties(QVTKWidgetPlugin PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
|
||||
+ set_target_properties(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} PROPERTIES COMPILE_DEFINITIONS QT_NO_DEBUG)
|
||||
|
||||
# link with Qt libs
|
||||
- vtk_module_link_libraries(QVTKWidgetPlugin ${QT_LIBRARIES})
|
||||
+ vtk_module_link_libraries(QVTKWidgetPlugin-${VTK_MAJOR_VERSION}.${VTK_MINOR_VERSION} ${QT_LIBRARIES})
|
||||
|
||||
# install rules
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- GUISupport/Qt/PluginInstall.cmake.in.orig 2013-06-12 21:47:10.000000000 +0200
|
||||
+++ GUISupport/Qt/PluginInstall.cmake.in 2013-09-13 12:06:53.000000000 +0200
|
||||
@@ -2,7 +2,7 @@
|
||||
SET(VTK_LIB_DIR "@CMAKE_LIBRARY_OUTPUT_DIRECTORY@")
|
||||
SET(VTK_INSTALL_QT_DIR "@VTK_INSTALL_QT_DIR@")
|
||||
SET(VTK_INSTALL_QT_PLUGIN_DIR "@VTK_INSTALL_QT_PLUGIN_DIR@")
|
||||
-SET(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin@CMAKE_SHARED_LIBRARY_SUFFIX@")
|
||||
+SET(VTK_INSTALL_QT_PLUGIN_FILE "@CMAKE_SHARED_LIBRARY_PREFIX@QVTKWidgetPlugin-@VTK_MAJOR_VERSION@.@VTK_MINOR_VERSION@@CMAKE_SHARED_LIBRARY_SUFFIX@")
|
||||
SET(VTK_CONFIGURATIONS "@CMAKE_CONFIGURATION_TYPES@")
|
||||
|
||||
IF(VTK_CONFIGURATIONS)
|
@ -1,11 +0,0 @@
|
||||
--- Rendering/FreeType/vtkFreeTypeTools.cxx.orig 2020-10-26 19:28:43 UTC
|
||||
+++ Rendering/FreeType/vtkFreeTypeTools.cxx
|
||||
@@ -280,7 +280,7 @@ FTC_CMapCache* vtkFreeTypeTools::GetCMapCache()
|
||||
}
|
||||
|
||||
//----------------------------------------------------------------------------
|
||||
-FT_CALLBACK_DEF(FT_Error)
|
||||
+static FT_Error
|
||||
vtkFreeTypeToolsFaceRequester(FTC_FaceID face_id,
|
||||
FT_Library lib,
|
||||
FT_Pointer request_data,
|
@ -1,11 +0,0 @@
|
||||
--- Rendering/FreeType/vtkFreeTypeUtilities.cxx.orig 2020-10-26 19:35:51 UTC
|
||||
+++ Rendering/FreeType/vtkFreeTypeUtilities.cxx
|
||||
@@ -325,7 +325,7 @@ void vtkFreeTypeUtilities::MapIdToTextProperty(unsigne
|
||||
|
||||
//----------------------------------------------------------------------------
|
||||
#ifdef VTK_FREETYPE_CACHING_SUPPORTED
|
||||
-FT_CALLBACK_DEF(FT_Error)
|
||||
+static FT_Error
|
||||
vtkFreeTypeUtilitiesFaceRequester(FTC_FaceID face_id,
|
||||
FT_Library lib,
|
||||
FT_Pointer request_data,
|
@ -1,40 +0,0 @@
|
||||
--- Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx.orig 2015-03-03 20:37:14 UTC
|
||||
+++ Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx
|
||||
@@ -386,7 +386,7 @@ XVisualInfo *vtkXOpenGLRenderWindow::Get
|
||||
|
||||
vtkXOpenGLRenderWindow::vtkXOpenGLRenderWindow()
|
||||
{
|
||||
- this->ParentId = static_cast<Window>(NULL);
|
||||
+ this->ParentId = static_cast<Window>(0);
|
||||
this->ScreenSize[0] = 0;
|
||||
this->ScreenSize[1] = 0;
|
||||
this->OwnDisplay = 0;
|
||||
@@ -394,8 +394,8 @@ vtkXOpenGLRenderWindow::vtkXOpenGLRender
|
||||
this->ForceMakeCurrent = 0;
|
||||
this->UsingHardware = 0;
|
||||
this->DisplayId = static_cast<Display *>(NULL);
|
||||
- this->WindowId = static_cast<Window>(NULL);
|
||||
- this->NextWindowId = static_cast<Window>(NULL);
|
||||
+ this->WindowId = static_cast<Window>(0);
|
||||
+ this->NextWindowId = static_cast<Window>(0);
|
||||
this->ColorMap = static_cast<Colormap>(0);
|
||||
this->OwnWindow = 0;
|
||||
|
||||
@@ -776,7 +776,7 @@ void vtkXOpenGLRenderWindow::DestroyWind
|
||||
if (this->OwnWindow && this->DisplayId && this->WindowId)
|
||||
{
|
||||
XDestroyWindow(this->DisplayId,this->WindowId);
|
||||
- this->WindowId = static_cast<Window>(NULL);
|
||||
+ this->WindowId = static_cast<Window>(0);
|
||||
}
|
||||
|
||||
// if we create the display, we'll delete it
|
||||
@@ -1168,7 +1168,7 @@ void vtkXOpenGLRenderWindow::WindowRemap
|
||||
|
||||
// set the default windowid
|
||||
this->WindowId = this->NextWindowId;
|
||||
- this->NextWindowId = static_cast<Window>(NULL);
|
||||
+ this->NextWindowId = static_cast<Window>(0);
|
||||
|
||||
// set everything up again
|
||||
this->Initialize();
|
@ -1,25 +0,0 @@
|
||||
--- ThirdParty/verdict/vtkverdict/CMakeLists.txt.orig 2013-06-26 09:41:53.000000000 +0200
|
||||
+++ ThirdParty/verdict/vtkverdict/CMakeLists.txt 2013-06-26 09:42:13.000000000 +0200
|
||||
@@ -117,14 +117,14 @@
|
||||
# Installation stuff
|
||||
#
|
||||
IF(NOT verdict_INSTALL_NO_DEVELOPMENT)
|
||||
- install(FILES
|
||||
- README
|
||||
- Verdict.htm
|
||||
- Verdict.doc
|
||||
- verdict_test.cpp
|
||||
- DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
|
||||
- COMPONENT Development
|
||||
- )
|
||||
+# install(FILES
|
||||
+# README
|
||||
+# Verdict.htm
|
||||
+# Verdict.doc
|
||||
+# verdict_test.cpp
|
||||
+# DESTINATION ${verdict_INSTALL_DOC_DIR}/verdict/${verdict_VERSION}/
|
||||
+# COMPONENT Development
|
||||
+# )
|
||||
|
||||
install(
|
||||
FILES ${verdict_BINARY_DIR}/verdict.h
|
@ -1,16 +0,0 @@
|
||||
So that this port doesn't clash with science/paraview:
|
||||
|
||||
--- ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake.orig 2017-01-20 17:51:20 UTC
|
||||
+++ ThirdParty/hdf5/vtkhdf5/CMakeInstallation.cmake
|
||||
@@ -105,11 +105,6 @@ configure_file (
|
||||
${HDF5_RESOURCES_DIR}/libhdf5.settings.cmake.in
|
||||
${HDF5_BINARY_DIR}/libhdf5.settings @ONLY
|
||||
)
|
||||
-install (
|
||||
- FILES ${HDF5_BINARY_DIR}/libhdf5.settings
|
||||
- DESTINATION ${HDF5_INSTALL_CMAKE_DIR}/${HDF5_PACKAGE}
|
||||
- COMPONENT libraries
|
||||
-)
|
||||
|
||||
#-----------------------------------------------------------------------------
|
||||
# Configure the HDF518_Examples.cmake file and the examples
|
@ -1,11 +0,0 @@
|
||||
--- Wrapping/Tcl/CMakeLists.txt.orig 2015-03-03 14:37:14.000000000 -0600
|
||||
+++ Wrapping/Tcl/CMakeLists.txt 2015-11-25 17:33:43.838696000 -0600
|
||||
@@ -264,7 +264,7 @@
|
||||
# Configure the Tcl package index file for the install tree.
|
||||
SET(VTK_TCL_SCRIPT_DIR "[file dirname [info script]]")
|
||||
IF(UNIX)
|
||||
- SET(VTK_TCL_LIBRARY_DIR "[file dirname [file dirname [file dirname [info script]]]]")
|
||||
+ SET(VTK_TCL_LIBRARY_DIR "[file dirname [info script]]")
|
||||
ELSE()
|
||||
SET(VTK_TCL_LIBRARY_DIR
|
||||
"[file join [file dirname [file dirname [file dirname [file dirname [info script]]]]] bin]")
|
@ -1,12 +0,0 @@
|
||||
The Visualization Toolkit (VTK) is an open-source, freely available software
|
||||
system for 3D computer graphics, image processing and visualization. VTK
|
||||
consists of a C++ class library and several interpreted interface layers
|
||||
including Tcl/Tk, Java, and Python. Kitware, whose team created and continues
|
||||
to extend the toolkit, offers professional support and consulting services for
|
||||
VTK. VTK supports a wide variety of visualization algorithms including: scalar,
|
||||
vector, tensor, texture, and volumetric methods; and advanced modeling
|
||||
techniques such as: implicit modeling, polygon reduction, mesh smoothing,
|
||||
cutting, contouring, and Delaunay triangulation. VTK has an extensive
|
||||
information visualization framework, has a suite of 3D interaction widgets,
|
||||
supports parallel processing, and integrates with various databases on GUI
|
||||
toolkits such as Qt and Tk.
|
3679
math/vtk6/pkg-plist
3679
math/vtk6/pkg-plist
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user